Sign in with
Sign up | Sign in
Your question

PC Slow to shut off when shutting down (raid 1)

Last response: in Windows 7
Share
October 8, 2011 10:13:13 PM

I have no idea why this is happening, and I've dealt with it for too long now.

Whenever I shutdown my pc (Windows 7 x64), the actual shutdown screen goes away in a reasonable amount of time, but my PC takes about another 8-10 minutes to shut off. Yes, that is 8-10 minutes to shut off. What is it doing during this time? The video signal to the monitor is shut off after the windows screen goes away, but my computers continues to do something for a long time before it will finally turn off.

I've never had this happen before on any of my pc builds (yes, this is completely custom), and it's been happening for over a year now, but it ONLY started once I set up a RAID 1 configuration. My boot drive is NOT on that RAID system. I have my boot drive on a separate disk (C drive) and two other 750GB disks are configured in RAID 1 (mirroring) for my storage drive. It uses the Intel Matrix Storage.

I should also note that this does not happen when rebooting, only when shutting down.

My setup is:

Mobo - Gigabyte P35-DS3R
RAM - 8GB 1033 RAM
Windows 7 x64 SP1
Primary Drive (Boot) - 640 GB Western Digital
Secondary Drives in RAID 1 - 750 GB Western Digital
RAID - Intel Storage Matrix Manager


One thing I will say is that my DVD-Rom drive slowly flashes it's light over and over while the hard disks are doing something, but after Windows has (seemly) shut down (no video feed to monitor). I don't think this has anything to do with it, because again, it only started once I put in a RAID configuration.

I didn't know if this should go in the Windows forum or somewhere else, because I really don't know the source of the problem. Please move it if needed.

Any ideas/help would be greatly appreciated.
a b $ Windows 7
October 8, 2011 10:36:16 PM

Make sure, that you are not clearing the "page file" at shutdown. Tell me the value? Is it 0?

It still takes way to long... BTW, do u have a Ramdisc?

Start>Run>Regedit
Registry Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
Modify/Create the Value Data Type(s) and Value Name(s) as detailed below.
Data Type: REG_DWORD [Dword Value] // Value Name: ClearPageFileAtShutdown
Setting for Value Data: [0 = Clear Page File Disabled / 1 = Clear Page File Enabled]
October 8, 2011 10:52:57 PM

nikorr said:
Make sure, that you are not clearing the "page file" at shutdown. Tell me the value? Is it 0?

It still takes way to long... BTW, do u have a Ramdisc?

Start>Run>Regedit
Registry Key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management
Modify/Create the Value Data Type(s) and Value Name(s) as detailed below.
Data Type: REG_DWORD [Dword Value] // Value Name: ClearPageFileAtShutdown
Setting for Value Data: [0 = Clear Page File Disabled / 1 = Clear Page File Enabled]


Unfortunately, that didn't seem to do anything at all. I tried it just last night. Verified just now that the value is indeed 0.
!