Sign in with
Sign up | Sign in
Your question

AC97 audio not working under Win7 64-bit

Last response: in Components
Share
January 22, 2010 6:39:38 AM

Hi all - I've installed Win7 64 bit and so far the only hurdle I've come across is with the sound drivers.

The AC97 is built into the motherboard (Abit IX48GT3). Before I continue its worth saying that Abit seemingly do not have Win7 drivers for this motherboard.

Microsoft drivers ARE installed for the sound card but the only device listed is the S/PDIF interface. I have my amp plugged into the 3.5mm stereo jack on the rear panel (which works fine under XP incidentally). SO there is no sound to my amp.

I have tried looking at the Reaktek website and I found Vista/Win7 drivers which I downloaded, but when I install it under Win7 I'm give the warning that the drivers are unsigned and so I click 'continue anyway' ... but then it gives another warning ... I click 'continue anyway'... and so on until I've clicked the damned thing 15+ times and it seems to be stuck in a loop.

Any advice will be appreciated on this, AC97 just shouldn't be an issue...

Thanks
January 22, 2010 2:29:58 PM

Win 7 does not use AC'97.
Download the HD audio driver for your device and you should be fine, although A-bit is exiting the motherboard market and you have noted yourself that board does not have Win 7 Support.
Try using Vista 64bit drivers for it, I have found on occasion that they work just fine in Win 7 when you cannot find an alternative.

Other than that why not upgrade your sound card. If you have it hooked up to an AMP surely you want good quality audio.
January 22, 2010 2:33:34 PM

Thanks.

I find the audio quality okay, not scratchy, and I have an active sub attached too.
Related resources
a b \ Driver
a c 95 V Motherboard
January 22, 2010 5:43:30 PM

W7 does use AC97, just installed W7x86 on a old Dell 2400 and it installed Intel AC97 drivers via Windows Update and sound is fine.
January 22, 2010 7:38:38 PM

Good to know that you install is okay.
January 23, 2010 2:27:12 PM

Just another thought........you may have already tried this, but..

I know you already have Win 7 installed, so not sure if this will run or not, but they came out with a very handy tool that scans your entire system and tells you any compatibility issues with Win 7, and often what you can do about them.

Here's the link.....I found it quite useful for my own upgrade.

http://www.microsoft.com/downloads/details.aspx?FamilyI...


..hope this helps...
January 23, 2010 9:40:35 PM

Thanks!

PS - I ordered a great sound card today, Sound Blaster Audigy 4 Pro...
March 7, 2010 9:33:22 AM

plasmastorm said:
Win 7 does not use AC'97.
Download the HD audio driver for your device and you should be fine, although A-bit is exiting the motherboard market and you have noted yourself that board does not have Win 7 Support.
Try using Vista 64bit drivers for it, I have found on occasion that they work just fine in Win 7 when you cannot find an alternative.

Other than that why not upgrade your sound card. If you have it hooked up to an AMP surely you want good quality audio.



Where can I find this HD audio driver?

!