Sign in with
Sign up | Sign in
Your question

Why doesn't my ssd preform as fast as it should?

Last response: in Storage
September 28, 2011 9:15:28 PM

I just built a new PC and put a Plextor PX-M2 Series PX-128M2S 2.5" 128GB SATA III Internal Solid State Drive (SSD) in it. I ran a bench mark test and the write speed was the speed the manufacturer specified but the read speed wasn't. The read speed specified is up to 420mb/s with sata 3 which I am using but its only running at 300mb/s. I'm not sure what other factors determine the speed of the drive. Can anyone give me any info?

More about : ssd preform fast

a c 504 G Storage
September 28, 2011 11:15:24 PM

What's the make & model of your motherboard?
a c 415 G Storage
September 28, 2011 11:51:15 PM

300MByte/sec is the maximum bandwidth of a SATA-II connection, so the obvious question to ask is: do you have the drive plugged into a SATA-II port instead of a SATA-III port?

Also, don't forget that SSDs really shine because of their very fast access times, more so than because of their transfer rates. So if it turns out that you don't have a SATA-III port to plug your drive into then don't sweat it too much - you're still getting most of the performance improvement that the drive is capable of.
Related resources
September 29, 2011 12:29:35 AM

There is the link for the motherboard. It is not plugged into a sata II port because it doesn't have any. I did run another bench mark and it was up to 350mb/s. I did just OC the CPU from 3.2 to 3.6ghz but I don't know if that made any difference.
a c 504 G Storage
September 29, 2011 12:51:54 AM

Yes, you should be getting close to the maximum advertised speeds of your drive with that motherboard.

Was the SATA port your SSD is connected to in AHCI mode when you installed your O/S?
September 29, 2011 2:13:56 AM

I'm not sure. How do I check?
a c 415 G Storage
September 29, 2011 4:10:43 AM

Many drives have a jumper that forces them to SATA-II mode in case they run into any compatibility issues with SATA-II ports. It would be worth checking to see if you drive has such a jumper and, if so, that it's not set.
September 29, 2011 2:53:19 PM

Ok I'll checked today.
a c 351 G Storage
September 29, 2011 3:08:24 PM

(1) Down load and run AS SSD. Don't need to run the benchmark. Look at the upper left. It should show what driver is being used. Will also show/verify that partition alaingment os "OK". Should also show Firmware version.

(2) Verify that the SSD has the latest Firmware version (Check plextor support website) for latest Firmware. My Curcaial M4 is very simular and they recently came out with a new firmware that improved performance.

(3) Most benchmarks are performed using a Intel chipset, there may be a small performace diff between your chipset and the latest Intel ver 10.6 chipset driver.

Screen shot of My M4 using AS SSD

(4) As sminlal indicated, do not pay to much attention to Sequencial read/writes as this is the LEAST important paramenter for a OS+Program SSD. The small file random 4 k is by fare more important. Also Unless you use the same benchmark as the one you are referencing against, the comparision may not be valid. The most often quoted benchmark scores are use data that can be compressed - Real life the data does NOT compress much.
September 29, 2011 10:51:35 PM

I ran AS SSD and it says the pciide is bad. What does that mean?
a c 504 G Storage
September 29, 2011 11:12:03 PM

kogo50 said:
I ran AS SSD and it says the pciide is bad. What does that mean?

"pciide" means that your drive is in IDE mode. "Bad" means that your drive is not aligned properly. Improper alignment usually occurs when a disk copy or image restore is done incorrectly.

Your drive needs to be in AHCI mode and it needs to be aligned properly for maximum performance.

I suggest you back up any needed files and do a fresh install of Windows with the drive in AHCI mode.
a c 351 G Storage
September 30, 2011 3:29:42 AM

^ The "BAD" refers to the pcide controller.
When the Windows was installed on the SSD the bios apparently was in IDE mode.

SSDs perform poorly when in IDE mode. Need to switch to ahci.
basiclly: You must enable the ahci in the registry, reboot, go to bios and set to ahci.
September 30, 2011 3:13:15 PM

Ok I followed RetiredChief's link and then change the setting in the bios. I ran AS SSD again and now it says msachi - ok. Also the score is better than it was. The first test was around 274. Then new one is 317.
a c 351 G Storage
September 30, 2011 3:30:22 PM

That is only about 15% improvement. Your plextor should perform simular to my M4 and your over all score is way lower than my 774.
The diff is that I'm on a Intel Chipset and using the Intel iaSTor driver (Ver 10.6). You might need to download and install AMDs equivalnt to Intels RST driver for your chipset.

I think the latest "AMD" ahci driver is 11.8 (dtd 8/17/11). I'm NOT an AMD guy so verify this is the corect version.