Sign in with
Sign up | Sign in
Your question

Ide channel 1 slave cd-rom and ide channel 2 master hdd

Last response: in Storage
Share
September 29, 2011 1:03:34 PM

Right heres my problem, my friend sold me this PC because he just got a new one, it was working fine. I brought it home and started it up and i got an error saying A Disk Read Error Occured please prest ctrl alt del and restart. I then found out the hdd had the click of death, so i bought a new one (sata 160gb) plugged it in the next day and the error went but! I received a new one saying Disk Boot Failure Insert System Disk And Press Enter. So i have played around with the settings and it still wont work... i even got a xp disk put it in an it seems like its not reading the disk? But the light it on for the Cd-Rom drive.

Now my HDD is Sata like i said but my CD-ROM Drive has the IDE Cable, now i have enabled S.m.a.r.t because it said it was disabled, i have changed aorund the boot order so many times... But it obv wont boot from HDD because it will have no data on there as it is new... and it wont read any disk's... The next thing i was wondering is that can you have 2 master channels E.G Channel 1 Master - CD-ROM
Channel 2 Master - None
Channel 3 Master - HDD So i played around and changed it to IDE Channel 1 Slave
IDE Channel 2 Master ?? I coudlnt work out how to make the HDD which is channel 2 to go to channel 1 so there would be a master and a slave? Please help me :(  i am only 17 and im doing a course at college for computing and now this has really downed me in computing not knowing how to fix this issue. Thanks
a b G Storage
September 29, 2011 1:18:47 PM

There is no master/slave for SATA. If the IDE drive was master, you need to change the optical drive to master. I'd remove the dead IDE. Change the optical drive to master and put it on the farthest connecter on the IDE cable.
September 29, 2011 1:27:02 PM

okay right i done that now when i look i see this
IDE Channel 0 Master [none]
IDE Channel 0 Slave [none]
IDE Channel 1 Master [BENQ CD-ROM 652]
IDE Channel 1 Slave [none]
IDE Channel 2 Master [Maxtor 6V160E0]
Related resources
September 29, 2011 1:28:22 PM

I still get the error by the way, this is what my settings were on before.
a b G Storage
September 29, 2011 3:30:56 PM

What motherboard do you have?

Don't worry about having the channel 0, channel 1, channel 2, etc. This simply means you have your SATA ports mapped as IDE. This is fine as it means you don't have to worry about SATA drivers while installing windows.

Looking at the list I see your optical drive is master on the secondary IDE, while the SATA hdd is on the SATA port. This *should* work, I'm not sure why it isn't. Just in case its some odd bios thing, move the optical drive over to the primary IDE. I'm guessing that it wants a boot option on the primary master.

Another thought, if the board is old enough to have 2 IDE ports, then it might not support SATA II. Make sure the jumper on the hdd is set to SATA I operation.
September 29, 2011 4:03:03 PM

Okay how do i move it over to the primary IDE? Its a very old board erm its a WINFAST 760GXK8MC Thats all i can tell by reading it on the motherboard, some people say maybe i need to update my bios but... i cant update it as my cd-rom isnt working :(  and okay ill check the sata 1 now
September 29, 2011 4:03:53 PM

it is sata 1 :) 
a b G Storage
September 30, 2011 12:38:29 AM

Moving it over is easy. Unplug it from the IDE port its in now and move it to the other one.

If you have SATA, did you jumper it for SATA I operation?
September 30, 2011 8:54:29 AM

okay yes its in a blue one now ill put it in the other (white) IDE port and yes the sata one is in operation1 it was in the first place, by the way thanks for helping me i really appreciate it just hopefully we can fix this fault. Nope still comes up! :( 
September 30, 2011 8:55:13 AM

Now it says the CD-ROM is in IDE Channel 0 Master
a b G Storage
September 30, 2011 10:08:33 AM

Bummer. I was hoping the BIOS was looking for a bootable device on that port/channel.

I don't see where you said you jumpered the hdd for SATA I operation.
!