Sign in with
Sign up | Sign in
Your question

Error while copying data I/O device error

Last response: in Storage
Share
September 30, 2011 6:13:15 AM

Hello,
I have a 2 TB external HDD in which only 30 to 35 GB data is present at the moment. But when i am copying any large file say around 1.5 GB or more to same HDD but in different folder or in my local drives it is giving me I/O device error and i am getting blocked on this. I tried running chkdsk /r on my external HDD drive but it doesn't move on? I want to know how much time chkdsk /r will take approx to complete on 2TB HDD? Also when am copying some small size data (i tried with 50MB file ) it works very smoothly...Need your help experts!!
Thanks in advance!!!
a c 354 G Storage
September 30, 2011 12:31:25 PM

I'm not sure why you are getting an I/O error, but a chkdsk /r on a 2T drive will take over 5 hours easily. I usually run the command on larger disks overnight.
a b G Storage
September 30, 2011 1:12:06 PM

You didn't say what interface your external drive is connected to I will assume it is USB. In which case I don't think that your hard drive is faulty rather it is your USB interface that is giving the errors. If the external drive is on a USB interface it will take over 18 hours to do a chkdsk /r.
Related resources
October 1, 2011 6:12:46 PM

Thanks guys!! yeah you are correct.. my external drive is on USB... i used chkdsk /r for more than 6 hrs and still ddnt got anything... any other information you have so that i can use and make my 2TB run smoothly... this is getting more n more painful... :( 
!