Sign in with
Sign up | Sign in
Your question

[SOLVED] - Asus 5850 Crossfire, Manual Fan Control No Work

Last response: in Graphics & Displays
Share
November 14, 2009 2:53:40 PM

Few days ago I picked up 2 Asus 5850 cards and everything runs ultra cool and quiet when in idle for web surfing...etc

When playing Unreal Tournament and this MMO called Phantasy Star Universe, I notice my GPU temps break 65 to 70c. When I had my previous Diamond 4870, even though it ran hot, I adjusted the fan control and it never really went over 50c

Ive got the latest drivers, but for some reason when I enable Manual Fan control and use the slider, the fans will not go faster and the temps stay the same, unless Im idle and they go under 50c


Here's my setup

Windows 7 Ultimate 32bit
Thermaltake Purepower 600w
Asus PT6 Motherboard
Intel i7-940 3GHz
3GIG RAM 1333MHz
WD Raptor 150GIG
November 15, 2009 4:32:19 PM

Hey ZoSo,

65-70 degrees celcius is nothing to worry yourself over, especially in CrossFire configuration where the cards aren't cooling to their full capacity regardless. I understand why you want to keep the fans up to reduce your system temperature, but realistically it is probably not going to help the overall temperature very much unless you're doing some intensive overclocking with your other components that require that.

Regardless, if you still wish to try, you can download RivaTuner and it should allow manual fan control for at least one (if not both) of the cards. Best of luck.

As a side note, seeing as you're using an x86 version of Windows 7, I do hope you realize having two 1GB 5850s it's taking up 2GB total of your user addressable memory space, effectively leaving you with 2GB of memory rather than the 3 (or 4) you think you have. I'd recommend upgrading to the x64 version.
m
0
l
November 15, 2009 11:36:58 PM

Yea I was worried about that using up my system memory...that totally sux. Was not really wanting to go 64bit because of some programs but I do have a bunch of spare parts and can build it for a backup game system to run older games on. Also, would like to double the RAM to either 6-8 GIG RAM for 64bit


Actually I got it to work last night.

I disabled Crossfire in Control Panel and was able to get the fan go faster. Enabled Crossfire and it fully works now.... weird.
m
0
l
November 16, 2009 12:36:53 AM

zoso925 said:
Yea I was worried about that using up my system memory...that totally sux. Was not really wanting to go 64bit because of some programs but I do have a bunch of spare parts and can build it for a backup game system to run older games on. Also, would like to double the RAM to either 6-8 GIG RAM for 64bit


Actually I got it to work last night.

I disabled Crossfire in Control Panel and was able to get the fan go faster. Enabled Crossfire and it fully works now.... weird.


Rest assured Windows 7 x64 will run every program that works on Windows 7 x86 completely fine. ;)  Congratulations on getting it to work.
m
0
l
!