Sign in with
Sign up | Sign in
Your question

GeForce 9800GT 1 Gb --> Pain in the Neck !<--- Help if u can...

Last response: in Graphics & Displays
Share
November 14, 2009 5:46:22 PM

Hello everyone .
Looks like I'm having very common problem with my nvidia, unfortunatelly common sollutions are useless so far.
While playing GTA 4 or viewing "Google Earth" some bad things are happening with my display :( 

Lets start with "Google Earth" problem.
Every time I try to spin the earth my display is starting to flash and freez every 1-2 sec. after some while I m getting message:
Open GL : Too many errors occured which indicates a serious problem from which we cannot recover. The appliction must close.
http://docs.google.com/View?id=dd94657p_6dfvdhxgz

Other time when I'm running GTA 4 display is freezing during LOADING screen
http://docs.google.com/View?id=dd94657p_14przhkndf Then the PC is not responding at all . After several seconds the Blue screen of death appears with info : nv4_disp . Or sometimes instead of blue screen display is changing into a SAFE MODE and info in the window: DISPLAY DRIVER STOPPED RESPONDING.
http://docs.google.com/View?id=dd94657p_4c5m92zcg
Sometimes I'm lucku enough and Game is loaded without an error . then during the gameplay everything works OK .I Never had any problems.

So far I did following actions:
1 -instaling latest drivers from nvidia web which is .191.07
2 -instaling older versions of drivers :190.62 and 181.22 .
3 - every time before instaling diferent drivers I've used "Driver sweaper" and SAFE MODE to delete previous version of drivers.
4- I've checked card if there are any 6pin sockets for extra power. None found.



Thats my PC spec.
Windows XP Pro. 32
intel pentium E5200 2 x 2,5 Ghz
HDD WD 250gb and Seagate360 gb
Monitor Xerox 19" wide. Max. Resolution1440x900@75Hz Vertical Refresh Rate (Hz)56-75

that's the pictures of my GeForce and PSU." alt="" class="imgLz frmImg " />" alt="" class="imgLz frmImg " />

http://docs.google.com/View?id=dd94657p_8cbj7dfg2
http://docs.google.com/View?id=dd94657p_12cwmjwjfv
http://docs.google.com/View?id=dd94657p_10gp45vt85


I'll appreciatre if someone can help me haw to solve this problem .
Thank you.

a c 273 U Graphics card
November 15, 2009 6:27:17 AM

I have reason to dislike those EZcool PSU's, I would change it anyway.
a b U Graphics card
November 15, 2009 6:35:47 AM

^+1
Related resources
a c 173 U Graphics card
November 15, 2009 12:28:32 PM

4- I've checked card if there are any 6pin sockets for extra power. None found.

Well there you go, many of the low power cards have been very problem ridden. Second the psu is crap (how else would you like it).
a c 147 U Graphics card
November 15, 2009 1:50:34 PM

Yeah I've never seen a 9800GT that did not have a PCI-E power connector. I'm wondering if it just doesn't have enough power from the PCI-E slot.
November 15, 2009 4:37:55 PM

nforce4max said:
4- I've checked card if there are any 6pin sockets for extra power. None found.

Well there you go, many of the low power cards have been very problem ridden. Second the psu is crap (how else would you like it).


Well , do you think I can solve this problem by changing PSU ??? what are thye chances ??? If this will not change anything, you know...I don't wanna spend money for no reason. my PC is running 8 months on this PSU and I have never had any problems with it.
2dn .If you think this is the sollution to my issue, which PSU would you recommend to me ?
Thanx mate .
November 15, 2009 4:41:42 PM

jay2tall said:
Yeah I've never seen a 9800GT that did not have a PCI-E power connector. I'm wondering if it just doesn't have enough power from the PCI-E slot.


Well , not any more :D  that's the first one then ^^
I think if it hasn't got an extra PSU connector ,that's how it meant to be .... I think they designed it to work without it...
November 15, 2009 5:15:19 PM

Mousemonkey said:
I have reason to dislike those EZcool PSU's, I would change it anyway.


Which PSU can u recommend me ???
a b U Graphics card
November 15, 2009 5:36:57 PM

corsair 550 watts
a c 273 U Graphics card
November 16, 2009 6:28:30 AM

obsidian86 said:
corsair 550 watts

That'll work.
November 17, 2009 9:40:19 PM



So , just to make sure .... are you saying thst my nv4_disp problem will be solved after I get that Corsair 550W PSU ???? I dont wanna spend money for nothing :/  if it isn't going to help I better spend that $150 for a new better Graphic card .
a c 273 U Graphics card
November 18, 2009 4:41:02 AM

A new graphic card running on an old and potentially unstable PSU would be a pointless exercise. I think you would be better off to get the power supply sorted first and then go from there.
a c 173 U Graphics card
November 18, 2009 11:05:14 AM

Mousemonkey said:
A new graphic card running on an old and potentially unstable PSU would be a pointless exercise. I think you would be better off to get the power supply sorted first and then go from there.


Best advice thus far. Also keep in mind that many other people have reported issues with the low power editions of the 9800gt which is nothing more than a 55nm G92 with lower clocks. The ones with the connector can easily go to 740 core 1800+ shader. Mine had the TMU block fully enabled (all 64).
November 18, 2009 12:30:37 PM

Thanx for last two posts . I've already ordered Corsair 550W on ebay. I'll let u know if that will solve this issue.
Thanx again.
!