Sign in with
Sign up | Sign in
Your question

5.1 sound in games with x-fi

Last response: in Components
Share
January 24, 2010 4:16:31 AM

Ok , I have a problem. I just bought a an x-fi titanium (the plain one without the casing) and installed it in my system with no problem using the Daniel K drivers, the support pack 2.0 to be exact. the problem is I can't get 5.1 audio in games even the ones that are reported to have 5.1 (CoD 4). The only game that works with 5.1 audio with no problem is quake 4.

The creative audio console has a tab called "encode" and the buttons say "off", "Dolby Digital Live" and DTS Connect. When I click DDL or DTS connect. there is no sound from any source (game, internet, video files). When I set it to "off" i get 2.1 sound for music, games and even 5.1 with DD or DTS encoded movies (episodes of supernatural) but not for games.

When I right click on the speaker icon on the bottom right of the screen i go to "playback devices" and hit "advanced" it only allows me to select from 2 channel audio from the optical out.

There is nothing wrong with my receiver it plays 5.1 audio perfectly on my consoles and my tv (when I watch a show that is broadcast in 5.1).



Can anybody help me to get 5.1 from my pc games on windows 7 x64 with the x-fi?? Below is the receiver i have and the card i have.

sound card
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Receiver
http://www.crutchfield.com/S-AM49knxzP8N/p_158HTDW700/S...

More about : sound games

January 24, 2010 3:36:16 PM

Assuming your using an optical cable to connect your receiver to the sound card. You should select Speakers(Creative SB X-Fi) as your default device and you should also press the configure button. Then you can configure it to 5.1 settings and you can test it as well. You should also set it to 5.1 in your Creative Console as well as test it. You should also try enable the Creative X-Fi CMSS 3D. Set it to surround(click the Surround button and Select Stereo Surround) and move the slider to the middle. As for the encoding section you need to set it to Dolby Digital Live or DTS Interactive and make sure you select SPDIF output Creative SB X-Fi. I hope this helps.
m
0
l
January 24, 2010 5:54:44 PM

Ok, followed the step you posted and the games seem to work in 5.1 now through optical out. The display on my receiver shows 5.1 when listening to anything even things that I know are not 5.1 like youtube videos or standard 2 channel mp3 files. So this leads me to wonder are my games really getting true 5.1 with the above steps or just some up mixed pro logic type deal??

However, the real problem is that now video files that worked before i performed the recommended steps now only get static. As I said in my original post, before i did the steps the guy suggested, youtube videos played fine in 2 channel mode, and my video files that are encoded in 5.1 (episodes of supernatural) played perfectly in 5.1 it was just the games that were not doing 5.1. Now the games play in 5.1 and the movies that used to work are now just static.

Anyway I can get both to work with the "creative speakers"or do I just need to go to the playback device and switch it back to SPDIF out as the default playback device when I want watch movies, youtube, etc and creative speakers when i want to play games?


Edit:

Ok did some experimenting, it seems that video files will not get sound no matter what if the default playback device is set at "Speakers: Creative SB X-FI" it will only get static. not matter if Dolby Digital or DTS encoding is selected in the creative audio console.

On the other hand if SPDIF Out: Creative SB X-FI" is selected and Dolby Digital or DTS is set to "off in the creative console then the video files get their normal 5.1 with no static.

So the way it appears is that when i want to watch movie or listen to music then i have to set the default playback device as SPDIF and then go to the creative console and turn encoding to off. When I want to play games in 5.1 i have to change the playback device to "speakers and go into the creative console and turn on the DD or DTS encoding on.

This seems like a hassle is there any way to get everything to work without the constant switching the playback device and constantly having to turn the encoders on and off when doing different things?
m
0
l
Related resources
January 24, 2010 8:49:04 PM

What configuring as I've said does is that it encodes whatever source into 5.1 using the soundcards' processors. Well you need to configure all of your media players to play 5.1. and you would need to set the Sound Output in your media players to System Default. You could also go to the creative website for troubleshooting and tips on how to setup your sound system. Thats what I did when I first tried to configure the settings to be able to play everything without having to switch modes everytime.
m
0
l
January 24, 2010 11:58:08 PM

I use media player classic for all video files and it normally plays file in 5.1 with no problem (when i was using the built in coax on the MB). If the file had DTs or DD built in then it would play it in 5.1 with no prob and it does the same now if i turn the encoding off so they are set up to play in 5.1

I use the latest AC3 filter and it set up for spdif pass through, the speakers are set up for 5.1 all the settings are correct. so my media players are indeed set up for 5.1. The media player is set to "system default" so that's not the issue.

I'll check the creative site but from the experience so far I doubt the advice will be productive.
m
0
l
January 25, 2010 11:31:53 AM

Assuming your reciever is able to decode DD/DTS signals properly:

Sound Card:
Set to 5.1 output
Output via SPDIF
Set either Dolby Digital Live/DTS Connect as output method
(Optional) Use CMSS3D to upmix 2.0 audio to 5.1 [for 2.1 source audio]

Also, make sure that your media players aren't trying to decode any audio signals before sending them out via SPDIF; I've had more then a little troubles with 5.1 using WMP because it kept decoding my encoded audio, then sending it as 2.0 PCM...
m
0
l
January 25, 2010 3:54:11 PM

gamerk316 said:
Assuming your reciever is able to decode DD/DTS signals properly:

Sound Card:
Set to 5.1 output
Output via SPDIF
Set either Dolby Digital Live/DTS Connect as output method
(Optional) Use CMSS3D to upmix 2.0 audio to 5.1 [for 2.1 source audio]

Also, make sure that your media players aren't trying to decode any audio signals before sending them out via SPDIF; I've had more then a little troubles with 5.1 using WMP because it kept decoding my encoded audio, then sending it as 2.0 PCM...


I agree. Thanks for putting it in simpler terms. On another note, what do you think about ASUS soundcards?
m
0
l
January 25, 2010 4:08:42 PM

Also, doesn't the X-fi have 3 modes? I would have thought it would need to be in Games mode to work properly with games.

Or at least that's what happens with my Auzentech X-fi...
m
0
l
January 25, 2010 4:37:42 PM

ASUS <> Auzentech <> HT Omega > Creative

Really, Creative cards aren't even competitive quality wise; the only thing they have going is X-fi, which isn't even being used in newer games anymore.

The general consensus is Auzentech for gaming, ASUS for HT systems, although both companies are quite capable in both areas.
m
0
l
!