Solved

USB 3.0 Slow xfer speeds on small files?

I just purchased a Western Digital USB 3.0 Passport 1TB external drive. It came with a USB 3.0 cable and some software.

I immediately wanted to try to see what it could do, so I plugged it in to start loading my music onto it. I was disappointed to see that the transfer rates peaked at about 40mb/s. I canceled the transfer and tried a different file, this time a huge movie rip I had done, which was finished almost instantly @ a staggering 105mb/s. I figured maybe something maybe didn't get ramped up for the music, so I started the music again, only to see my transfer rates sitting around the same place my external USB 2.0 drives transfer at. I repeated the same tests a few times, with all teh same conclusions. Any file over 1gb that I moved over was blasted to the drive at 100mb/s or more, and anything like music would apparently have to wait.

Does anyone else experience this? Is this something I just have to live with or is this a driver issue or what?

I have the following hardware:

Core i5 2500k @ 4.5ghz
ASUS p8p67 Deluxe
16GB corsair DDR3
GTX 260 @ 610mhz
WD Caviar Black 1TB SATA III
etc etc etc

And just to avoid the basic questions I know everyone will ask:
YES USB 3.0 is enabled
YES my drive should produce speeds faster than 40mb/s
YES i have a USB 3.0 cable
YES I have it plugged into the blue USB 3.0 slot and
YES i am certain I have the most recent drivers for the USB 3.0 controller.

If ANYONE has any information or experience with this same problem I'd greatly appreciate being pointed into the right direction on how to fix it, or if I should give up being told that would be awesome too.

Thanks
8 answers Last reply Best Answer
More about slow xfer speeds small files
  1. Hi there,

    Small files will do that. Try to max it with http://www.codesector.com/teracopy.php
  2. Best answer
    Did you enable write cache?
  3. I did not enable write cache. Could you provide some more information or some detail on how to do this?
  4. right click on drive>properties>hardware

    double click your usb 3.0 HDD>change settings>policies
  5. Nevermind, I found a guide for enabling Write Cache. I'm at work, so I can't try it now ,but I will try it once I get home and test it out.

    @pyree thank you for the quick reply. Your suggestion (after googling the same thing) seems to have solved the problem for a few others. Thanks again for the quick reply :)
  6. Best answer selected by USB30needhelp.
  7. That solved my problem, thanks again Pyree. I have one last question. Are there any real risks to not "Safely Remove Drive" aside from losing data while transferring?
  8. Not that I know of. I never have a problem with losing data due to improper removal of drive because I always remove them with safe remove.
Ask a new question

Read More

Western Digital USB3 Storage