Sign in with
Sign up | Sign in
Your question
Closed

Cannot access or format External Hard Drive (WD My Book Essential)

Last response: in Storage
Share
October 3, 2011 7:05:06 AM

Hi,

I currently own a Western Digital My Book Essential 2TB Hard drive under a Windows XP OS. I normally leave my computer on stand by when I leave and this was no different on this day. When I returned to access my hard drive and play a music file, the program froze and I was prompted to restart.

Upon restarting, I could not access the drive or my files any longer. The hard drive that normally showed up as "My Book (E: )" now shows up as "Local Disk (E: )" and I am unable to access it or create/replace files on the hard drive. As you will see in the picture below, my computer recognizes the device and it acts as if it is completely normal, except I cannot do anything with the hard drive. I have been using this as a backup storage unit for all of my files. I have been going through various sites for troubleshooting and downloading many data recovery programs (Recuva for example) has led to no avail. When I try this it only recognizes the C drive and not the E drive and anything that notices the E drive says it has no data on it.

In addition, I have tried formatting and my computer will just not respond to the task and when I try the "start, run, chkdsk e:/ f" as adviced on these forums, I am receiving a notice that says "Cannot find direct access" or something along those lines.

I should also add that there was a lot of lightning strikes on the day that this had occured. Do I need to take the drive to a data recovery place or just cut my losses and get a new external hard drive? Also, is it possible that my hard drive has an electrostatic discharge and its impossible to retrieve the data that is on my hard drive? There are no noises emitting from the drive and virus scans on the hard drive detects that nothing malicious is effecting the drive.

I have demonstrated a few pictures to show that I have tried all the possibilities. Please help!!! Thank you very much for reading and I hope someone can find me a way to get my drive up and running again.





a b G Storage
October 3, 2011 2:43:16 PM

First I would try it on another computer.
Failing that, I would take it apart and connect the drive directly to a computer that supports the drive type. (essentially it could be a problem with the USB electronics and not the physical drive).

professional data recovery is extremely expensive and destroys the unit in the process. So thats your call depending on the importance of the data.

If its under warranty, get the unit replaced or shop for something else.
I would also recommend buying a UPS unit from APC. A "Back-ups1200" or similar.
a c 351 G Storage
October 3, 2011 3:16:31 PM

Have you tried this one (the freeware version).
http://www.easeus.com/product.htm

Myself (if above does Not work) I would try canadian69's approach of dissasembling it and trying the drive hooked up directly to the computer. The draw back is this would probably void the warrenty. So it depends on how badly you want to recover the data.
You may be able to dissasemble without it looking like you did so if that does not work you may still be able to RMA the drive and at least recover the cost.
Related resources
October 3, 2011 4:09:09 PM

I had one of these fail on a client of mine. It was a giant PITA to open it up. Turns out it was the HDD in my case. Sad part is that the serial# on the drive is linked to the enclosure, so we couldn't just do a warranty on the drive itself. Had to replace the whole thing together.
October 6, 2011 12:37:50 AM

So I tried it on another computer and the same thing happens. Using Kernel and the aforementioned program by Retired Chief has me perplexed to the same problem. The programs only pick up the C drive and not the E drive. I really want to recover the data since I have a library full of videos, so I suppose the only thing left for me to do is disassemble it and connect to the computer?
a b G Storage
October 9, 2011 11:57:34 AM

Did you have a chance to try the bare drive in another computer? Shame about the unit itself. Hopefully you can get your data back intact.
September 9, 2012 9:28:26 AM

This topic has been closed by Mousemonkey
!