Sign in with
Sign up | Sign in
Your question

My WD 2T USB3.0 is not getting detected in W7

Last response: in Storage
Share
October 3, 2011 6:16:25 PM

Hello,
I have bought a new WD 2T USB3.0 and then i updated the firmware. I have used the WD after that and then i didnt use it for one day. And when i connected the WD, its not getting detected. And then i checked in the Device manager, i found that the WD SES Device driver and CD-Rom Device. And i tried to update the driver, but getting response its up to date. But, the device is not working properly.then i tried disk management: But cant initialize the disk. Tried to update the firmware once again. but failed.. I dont know how to do. I have my important datas in that hard Disk. Is there any possible way to detect my hard disk without losing the data inside that... Please help me..!!!

More about : usb3 detected

October 3, 2011 6:40:53 PM

have you tried to use another computer?
and always backup your data.
m
0
l
October 11, 2011 1:23:26 AM

Yeah.. I tried couple of other systems.. In each and every system, i can find my WD hard disk in devices and printer. But there are no drivers like WD SES, Virtual CD device, etc. and ive installed all the drivers except Virtual CD Device and i cant install that one.. Because of this, i cant access the hard disk.
m
0
l
Anonymous
a b G Storage
July 7, 2012 4:00:13 PM

I had a problem with a WD 3TB external disk not getting found on USB3.0. I only got it connected once with slow speed. USB2.0 worked fine.

The solution I found was written on another forum. I turned off the overclocking feature on my motherboard and BAM it worked. I had upped the CPU by 5%.

Throughput is now 60-95MB/sec instead of 25MB/sec and it seems stable :-)
m
0
l
!