Sign in with
Sign up | Sign in
Your question
Solved

GA-890GPA-UD3H Sideport/IGX Config

Last response: in Motherboards
Share
May 11, 2010 7:47:30 PM

So, I recently built a new system w/ the following components:

Phenom II X4 955 @ 3.2Ghz
GA-890GPA-UD3H 890GX mobo
4GB (2GBx2) G.Skill ECO DDR3 1600 @ 8-8-8-24 1.40v (wasn't stable @ advertised 7-8-7-24 1.35v so I dialed back until stable)
ASUS DIRECTCU TOP 5850 1GB
Antec Earthwatts 750W PSU
hp dvd270 dvd-multi w/ Lightscribe
AFT 70in1 Multi-card Flash Reader
Antec Two Hundred Two case

Everything is running very nicely, but while reviewing my "detailed performance I came across a a few things that I'm not 100% about, and was hoping you guys might be able to help me sort it out.

Pasted directly from report:

Total available graphics memory 2807 MB
Dedicated graphics memory 1024 MB
Dedicated system memory 0 MB
Shared system memory 1783 MB

Now, what I don't understand is why there is 2807MB of available graphics memory? I went into the BIOS and looked at the IGX configuration, and here is where I am getting confused... it looks like the onboard 4200 is reserving 512MB of system memory, in addition to the 128MB of sideport memory, but that doesn't add up to 1783MB, nor is my System Memory showing up like any of it is reserved for the on-board graphics as it shows the full 4GB available.

Dedicated GPU - 1024MB
Sideport Mem. - 128 MB
UMA - 512MB

Between the dedicated 5850's 1024MB, the onboard 4200 claiming 512MB, and the 128MB of sideport, it ALMOST adds up to that "Shared System Memory" reading of 1783MB, but not quite. But even if, for whatever reason, that "Shared System memory" is the 3 of those together, where is it getting the other gig of memory from?

Really though, I just want to know what I should do about all of this? I didn't think my GPU supported Hybrid-Crossfire, and even if it does, from what I've read about it, I probably wouldn't want to use it anyway. So, should I disable the UMA? Disable the sideport + UMA? Or just leave it as it is now? I'd really rather not have that much (or any of my system memory for that matter) being gobbled up by an unnecessary feature, especially a redundant on-board VGA that is only going to gum up the works.

So if anyone could explain any of this, and give me some recommendations on how to proceed, I'd be very grateful. Thank you in advance :) 
a c 177 V Motherboard
May 11, 2010 8:20:39 PM

Go to the " IGX Confguration" sub-page of the "Advanced BIOS Features" page of the BIOS, set:

"Internal Graphics Mode" to "Disabled"
"UMA Frame Buffer Size" to "Auto"
"Surround View" to "Disabled"

on the "Advanced BIOS Features" page itself, set:

"Init Display First" to "PEG"

should do it...


m
0
l
May 12, 2010 12:43:42 AM

I followed your instructions, set everything just as you explained, saved the changes to the BIOS and rebooted. Everything posted fine, so I re-ran the Windows Experience Index which is what is producing the detailed report I am getting this info from, and....

It was the same as before, still showing 2807 MB memory available graphics memory. Here's the whole report:

Manufacturer Gigabyte Technology Co., Ltd.
Model GA-890GPA-UD3H
Total amount of system memory 4.00 GB RAM
System type 64-bit operating system
Number of processor cores 4

Storage
--------------------------------------------------------------------------------

Total size of hard disk(s) 466 GB
Disk partition (C:)  426 GB Free (466 GB Total)
Media drive (D:)  CD/DVD

Graphics
--------------------------------------------------------------------------------

Display adapter type ATI Radeon HD 5800 Series
Total available graphics memory 2807 MB
Dedicated graphics memory 1024 MB
Dedicated system memory 0 MB
Shared system memory 1783 MB
Display adapter driver version 8.723.0.0
Primary monitor resolution 1920x1080
DirectX version DirectX 10
--------------------------------------------------------------------------------

I had assumed that disabling the Sideport and UMA would have at least reduced the amount it says in the report, but it hasn't changed at all. Is there a setting in Windows that is causing this? I wouldn't think so b/c if there was then Windows would display less system memory available, correct?

I thought it might have been a glitch in whatever diagnostic windows is using to get this info, so I decided I'd run a dxdiag and see what that had to say....

Interestingly, there are some discrepancies between what dxdiag, and the WET (Windows Experience Tool) reported, mainly that I am running dx11 which WET reported as dx10, and dxdiag also reported my graphics card to have 2797MB of available memory....

Where is this extra gig and a half of memory coming from? and if it's my system memory, how to I stop it from being set aside for graphics memory?
m
0
l

Best solution

a c 177 V Motherboard
May 12, 2010 4:13:41 AM

Couple people have reported other 'wierdnesses' with the 8xx chipset - my guess, a couple months of windoze 'updates', and a BIOS flash or two, and it'll 'all be a memory' [:bilbat:9] (pun 'semi-intended...)! This one seems harmless - your actual available system memory does not seem to be affected. Suggestion - 'zip up' that extra gig an a half of GDDR, and email it to me as an attachment; I'll put it in my 'someday' box, to use with my imaginary 512 core Fermi[:jaydeejohn:4]

Seriously though, give this a try: d/l the latest GPU-Z, run it, and post the results - curious to see what it 'thinks' about the situation...
Share
May 12, 2010 3:37:46 PM

So I DL'ed and ran GPU-Z, and it reports everything as it should be, w/ my GPU "only" having 1024 MB...although I guess I should note that it does specifically say that any additional memory from multi-GPU set-ups aren't displayed. Not that I have a multi-gpu set-up, unless you count the on-board, which shouldn't be counted but I have a feeling that's exactly what windows and dxdiag are doing.

You're probably right though, it's probably just some "weirdness" w/ the chipset and/or the way the chipset communicates w/ windows.

Thanks for the help...and the puns (I guess, lol)
m
0
l
a c 177 V Motherboard
May 12, 2010 3:49:19 PM

Always [:graywolf:9] !
m
0
l
May 12, 2010 4:24:26 PM

Best answer selected by Lord_Foortwenti.
m
0
l
!