Sign in with
Sign up | Sign in
Your question

Converting external hard disk to internal after overvolting

Last response: in Storage
Share
October 5, 2011 2:53:48 PM

Hello,I had a 3Tb WD My Book Essential and being the genius that I am plugged my laptop power (19V compared to the required 12V) supply into it. After that it unsurprisingly stopped working.
I searched this forum and others and followed the advice of removing the HD from it's casing and attaching it as an internal HD on a desktop to check if it still works.
I am using windows and although the disk is not visible in 'my computer' it is in 'device manager' and 'disk management'. However, it says I have to initialise the drive. I have searched many forums and have come back with conflicting answers as to whether this will erase all data on the disk? I am using windows 7 and the disk was originally formatted under windows vista if it makes any difference.I would really like to keep all of the data off the dive and will buy another external casing for it or a replacement drive depending on which you recommend. Any help as to how to proceed is greatly appreciated.
a c 277 G Storage
October 5, 2011 4:17:37 PM

There is no conflict. Initialising, partitioning, and formatting the drive will wipe your data, or at least make it harder to recover.

The first step is to try software-only methods of recovering the data. In the simplest cases, only the partition and/or format information is lost. I suggest that you download and try the free EASEUS partition recovery tool: http://www.easeus.com/partition-recovery/ . It's primary function is recovering lost partitions, and your partition is lost.

If that doesn't work, there are more aggressive utilities that will read every accessible sector and see if they can recover files. If that doesn't work, you may need a lab, a hardware solution, or to give up on the data on it.

In the future, have at least two copies of everything that you want to keep.
October 6, 2011 9:27:57 AM

Thanks for the response, unfortunately after downloading the software it says that 'the destination disk is unsupported' after checking the help page the maximum disk size is 2TB and mine is a 3TB WD Caviar Green. Do you (or anyone else) know of any similar software that is compatible with a HD of this size?
Again thanks for the help
Related resources
October 6, 2011 1:31:20 PM

Don't worry I'm currently trying the EASEUS Data Recovery Wizard Free edition just to see what it finds with it's search and will then post an update to see if anyone has any other ideas. Thanks for pointing me in the right direction and stopping me initialising the disk anyway!
a c 271 G Storage
October 9, 2011 4:24:30 AM

pete26, WD's Essentials drives are usually (always?) hardware encrypted using 128-bit AES, even if you have not set a password. Therefore recovery software will be useless -- you will only see jibberish. In fact you can use a disk editor to examine the first few sectors. If you see a repeating pattern of 16 bytes, then these will be encrypted zeros.

If you wish to recover your data, then you will need to repair your USB-SATA bridge board, or replace it with an identical one from an identical product of the same capacity. I suspect that a repair will probably involve bridging a fuse. If you could upload a detailed photo, then I may be able to identify it for you.

An added complication is that your USB mass storage device is configured with 4KB LBAs. This means that, even if the data were not encrypted, you would still have great difficulty accessing your data when the drive is installed inside your PC. This is because the naked drive communicates using 512-byte LBAs, but its data is structured with 4KB LBAs.

DMDE (DM Disk Editor and Data Recovery):
http://softdm.com/download.html

HxD - Freeware Hex Editor and Disk Editor:
http://mh-nexus.de/en/hxd
October 10, 2011 6:44:24 AM

Hi fzabkar,

Thanks for your reply, just to update on the results of two programs I tried. The first was the previously mentioned EASUS data recovery wizard which came back saying that the hard disk was 328GB in size with 250 files: including a 2.15GB word file, numerous GZip files and lots of shockwave files of various sizes up to 3.97GB. None of these are actually data on the hard drive (it is mainly .avi .mp3 and matlab files). I presume this is due to the encryption.

Second I used TestDisk 6.12 by CGSecurity. This produced the following output: (hopefully the photo will work it's the first time i've tried)




As the program took ages (I left in running in work over the weekend so not sure how long but at least 7 hours) to run I'd prefer not to run it again and just wanted to know whether pressing 'continue' was a good idea or if this will make it even harder to get any data back?

I don't have my camera in work today but will bring it in tomorrow to take the pictures of the circuit board for you but just wondered if any one knew what I should do at this stage?

Thanks again for all of the help
a c 271 G Storage
October 10, 2011 8:20:45 AM

TestDisk is reporting a nonsensical partition structure. This is to be expected of an encrypted drive. You must not write on the drive in this state. In fact there is nothing you can do without the bridge board.

A disc editor such as DMDE will allow us to see the actual bytes.

Here is the procedure to save the first 64 sectors to a file.

Choose your Physical Drive.

Go to Tools -> Copy Sectors.

Click Device in the Source tab. First Sector should be 0. Change Number of Sectors to 64. The Last Sector should adjust itself automatically.

Choose File in the Destination tab. DMDE will select a filename of "sec_0_64.ima". Choose a destination folder on one of your other drives, not your problem drive. Click OK.

The IMA file will be 32Kbytes in size and should contain the contents of track 0 plus your boot sector. Could you please upload it?
October 10, 2011 8:55:04 AM

Thanks for the quick reply here is a link to the file which should hopefully work, if not just let me know and I'll try another way of uploading it.



Thanks again
a c 271 G Storage
October 10, 2011 9:58:46 AM

Thanks very much.

As expected, the data are encrypted.

Specifically, the first 4KB of the IMA file contains encrypted data. This corresponds to LBA 0 if we think of 4KB LBAs, or LBAs 0-7 if we think of 512-byte LBAs.

The first sector (512 bytes) contains an encrypted MBR and partition table, and the next 7 sectors are padded with a repeating pattern of 16 bytes corresponding to encrypted zeros, as follows:

B2 3B D3 23 CA CD D4 EC AB 0F EB 05 BF 83 B4 09

The encryption method is 128-bit AES (16 bytes = 128 bits).

The remaining sectors contain unencrypted zeros. This is because the drive is initially zero-filled during manufacturing (outside the enclosure), and then installed in the enclosure and subsequently partitioned and formatted via the bridge IC.

I expected to find a boot sector at the end of the IMA file, but it appears that WD has placed it elsewhere.

In short, I don't believe you will be able to recover your data without a compatible bridge board. :-(
October 10, 2011 1:51:21 PM

Thank you again for getting back to me so quickly, I still have the bridge board so I guess the issue is how badly I have damaged it? Here is a link to the photo, let me know if you need higher quality but is the best I can do today.


Again, thanks for the help I've been reading various other forums on this and you seem to pop up everywhere with regard to this issue
a c 271 G Storage
October 10, 2011 9:21:09 PM

The photo isn't very clear. Does your camera have a macro function? Could we see the other side of the PCB as well?

That said, the only component that I can see that looks like a fuse is the zero-ohm resistor at location R56 near J3. Can you measure its resistance?

If you need help with this, see Q5 on the following page:
http://www.users.on.net/~fzabkar/HDD/TVS_diode_FAQ.html

If R56 tests OK, then power up the board on its own, press the ON button if necessary, and then measure the voltages at the +12V and +5V pins at the SATA power connector.

Serial ATA (SATA) power connector pinout:
http://pinouts.ru/Power/sata-power_pinout.shtml

BTW, the usual result of an overvoltage from a laptop adapter is a shorted 12V TVS diode on the drive itself. However, your drive is obviously OK.
October 11, 2011 11:08:45 AM

Sorry about the photo, I am planning on buying a digital camera tonight so will give you a better picture. The resistor measured 0.5 ohms.

The voltage at the pins measured correctly at first (when the power was first switched on) but then dropped off to 0 within about 10s. This happened again if the power was turned off and on. Any idea as to what this means and if there is any way to fix it?
I have access through work to the tools and expertise necessary to do some repairs and am currently looking up the data sheets on the voltage regulators as someone advised me that this might be the problem.

Any further advice would be greatly appreciated
a c 271 G Storage
October 11, 2011 2:21:42 PM

I suspect that the bridge IC (Initio INIC-1607E ?) may be switching the supply voltages to the drive via a dual MOSFET at location U4. Feedback from users suggests that this IC may be an AO4616, AO4619, or AO4620.

It could be that the bridge IC waits 10 seconds for the drive to come ready, after which it times out and switches off the power. It may also be that the absence of a USB connection causes it to go into power saving mode.

You could verify whether the gate pins of each MOSFET connect to the bridge IC. This would confirm whether the bridge is controlling the power. I would also test whether +12V and +5V continue to be present at the input pins of the MOSFETs.

I believe that U5 is a PWM controller that is associated with the 150uH coil. Together they would form a switchmode +5V regulator. This DC-DC converter should have a sufficient supply voltage margin in order to easily withstand a 19V overvoltage.

In the event that you are unable to repair your board, and if a replacement board is unable to decipher your data, then you may need to transfer the serial flash memory chip (U2 ?) to your donor PCB. This chip contains the firmware for the bridge IC.

The following compilations of datasheets should help you identify your ICs. If any are not included, then please let me know and I'll try to update my database.

Datasheets for HDD semiconductors, regulators, op-amps:
http://www.users.on.net/~fzabkar/HDD/HDD_Semis_Regs.htm

Datasheets for HDD memory ICs including EEPROM, EPROM, flash:
http://www.users.on.net/~fzabkar/HDD/HDD_EEPROM_Flash.h...

HDD IC database:
http://www.users.on.net/~fzabkar/HDD/HDD_ICs.txt

FWIW, here is a datasheet for the INIC-1607E:
http://www.griol.com/ftp/OTHER/INIC_2.rar
http://www.griol.com/maintenance.html

Unfortunately the file is password protected. :-(
October 11, 2011 2:52:54 PM

Thanks again for the reply, looking at the chip which I presume is in place of the Initio one it is instead a JMS538S. I've tried searching the web but can't find any information on this chip but instead found this which I presume is something very similar given the description:



Do you have any experience with this chip or should exactly the same things apply. I'm not sure if I should have mentioned this earlier but the board is USB3.0

As I said I will get a digital camera tonight and get a better quality picture for you. When the HDD functioned as an external drive it did automatically power down after removal of the USB cable so it might make sense that the voltage dropped when not connected. It is also mentioned in the specifications of the above chip that it has a USB power saving mode. Can you see any added danger to either the board or a connected computer if I plugged the cable in and retested the voltages at the pins to see if they remained stable?

I've tried searching through your HDD IC database but couldn't find any of my ICs listed there. I have found datasheets for most of them and will happily send you the links if you would like?

Again, thank you for spending so much time trying to help me out.
a c 271 G Storage
October 11, 2011 10:04:00 PM

This is the first time I've seen that JMicron chip, but I would expect that it should behave in a similar way to Initio's bridge.

FWIW, according to the datasheet of the JMS539, this chip incorporates "VIA ROM
64Kx8", and the external NVRAM chip (serial SPI flash) incorporates "Vendor Information, USB2/USB3 Descriptor, and Vendor ROM code".

The use of the word "ROM" (read-only memory) is confusing because it would suggest that the code is masked and therefore not upgradable. However, the datasheet states that JMicron "provides software utilities for downloading the upgraded firmware code under USB2.0/USB3.0". I suspect this only applies to the external flash, not the internal code, otherwise there could be differences in the bridge chip.

As for the potential of damage to the connected computer, I expect that you should be OK. When testing voltages, I suggest you avoid "busy" areas to reduce the risk of shorting adjacent pins with your probes. In particular I would test the voltages on each of the pins of U4, assuming it is a dual MOSFET.

I would be most grateful if you could tell me the markings on each of the ICs and transistors, including U2, U4, U5, Q2, Q1, and the 5-pin IC at 11 o'clock to the 150uH coil. Any links to datasheets would also be greatly appreciated.
October 12, 2011 12:10:47 PM

Here are some hopefully better pictures for you.
Front:



Back



The chips are as follows:

U5=
RT8284
GSPCKJ32


U4=
APM4532
RMC98


U2=
25X20BLNIG
1043


5pin chip says 3R=D0B I think but can't seem to find information on it and the first '0' is very hard to read so could be D,B or 8 etc.

Transistors are both W1P with PO written perpendicular

The voltages at pins of u4 were as follows:
1=0v
2=0v
3=12v
4=12v
5=0
6=0
7=0.025
8=0.025

Any use?

a c 271 G Storage
October 12, 2011 9:53:00 PM

Thanks for the datasheets. I've added your components to my HDD IC database.

Let me first say that the bridge board appears to be working as expected. That is, it applies +12V and +5V power to the HDD's power connector, waits for it to spin up and come ready, and then times out and turns off the SATA power.

Nevertheless, here is what I make out of the circuitry on the board.

U5 is indeed a PWM controller. I believe you will measure +5V at the 150uH coil during the initial 10 seconds after power-up, after which the output should go to 0V. If so, then the JMicron bridge IC will be controlling the +5V supply to the HDD via U5's ENable pin.

Similarly, I expect that pins 5 & 6 of U4 will be sitting at +12V at switch-on, and 0V after the 10s timeout. U4 is indeed a dual MOSFET as expected. Its datasheet specifies it for Power Management applications. The P-Channel MOSFET appears to be switching the +12V supply to the HDD, in which case I believe its gate (pin 4) will be controlled by the bridge. I can't guess at the function of the N-Channel MOSFET in the same package, though.

The flash memory at U2 and the JMS538S bridge chip both require a +3.3V supply. Some bridges derive this supply internally from the +5V USB port. However, I believe that the 5-pin component (whatever it is) plus the small coil to the right of it, and to the left of Q2, may constitute a +3.3V switchmode DC-DC converter. If so, then you should measure +3.3V at the coil.

I suspect Q2 may be the driver for the LED, and Q1 may provide the 3.3V-to-12V level shifting to enable the bridge to control U4.

BTW, here is a direct link to your photo (no ads, banners, etc):
http://farm7.static.flickr.com/6169/6237381128_214f127e...

Here are links to your datasheets:

W25X20BLNIG, Winbond, 2.3V - 3.6V, 2 Mbit serial flash memory, 4KB sectors, Dual I/O SPI:
http://www.winbond.com/NR/.../W25X10BL_W25X20BL_W25X40B...
http://www.dz863.com/downloadpdf-cfkijucfcf-25X20BLNIG....

APM4532, Anpec, Dual Enhancement Mode MOSFET (N-and P-Channel), N-Channel 30V/5A, P-Channel -30V/-3.5A:
http://www.anpec.com.tw/ashx_prod_file.ashx?prod_id=242...
http://www.datasheetcatalog.org/datasheets2/21/210443_1...

RT8284, Richtek, 2A, 23V, 340kHz Synchronous Step-Down Converter:
http://www.richtek.com/download_ds.jsp?s=566

PMBT2222A, NXP, marking W1P (W = site code), SOT23, 40V, 600mA, NPN, switching transistor:
http://www.nxp.com/documents/data_sheet/PMBT2222_PMBT22...
July 16, 2012 12:03:17 AM

Hi Pete26,

Were you able to recover the data from the "WD essential 3GB" drive?

I've exactly the same situation as you.

Thanks,
wvguitar
(wvguitar@yahoo.com)
July 16, 2012 7:22:19 AM

Hi Wv,

Unfortunately not, I tried following the voltages at each of the pins and while some were ok, some were a long way off, I'm sorry it was a while ago and I've lost the sheet I had it all written down on. I work at a an engineering company (not an engineer myself) so got someone to have a quick look for me and they thought the problem was with a voltage converter.

Fortunately I had a back up of all the data on the drive, it was just in another country at the time, so have now put the HD in an new external case and next time I get the chance will have a go at formating it and seeing if I can get it working again.

If you really need to recover the data the I would see if you can get fzabkar to help you, he was very knowledgeable and helpful.

One thing I would like to suggest is that if you do start testing pin voltages yourself with a mulitmeter, make sure that you do not short circuit anything. This was the final straw in me giving up, I had tested the whole lot and got my friend to have a look so was pretty much ready to give up anyway when I decided on one last test, jogged my hand and shorted a couple of pins and then many of the voltages had changed again.

Good luck, and thank you fzabkar for all of your help
July 16, 2012 3:54:16 PM

Thanks pete26 for the quick response.

I've since converted the Essential to one connected by USB3.0 adapter.
It was recognized by Windows 7 but said "it's not initialized".

Reading many feedback from Amazon of the same situation, it seems the drive is encrypted at the hardware level through the bridge card even though I did explicitly do it.

I'm looking at purchasing a bridge card if this's available.

Can someone who have tried this path share your experience?

Thanks.
!