Sign in with
Sign up | Sign in
Your question

SATA HDD and DVD Won't Play Nice

Last response: in Storage
Share
October 6, 2011 12:03:59 PM

I have a Gigabyte P67A-UD5 motherboard, running the latest bios (literally just updated it successfully). I cannot get 2 of my 3 drives to cooperate.

I have:
1) One SATA 1TB HDD.
2) One SATA DVD-RW.
3) One Vertex 2 OCZ SSD.

Any combination of drives 1 and 2, makes my PC not boot. It gets stuck on the "Detecting IDE Drives..." screen, and sometimes it finds a drive, other times not. Either way it never, ever, gets past that POST screen. Now oddly, they were working together fine, until a few days ago, in Windows when playing a DVD I noticed that my DVD drive lost contact with the system, like literally just disappeared from explorer and everything, and then reappeared a few minutes later. However, if I use just the SSD and the DVD, all is well. If I use just the SSD and the HDD all is well (except I can't watch DVDs *sadfase*) but the HDD and DVD are mortal enemies it seems.

What might be going on here, is the DVD dying/dead? I've found a few posts around the net about similar issues, but none of them resolve with a solution (of course!).

Thanks!
~521

More about : sata hdd dvd play nice

a b G Storage
October 6, 2011 12:46:31 PM

This could be a power supply issue, DVD drives can do some strange things when the power supply regulation is not what it could be. The reason that it works with the SSD and not the hard disk could be because the SSD draws less current on the 12v rail. To test out my hypothesis replace the power supply with a good known one.
October 6, 2011 1:00:26 PM

Hey there, I have a Zalman 850W, and prior to this I had 2 HDDs, 1 SSD and the DVD, as well as my two HD 5770s in CrossfireX mode. I would be surprised if it was a power issue myself, and I don't have a better PSU than this at hand to try with.

I could use one of the extension cables and move it to another rail perhaps? I will need to dig in the box and see what I have, it has a load of spare ports though. I'm just not overly convinced that is the issue, as it only happens if I connect the SATA cable regardless of whether the power is in it or not.
Related resources
October 10, 2011 5:09:18 AM

Hey guys, so far no dice. I've tried every combination of ports and cables and drives.

I've narrowed this down to my 1TB SATA HDD not liking my SATA DVD. Which is so strange, as a month ago they were working fine together, and had been doing so for 6 months prior... :( 

Could the DVD really be dud?
October 16, 2011 3:13:46 AM

Still no answer to this question.
a b G Storage
October 16, 2011 4:31:48 AM

Have you tried the power supply suggestion?
October 16, 2011 8:34:14 AM

No. I have an 850W PSU which is certified to power far more than my meager setup. This setup worked prior without adjusting anything. I can also disable one of my GPUs which draw far, far more power than any of my drives, and it still exhibits the same issue.
a b G Storage
October 17, 2011 12:52:18 AM

Well it could still be the power supply, power supplies do fail, and it could be the 12v rail that could be the problem which may not be loaded by the graphics card. If you are sure that it is not the power supply causing the problem, then the problem must be with the motherboard. The SATA interface is not affected by faults on other SATA ports. Have you tried resetting the CMOS memory correctly by using the link provided on the motherboard? Have you got the latest version of the BIOS? As a last resort you may have to change the motherboard to fix this.
October 18, 2011 12:15:33 PM

Hey there.

Well I got a second DVD drive to test and make sure it was/wasn't the DVD. This one lets me boot to Windows (sometimes) but then the DVD drive disappears in Explorer. Then a few moments later it returns.

I have the latest bios yeah, if something was going to freak out because of a bad PSU I would have thought I would see general system instability, rather than just the DVD. I can try putting the addition cables in the PSU and running the DVD from another cable, see if that helps.
October 18, 2011 12:36:18 PM

Nope, tested a new cable plugged into a different PSU port, dedicated to the DVD and still no dice.

It simply doesn't even get past the "Detecting IDE Drives" POST screen. :|

This is starting to drive me insane, this was all working fine mere weeks ago and all I did was nothing. >:|
October 18, 2011 12:39:08 PM

With the new drive, I booted a couple of times, and noticed something really weird on the POST screen, when it detected the drive, it had a string of what looked like "L" characters, like this:
L
.L
..L
...L
....L

etc etc. I just put the dots '.' there to add whitespace, but it was a long like of "L" characters and then it hung. That only happened a few times.
October 25, 2011 8:55:57 AM

[SOLVED] Turns out the reason for this was that the motherboard I purchased, was a version 1 of this specific model, which had issues in manufacturing in the silicon, so serious that Gigabyte issued a new variant, known as B3, which is one that works. To get around this I just got SATA->USB converters and use the drives in USB mode.
!