Sign in with
Sign up | Sign in
Your question

Stumper questions on Win 7 Pro build

Last response: in Systems
Share
November 11, 2009 3:53:51 PM

I have some stumpers of some questions for the community here.

First off some background. This is a new build running Windows 7 Pro 64 bit, being done as a clean install. The pc has a WD Raptor 10k RPM 74 GB SATA hd as the C: drive. There are two more WD 1 TB (3.0 GB/s SATA) drives for program and data storage. The mb is a Gigabyte GA-EP45-UD3P.

The following is a brief list of events which has led up to the current situation.

Initially I had planned to have the two 1 TB drives be set up as a RAID 1 (mirror) for data redundancy purposes. I installed Win 7 and once installed I went in to the BIOS and attempted to activate the RAID functionality to set up the data drives but after activating it and rebooting the pc got stuck in an infinite boot-loop so I deactivated it again in BIOS. Subsequently I went in to Windows and using the Disk Management utility I set up the two TB drives as a mirror there instead of through the BIOS/hardware. The utility appeared to work in creating the mirror but when it checked the status of the drive it listed it as Failed Redundancy. After some discussions with some folks I decided to forego the mirror and subsequently broke the mirror, deleted the partitions/volumes and reformatted them as standard hard drives. Currently one is listed as F: and in Disk Management it is currently a Basic drive formatted as NTFS and its status is Healthy (system, active, primary partition). The other drive is listed as G: and in Disk Management it is currently a Basic drive formatted as NTFS and its status is Healthy (primary partition). Both were formatted with a full format (not quick).

Now the problems:

1. After installation of most of the programs I had to do a reboot, and now sometimes one or both of the data drives occasionally act as if they are Read Only. Sometimes just the F drive is like that, sometimes just G, sometimes both, sometimes neither. If I look in the properties of the drives they do not appear to be set as Read Only. If I go to command line and use diskpart.exe I don’t see any flags for Read Only there either but if I manually use the CLEAR ATTR command on either the Disk or the Volume it appears it does clear whatever is going on behind the scenes and subsequently I can write to the drives fine. Again, this doesn’t happen all the time. Maybe about 30% of the time on boot up this happens to one or both of the data drives. The drives are plugged in to both of the purple ports on the mb (the 3.0 GB/s SATA ports). So, why is this happening and how do I fix these drives (preferably without having to reformat them yet again)? Does this have anything to do with the different status listed for the F and G drives? They were both formatted in the same way after breaking the mirror. I doubt it is a hardware fault on the part of the hard drives. One faulty drive I can believe ... but both? Unlikely.
2. I placed all of my music files on the G drive. When I started Media Player and started listening to some music for the first time Media Player suddenly stopped about 2/3 of the way through the first song. I tried to restart playing the song but got an error saying the media was not found. I looked in Windows Explorer and the F and G drives were suddenly entirely gone off the list of drives! I rebooted and the drives were once again listed as normal and tried to play the song again with Media Player and the entire computer locked harder than a drum and had to do a hard reset. I booted back up (which at that point resulted in something else interesting, see #3) and once again tried to play the same song again and it locked again. I have not tried to play a different song as of yet but will do so later today but I suspect it will do the same thing. So, why is this happening and how could this be fixed?
3. After the incident listed in item #2 when I attempted to boot up the computer would freeze when it got to the Gigabyte logo in BIOS. Hard drive activity would cease and can’t do anything. Now the kicker … if I subsequently hit the reset button it will power back up and hit the Gigabyte logo and proceed onwards and boot up normally. It does this every time I cold boot now. I have to hit power and then hit reset in order to bring it up. Not a critical problem but certainly an annoyance. So, what is happening here and how to fit it?

So. Who has some ideas? 
a b B Homebuilt system
November 12, 2009 12:23:27 PM

Just thoughts to contribute here.
You have an intermittent problem with HDD access and I agree it seems unlikely that BOTH units have the same problem.That started me thinking the mobo itself has a problem with those SATA ports. So, a few things to try:
Connect to other SATA ports and see if that changes anything.
Download and run WD's disk diagnostics - long thorough test - on each drive to see if that tells you anything useful.
Check all cables and connectors - people have had problems with SATA connectors that are loose enough to disconnect themselves partially.

Your #3 item leads in a different direction.This almost looks like the computer is not getting enough power at a critical point in the boot process while the POST is running. One way that can happen is if two or more heavy power users come on line at the same time, pulling a weak power supply line to low voltage. Two drives starting up simultaneously is an example. For this reason some BIOS's have a setting that will allow you to delay HDD startup, and to stagger the start times for 2 or more HD's. That might be a work-around, but if this really is your problem, it makes me worry that your PSU has a flaw that is not going to cure itself.

By the way, once you get this resolved, my understanding is that running a RAID1 array using the mobo's built-in RAID control systems is better than using Windows' version of RAID1. Anyone else have experience to contribute to this question?
m
0
l
November 12, 2009 5:36:11 PM

If I move the hard drives to different SATA ports will that effect any programs that were installed on them?

I have not as of yet ran the WD diagnostics because the listed operating systems for the software is up to and including Vista 32 bit. I wasn't sure it would run on Win 7 Pro 64. But I will give that a try (if the program will even run).

I doubt it is a loose connection issue, if they were coming disconnected I would assume the drives would drop offline completely instead of listing themselves as Read Only. Will look in to it though.

FYI the ps is a 750w Corsair so I seriously doubt there is a lack of power in the system. But, for the record, the system has:

1 WD Raptor 10k RPM SATA hard drive
1 DVD-RW optic drive
1 Blue Ray optic drive
2 WD Cavair 7.2k RPM SATA hard drives
1 EVGA GTX 260 superclocked vid card
4 120mm fans (3 in the case, 1 on the CPU)

My past research indicates that a 750 should be sufficient for this. Is this correct?
m
0
l
Related resources
a b B Homebuilt system
November 12, 2009 5:43:03 PM

Your research is correct. A 750W PSU is more than enough for your system. You could've went down to a 650W PSU and been safe.
m
0
l
a b B Homebuilt system
November 12, 2009 8:06:25 PM

Moving SATA drives to a different port should NOT affect anything. The only possible problem is if windows re-assigns them names and gets them changed somehow. If that happens, you can use Disk Manager to change their names to what you want.

The loose connection idea was along the line that a slightly loose connector may have one line out of several not connected, so the result is incomplete or erroneous data transfers, not necessarily total failure.

My suggestion about inadequate power was not really about having chosen a PSU that is too small, although that also is possible in some cases - but not yours. I was thinking more about a faulty PSU failing to deliver according to its design.
m
0
l
!