Sign in with
Sign up | Sign in
Your question
Closed

New Sony TV and new NVIDIA card-- can't improve display quality?

Last response: in Graphics & Displays
Share
November 19, 2009 12:10:22 AM

I am having a very annoying issue with getting my computer and my TV to get along. I have a Sony KDL-46V4100 LCD which is about 8 months old, and I have two PCs both running Windows 7 64-bit. The first PC has an NVIDIA GTX 280, and is connected to the TV using a DVI-to-HDMI adapter with an HDMI cable. The second one has an NVIDIA 8800GT and is connected to the TV with a DVI to HDMI cable.

Both are set up at 1920x1080 @ 59Hz (I also tried 60Hz) and 32-bit color.

I have tried switching up which port that either computer is plugged into, but no matter what I do, the computer with the GTX 280 always looks washed out and most of the image quality options are greyed out and disabled. I can't adjust the color and a number of other image settings. My TV also has optimizer options such as "Game Mode" and "Video/Photo Enhancer", which can normally be enabled or disabled on a per-HDMI port basis, but again these options are all greyed out. When I try to change them, my TV says "Feature not available for PC input". I have done a context-sensitive google search for this error and have not found a single result on the entire Internet, hence me posting here in desperation.

The computer with the 8800GT does not detect as a PC, and is detected as an "HDMI" input, which allows to me change any setting just like I could on my PS3.

If anyone actually knows a solution please let me know. Thanks.
November 19, 2009 12:26:34 AM

moozh said:
I am having a very annoying issue with getting my computer and my TV to get along. I have a Sony KDL-46V4100 LCD which is about 8 months old, and I have two PCs both running Windows 7 64-bit. The first PC has an NVIDIA GTX 280, and is connected to the TV using a DVI-to-HDMI adapter with an HDMI cable. The second one has an NVIDIA 8800GT and is connected to the TV with a DVI to HDMI cable.

Both are set up at 1920x1080 @ 59Hz (I also tried 60Hz) and 32-bit color.

I have tried switching up which port that either computer is plugged into, but no matter what I do, the computer with the GTX 280 always looks washed out and most of the image quality options are greyed out and disabled. I can't adjust the color and a number of other image settings. My TV also has optimizer options such as "Game Mode" and "Video/Photo Enhancer", which can normally be enabled or disabled on a per-HDMI port basis, but again these options are all greyed out. When I try to change them, my TV says "Feature not available for PC input". I have done a context-sensitive google search for this error and have not found a single result on the entire Internet, hence me posting here in desperation.

The computer with the 8800GT does not detect as a PC, and is detected as an "HDMI" input, which allows to me change any setting just like I could on my PS3.

If anyone actually knows a solution please let me know. Thanks.

What happens if you use the DVI TO HDMI cable from the 8800 with the GTX280 ? , maybe the DVI>HDMI adapter is the problem ? I know one of the DVIto HDMI adapters I had did not work .
Score
0
November 25, 2009 5:33:24 AM

OMG!!!!!!!!!! I am also in the same boat! I felt like i scoured the entire internet to no avail! I am having the same issue: I have a HTPC set up via HDMI cable to a SOny KDLv4100. My video card is a radeon HD 4350, so there is a HDMI output which I am using. However, when feeding into the sony TV, the tv recognizes it as a PC! In this mode, the only picture options I have are VIDEO and TEXT, and forget about all the advancing setting and cinemotion options, they are non-existent in PC mode.

I have yet to come up with a solution, and it is VERY annoying because I want to watch my media with Cinemotion on. I did, however, find a workaround. I have an ATI card, and there is an option for force the EDID of 1080p/24 instead of 1080p/60. When doing this, the refresh rate is only 24hz, so mouse movement isn't as smooth. BUT, if you hit display on the TV remote, u will see that it recognizes this input as a TV, as the resolution above is 1080p/24. THe onlly bad thing about this for me is that in Windows 7, when i open the media center, the resolution of media center is set to 1080p/59.94, and it reverts back to PC mode (which is where i watch my media~!)

I've messed around with the settings in media center and if u can believe it, i made it worse. Now not only am I still in PC mode in media center, full screen media center does NOT take up the whole screen. so I have a nasty black border going around the screen. And the weird part is, it's only in media center... the regular windows screen has no overscanning issues. it's 2:30AM here on a work night, so I'm going to retire from it tonight.

If I use a DVI-to-HDMI adapter to connect to the TV, i do NOT have this issue; the TV recognizes it as a non-PC source. HOwever, I won't have sound either as I need the sound from the HDMI cable to go into the TV to decode.

mY suggestion to you is to mess around with your nvidia software. Try forcing a different output. When doing so, hit display info on your tv remote to see what your TV is recognizing. over the weekend, im considering a reinstall. From what I read, when Media Center does an "auto adjust", there is no reverting back. So i'm stuck.

I want to call Sony, but I'm afraid they'll point to the aTi card. and if i call ATi, they'll point to Sony. If you make any headway, let me know. I'll do the same.
Score
0
Related resources
December 2, 2009 1:18:46 AM

It's definitely an issue on Sony's end. It is their design intent to detect PC sources, and forcibly limit the image quality. It's because they want you to watch movies on their Bluray players and play games on their PS3, they don't want you using a PC for these things. Sure, they make PCs, but nobody buys them because they are terrible and expensive.

What's interesting is you say if you use a DVI-to-HDMI adapter that you don't have this problem. I'm using a DVI-to-HDMI adapter and it is detecting as a PC input. I can't find a work-around.
Score
0
December 2, 2009 1:56:14 AM

huy1224 said:
OMG!!!!!!!!!! I am also in the same boat! I felt like i scoured the entire internet to no avail! I am having the same issue: I have a HTPC set up via HDMI cable to a SOny KDLv4100. My video card is a radeon HD 4350, so there is a HDMI output which I am using. However, when feeding into the sony TV, the tv recognizes it as a PC! In this mode, the only picture options I have are VIDEO and TEXT, and forget about all the advancing setting and cinemotion options, they are non-existent in PC mode.

I have yet to come up with a solution, and it is VERY annoying because I want to watch my media with Cinemotion on. I did, however, find a workaround. I have an ATI card, and there is an option for force the EDID of 1080p/24 instead of 1080p/60. When doing this, the refresh rate is only 24hz, so mouse movement isn't as smooth. BUT, if you hit display on the TV remote, u will see that it recognizes this input as a TV, as the resolution above is 1080p/24. THe onlly bad thing about this for me is that in Windows 7, when i open the media center, the resolution of media center is set to 1080p/59.94, and it reverts back to PC mode (which is where i watch my media~!)

I've messed around with the settings in media center and if u can believe it, i made it worse. Now not only am I still in PC mode in media center, full screen media center does NOT take up the whole screen. so I have a nasty black border going around the screen. And the weird part is, it's only in media center... the regular windows screen has no overscanning issues. it's 2:30AM here on a work night, so I'm going to retire from it tonight.

If I use a DVI-to-HDMI adapter to connect to the TV, i do NOT have this issue; the TV recognizes it as a non-PC source. HOwever, I won't have sound either as I need the sound from the HDMI cable to go into the TV to decode.

mY suggestion to you is to mess around with your nvidia software. Try forcing a different output. When doing so, hit display info on your tv remote to see what your TV is recognizing. over the weekend, im considering a reinstall. From what I read, when Media Center does an "auto adjust", there is no reverting back. So i'm stuck.

I want to call Sony, but I'm afraid they'll point to the aTi card. and if i call ATi, they'll point to Sony. If you make any headway, let me know. I'll do the same.


did you loasd the ati hd sound drivers , my ati4650 would not play sound till i loaded the ati hd audio drivers
Score
0
a b x TV
December 2, 2009 12:47:53 PM

Read the post below. You may have similar issues pertaining to SONY LCD TV and NVIDIA Cards

http://www.tomshardware.com/forum/275338-33-blue-stutte...

I have 8800GT OC 512, GTX 280C connected to HDTV (52 inch, 70 inch) and both work like a charm @ 1080P. I have another setup with 2x4890 connected to a 70inch HDTV. No problem at all @ 1080P.

I have been playing with Aus 5870 lately on my 70 Inch HDTV and i dont have such problems that you guys see.

All of my connections are through HDMI.

I suggest you read the manual of your Sony TV and see if there are video features that needs to be tweak. This may be potentially a SONY specific related issue. It can be a settings related problem. Read your Sony HDTV LCD Manual.

Score
0
December 2, 2009 5:51:29 PM

leon, the post you linked is a completely different issue. Our issue is that since our TV is detecting the source as a "PC" input over HDMI, it is disabled almost all picture adjustments.

The solution in the thread you provided says to toggle Game Mode and other optimizers. All of these optimizers (Game Mode, Photo Mode, etc.) are disabled and greyed out. There is nothing to adjust.
Score
0
a b x TV
December 2, 2009 6:30:35 PM

GTX 280 OC you should get a audio and video through HDMI. You need to use DVI-HDMI converter. The Audio on GTX 280 OC is PASS THROUGH via the SPDIF link between the video card and Soundcard(PCIE base sound card or motherboard built in sound card).

ATI 3000, 4000,5000 family video card will pass Audio & Video through HDMI. You need to use the DVI-HDMI converter from ATI.

I tried Mitsubishi, Pioneer, Samsung, and JVC. I got it all to work audio/video through HDMI at 1080P.

8800GT OC 512: HDMI, Video 1080P, Audio-NA.. No Audio option on 8800GT OC
GTX 280 OC: HDMI , Video 1080P, Audio OK(SPDIF Linke bet Video card/Sound card)
3870 512 : HDMI, Video 1080P, Audio OK
4870 512 : HDMI, Vide 1080P, Audio OK
4890 XOC 2x CF and Single 4890: HDMI , Video 1080P, Audio OK

Each TV manufacturer have some intricacies for PC interface to work. Read the manual and play around with it.

Make sure you have administrative privileges when change video settings.

Clean up your video driver. Make sure there is no remnants of OLD driver before you install the latest one.

Score
0
December 3, 2009 1:27:23 AM

just tried it on my sony kdl4900 32" , works fine , does not downgrade pic 720 p and blu ray look great . Using HIS 4650 fanless with 1gb mem , xp pro , opteron 185 , 2 gb ram . Only thing was had to dl and add the ati hd audio drivers to get sound through hdmi .
Have it on hdm1 2 on the back of the sony , if that makes a difference .
Score
0
December 3, 2009 3:52:38 AM

I was pretty excited to try the game mode on / theater mode off trick, but moohz is right. that is a completely different issue. I did find some forums discussing the use of an application called "PowerStrip." Supposedly able to adjust the timing of the output, changing it from PC-timing to video-timing (which is what we need). Never got it to work though, but I didn't get too in depth with it. I did adjust something in it and the TV said it was an unrecognized input, so i ended up uninstalling the PowerStrip program to get it back to normal. Will try to research it more over the X-Mas break.

In the ATI forums, it's said that ATI Drivers is the issue. Apparently, Catalyst Center 9.2 and outputs it as PC timing instead of video timing.

But there are other forums citing, as moohz has mentioned, that it is a TV issue.

In either case, don't bother calling Sony support, they are worthless. She actually recommended that I plug my PC in via the VGA input. Seemed like she heard the word "PC" and used her handbook to give a response. ugh.

I'd recommend googling "PC Timing" and various words for your case: Sony, Nvidia, GeForce. Let me know what u find, I'll do the same~
Score
0
December 3, 2009 5:40:43 AM

Of course it is a Sony issue. I am using an NVIDIA card and you are using an ATI card with the same issue. And the issue isn't that the TV is detecting a PC input, that's fine. But why is it disabling most of the picture quality adjustments due to the source being a PC input?

It even has an error message preprogrammed, "Feature not available with PC input". But it works with VGA, which is also a PC input. They just don't want people to have digital high-def quality movie and game sources to be streamed from PCs if it cuts into their other markets of Bluray players and PS3s. It's despicable.
Score
0
December 3, 2009 5:56:43 AM

I feel the pain.
Score
0
December 14, 2009 3:19:55 AM

Ok, has anyone gotten anywhere with this? I've been having the same problem with HD 4890 dvi-hdmi adapter, and sony bravia z 52''. Can anyone help?
Score
0
May 26, 2010 10:43:21 PM

Similar problem here - I can make changes on ATI control center when its open and they show on the screen - but as soon as I click 'apply' they last about 1 second before going back to what they were before.

Its as if the Sony TV is somehow feeding back through the HDMI cable back to CCC and putting them back to defaults.

The only other thing it could be is maybe I'm not running CCC in admin mode (as I saw the hint in this thread) - I'll try that when I get home - but there is no prompting to run in Admin mode though
Score
0
October 2, 2011 6:31:22 AM

For those with Nvidia cards, try this:

Nvidia Control Panel > Display > Adjust desktop color settings >

"Content type reported to the display:" - change from "Auto-select (recommended)" to "Full-screen videos"

I just encountered this problem when I upgraded my HTPC from Windows XP-32 MCE to Windows 7 Professional 64-bit. The WinXP32 system was always recognized as a regular digital video source and my Sony KDL-52XBR6 TV treated it just like any other source. All picture adjustment options were available. Then I put Win7-64 on a separate partition and upon hooking it back up to the TV, the TV insisted it was hooked up to a "PC" and offered only "Text" and "Video" for picture modes on that input.

Since I had not made ANY changes in my hardware I knew it was not a hardware issue. I started poking around in the Nvidia Control Panel looking for something that had to do with how the Nvidia card identified itself to the TV. "Content type reported to the display" seemed promising and when I changed it to "Full-screen videos" that fixed the problem. Once again all picture adjustment options are available for the HDMI port that the HTPC is connected to.

MSI GTX-9800 video card
Gigabyte GA-965P-DQ6 mobo
Intel Core 2 Quad Q9550 Yorkfield
8GB Kingston Ram
Windows 7 Pro 64
Sony KDL-52XBR6
Score
0
a c 171 Î Nvidia
October 2, 2011 7:11:36 AM

This topic has been closed by Mousemonkey
Score
0
!