Sign in with
Sign up | Sign in
Your question

Windows 7 install fails with Intel X25-M G2 SSD on P5k Premium Wifi

Last response: in Motherboards
Share
May 16, 2010 8:25:31 PM

Hi,

I find myself unable to install Windows 7 on my newly acquired SSD - an Intel X25-M G2 80GB.

I have original installation DVD's for Windows 7 Home Premium (32 & 64 bit), and Professional Edition - these work flawlessly on other PC's.

My PC configuration:
MB: ASUS P5K Premium WiFi - BIOS 1101 (newest)
CPU: Intel Q9400 Quad Core @2,66GHz
RAM: 2x2GB Corsair Dominator XMS
GPU: MSI Geforce 8800GTX 768MB
Plextor DVD-RW
PSU: Seasonic 500W

The installation fails every time during extraction of Windows installation files. 64 bit editions stop at 1% and 32 bit randomly at about 12-24%. This part of the installation takes much longer than normal, and the DVD drive spins up and down a lot. Finally there's an error message - needed files cannot be accessed - error code 0X8007045D.

I've tried mounting the SSD in my other PC (Media PC in the living room) and install Win7 on that configuration - works without problems.

After that i moved the SSD back to it's intended host PC (with Win7 installed), and used it there for about one week. This was a pain as the system chrashed very often (and always upon resume from sleep), and general performance was very unimpressive - read speed was measured at about 140MB (peak).

Finally i got tired of this, and reformatted the drive.

I have since tried repeatedly to reinstall Win7, but without success.

Other things I've tried:

- Update/reflash of ASUS P5K BIOS (ver. 1101 - newest)
- Configuration of SATA in BIOS for either IDE/ACHI/RAID
- Newest Firmware in SSD
- Tried both 32 & 64 bit versions of Windows 7
- Tried installing Vista 64 bit - same problem
- Removing all but 1 RAM block - tried different make of RAM (Samsung)
- Exchanged SATA cable
- Tried different SATA port
- Tried to run installation of Windows 7 from USB flash pen

In addition I've:

- Tried using an Intel 40GB V-edition SSD as system disk instead - same problem (this disk also works without problems in my other PC).

- Tried reinstalling Win7 on my old original system disk - a Seagate 160GB SATA HDD - this worked without problems.

All of the above statement lead me to believe, that it is my motherboard, that dosn't accept SSD's.
I can find articles from users, who have used SSD's with this motherboard without problems (even the same Intel SSD), which leaves me in all kinds of doubt.

Do any of you smart people have any suggestions as to resolve my situation?

Is there a way to make my SSD work with my motherboard?

Alternatively - would it be safe to conclude, that I could make my system work, if I exchanged the motherboard? I'd rather not spend the money if not...

Any help would be highly appreciated!
a b Ĉ ASUS
a b å Intel
a c 435 V Motherboard
May 17, 2010 12:47:52 AM

Here is what worked for me. I had no problems using a kingston value ssd. But with a partiot ps-100, I had to be creative. Using maxblast 5, I had a board failure while trying to do a drive to drive copy. So after sending the board back to biostar (rma time 9 days which is excellent), I bought an identical spare board at frys. Using maxblast 5.0, I setup the patriot drive as the new boot device, selected a drive to drive copy, and the system powered down. I disconnected the patriot ssd and rebooted with the sata drive until the windows screen appeared, and quickly connected the patriot drive so maxblast would see it and finish the drive to drive copy. What I think happened the first time was that windows was trying to boot up to the empty ssd and the board crashed. Maxblast won't load without windows running in the background. This time maxblast worked fine, and I disconnected the sata drive to save energy. If you need your sata drive for storage, then you may want to make it a secondary device while using the ssd. This may require a format by maxblast; you'll just have to try it. You can backup your files first with windows 7 using a dvd.
May 17, 2010 7:35:49 AM

Ok, if I understand your suggestion correctly, I should install Win7 on my old SATA HDD, then install Maxblast on it, and then try to mirror the HDD onto the SSD?
And during this process disconnect the SSD from the system during BIOS post, and then reconnect it as Windows loading screen appears?

I can give it a try. I'll get back with the results when I get home from work (Im on CET - Denmark).
Related resources
May 17, 2010 7:41:37 AM

I should probably add, that every time the Win7 install has failed, I've simply deleted the MBR using a boot tool before retrying.

Would it perhaps help if I performed a complete drive format (i.e. returned the drive to its "new & unused" state?

How is this best done with a SSD?
a b $ Windows 7
a b V Motherboard
May 17, 2010 5:21:34 PM

I would check memory voltages in bios and run memtest over night.
May 17, 2010 7:17:48 PM

I came home this afternoon and tried a new approach - this might also work for others, who are experiencing errors while Windows installation is expanding files...

Having read some entries on the Asus support forum, I downloaded the latest Intel ICH9R/Rapid Storage Technology drivers.

I then selected the "Have driver disk" during install process, and had Windows installation update the driver - and it worked! Installation completed without problems, and there is no apparent slack in disk access times like before.

Only remaining issue is read speed performance - HD Tune says avg. speed is about 125MB/s - only about ½ of the theoretical max value of this drive, or so I understand.
So now I get to look into that...
!