Sign in with
Sign up | Sign in
Your question

RAID 10 pauses

Last response: in Storage
Share
October 9, 2011 4:09:31 AM

Hello, I have an annoying RAID problem. THis is my 1st RAID array and so far the experience has been frustrating.
I set up a raid 10 array of 4 1tb barracuda 7200.12 sata II, stripe size 64kb and cache mode:writethru(couldn't change it to write-back). Read and write speeds are pretty good but I get random pauses. Basically the entire system becomes unresponsive with the hdd led off and it comes back to life again. For example if I installing something, the install progresses fast then stops for about 10 seconds and then finishes even faster. I have a SB700 southbridge, and I'm going to exchange the board for something with a sb800 southbridge tomorrow in hope that the problem goes away. I also didn't have to install any raid drivers when installing w7 on the array. Could that be the problem?

More about : raid pauses

a b G Storage
October 9, 2011 6:05:45 AM

hmmm, are your hard drives somehow set to powersave or something similar? sorry im not really sure how to explain it, ive only seen the problem in laptops where to save power they stop spinning inactive drives every like 2mins or so, then it needs to restart its spin cycle + read all the current data and the data needed to do what you want it to do
a b G Storage
October 9, 2011 10:41:19 AM

make sure you update your raid drivers when you get into widnows and you should be fine. teh above suggestion is my first guess as well.
Related resources
October 9, 2011 1:36:14 PM

mouse24 said:
hmmm, are your hard drives somehow set to powersave or something similar? sorry im not really sure how to explain it, ive only seen the problem in laptops where to save power they stop spinning inactive drives every like 2mins or so, then it needs to restart its spin cycle + read all the current data and the data needed to do what you want it to do


But would powersave randomly kick in during heavy io operations?
a b G Storage
October 9, 2011 4:35:08 PM

power save would not but if the power was already low it could choke the drives?

heavy io ops sounds like your CPU/controller is being over loaded. go into your system management windows and go to event viewer, sort by severity and see if you have any disk/controller/ntfs errors in there.
October 12, 2011 2:46:38 PM

ncc74656 said:
power save would not but if the power was already low it could choke the drives?

heavy io ops sounds like your CPU/controller is being over loaded. go into your system management windows and go to event viewer, sort by severity and see if you have any disk/controller/ntfs errors in there.


Nothing about that, but the cache mode is writhru. Could the pause be happening because the mirrored drive need to be synced? How do I enable writeback? I can't select it in RaidXpert.
!