Sign in with
Sign up | Sign in
Your question

Reading a single RAID disk in a guest non-RAID PC

Last response: in Storage
Share
Anonymous
a b V Motherboard
a b G Storage
October 9, 2011 2:24:41 PM

When my PC was set up (years ago) with a single 500Gb disk, the motherboard VIA RAID driver was loaded (pressing F6) when Windows XP was installed. The Motherboard has now gone bad.

How can I read my single disk in a different PC as a guest drive to recover the data? (Yes, I know, but my backups don't contain absolutely everything to date!) The disk is partitioned as C: and D: with the total space on these logical drives totalling the physical size of the drive so there is no data redundancy. BUT, I know that when it was working, if the RAID ROM was disabled in the BIOS on bootup, the system wouldn't boot. So, I expect problems in trying to read the drive in a guest machine....

I do have the original VIA RAID driver disk, but I assume that it will be useless wiithout the appropriate chipset, and I don't want to try installing RAID on my or a friends PC if it doesn't already exist (Would my VIA chipset flavour of RAID be compatible with anyone else's flavour, anyway?)

I haven't had the opportunity to experiment yet, but I mustn't lose the data, and time is short, so any help would be greatly appreciated.

Thanks, Sally Jelfs

(This has vague echoes for me of the good 'ole ATA-SASI days, pre-IDE, when HDDs only worked with the controller they were formatted on...!)

More about : reading single raid disk guest raid

a b V Motherboard
a c 415 G Storage
October 9, 2011 3:33:03 PM

My understanding is that the Linux LiveCD distributions (such as Ubuntu, for example) have drivers that can understand the on-disk format of most RAID implementation. If you download it, burn it to a CD and boot from it, you should be able to see the files on your drive so that you can transfer them to another disk.

Although I'm a bit surprised that you're having problems since there's generally nothing special about the way data is recorded on single-volume disks (also known as "JBOD" for "Just a Bunch Of Disks") and I'd rather expect that you'd be able to read it just by attaching it to whatever new system you have.
a b V Motherboard
a c 362 G Storage
October 9, 2011 8:17:03 PM

I agree with sminlal - I am surprised to read that you expect a single disk NOT to be readable in another machine. It is quite true that you generally cannot use a RAID HDD in a machine with a different RAID controller chipset. However, I am not convinced you actually have a RAID unit.

You see, there is no such thing as a RAID array using only one "drive". Now, I can understand the possibility that a RAID1 array could have been created from two Partitions on a single HDD unit (to provide redundancy), but that is a poor design. I cannot imagine anyone trying to build a RAID0 array from two Partitions on one HDD. You have not said (may not know) what type of RAID array you think you have.

Another possibility occurs to me. On many machines and mobos with SATA systems, the device drivers for SATA units were combined with the drivers for RAID controllers, and installed as if they were just a RAID driver. In fact, there were two sets of drivers being installed at one time, and the distinction was almost hidden. On such systems, if you wanted to use true SATA devices properly (as AHCI devices) you had to install the requisite driver, and it was often called the "RAID driver" even though it served both types of devices. Certainly if you wanted to boot from that drive as an AHCI device, you needed to install the driver using the F6 key when installing the original OS (especially if you were using Win XP). MAYBE that is what you had to do.

Now, you say, "I know that when it was working, if the RAID ROM was disabled in the BIOS on bootup, the system wouldn't boot." What do you mean, "RAID ROM disabled"? Do you mean if you went into BIOS Setup and altered the SATA Port Mode setting from SATA or RAID to IDE Emulation, that would cause the boot failure? If that is the case, it makes sense. If your HDD were really being used as an AHCI device with the properly-installed driver, changing its treatment by the BIOS to an IDE Emulation mode would certainly cause mis-reading and boot failure.

SO, if you really do NOT have a RAID array somehow on a single HDD, there is a good change what you actually have is a normal SATA HDD that needs to be handled as such - and that really means, as an AHCI device, the real mode of SATA drives. It happens to have two Partitions on it, but not RAID volumes. If that is the case, you CAN mount it in another machine as a normal SATA HDD, with the SATA Port Mode set to AHCI device type, and it should be completely usable.
Related resources
October 20, 2011 12:14:11 PM

Dear All,

Thank you for taking the time to reply with some useful information - it's much appreciated. For info when this is archived, the ASUS motherboard is by now ancient, and although it has integral SATA ports, the support for it is not in the BIOS, it has an additional SATA RAID BOOT ROM based around the VIA8237 chipset and drivers. The BIOS only allows this ROM to enabled or disabled. As I recall, when the system was first built many years ago with a single 500Gb SATA HD, the only way it would work was to enable the Boot ROM and use the supplied VT8237 drivers from floppy when installing Windows XP (and F6 in the first screen!)

The HD was partitioned into C:( Sally-progs) and D:( Sally-data) as I've lost C-drives before to suicidal OS's requiring a format as the only way forward. The intention being to never keep anything in C which I couldn't reload easily. But 'My Documents' slipped through the net. Now that the mobo has died. I needed that data back, together with 460Gb of photos etc from D: When I posted this thread, I had not had a chance to examine the disk as none of my other machines talk SATA, let alone RAID. So, I bought a SATA/USB interface cable, and the story continues....

Using this cable, I found that I could only see D:( Sally-data). No trace of C:( Sally-progs). Phew. At least most of my archive could be checked and backups properly updated, but I still had stuff in My Documents on C:( Sally-progs) relating to current negotiations which it would be awkward to lose.

I had heard that it *ought* to be possible to read the drive using a linux of some description, although the one I initially tried was perhaps too small or specific or whatever. Maybe even finger trouble as I'm not a linux afficionado. Whatever, I then moved on.

Google brought up RAID recovery programs which did not help as I did not *actually* have a RAID array. (But who knew from the little info when installed? Documenation is usually useless when trying to find anything out.)

Finally, a program called 'GetDataBack' was a star! It scanned the drive, found and identified the partitions, and allowed the resident data on C:( Sally-data) to be copied to a new home on a new drive. PROBLEM SOLVED! Windows disk management could see that there was something there, but wouldn't handle it in normal Windows until it had been reformatted (after the data was removed!)

I assume that the root cause of the pain was that the implimentation of the disk RAID structure necessitated by the driver requirement made it VIA-specific. Maybe a modern implimentation would say 'No RAID!' and then make the drive layout standard? It's the devil in the detail - as usual. Anyway, thank you all again - especially 'addict' for your help.

SexySally.
October 20, 2011 12:17:05 PM

Sorry - 'Thanks especially to Paperdoc'! - I'm new here and mis-read the author.
a b V Motherboard
a c 362 G Storage
October 20, 2011 6:17:27 PM

Happy you got all your data back. This is another testimonial (I've seen others) to GetDataBack for data recovery without having to fiddle around a lot.

My guess is that your old machine with the VIA chipset and drivers was NOT using this as a RAID unit, but somehow did write some data to it that does not conform to the current ways of handling SATA devices. Most likely the error is in the Partition Table entry for the first Partition. It appears the Partition Table structure itself was OK, but Win XP could not understand the specific entry for the first of the two Partitions (your C: drive). Anyway, thanks for posting the update of your story's successful end.

Since you now have all the data recovered from that old HDD and are using a new computer, you have a spare 500 GB HDD to use. I suggest you wipe out all its previous Partitions, then Create one or more new ones on it (Primary Partitions, but not bootable since you are using for data storage only) and Format it (them). You can use Windows Disk Management tools for that. This should re-write all the structures needed using current Windows tools and your new machine's 'standard SATA controllers, so it should work just fine.
March 23, 2014 6:46:35 AM

Reviving this thread as with NAS development, more and more questions pop up.
Actually I also faced the same kind of problem, my NAS crashed (Synology DS209, after 5 years of good service), so I was without my data. Looking further I realized my NAS creates ext3 or ext4 partitions. So all you need is to install ext3-4 capable drivers.
Ext2fsd is an open source driver that does the job perfectly. No need for fancy software, just plug the drive in your computer (directly on SATA or via a USB adapter), mount the drive using ext2fsd (do not forget to start the service if you did not restart your computer, tools\service management ) and copy the data you need.
Et voila...
!