Sign in with
Sign up | Sign in
Your question

Trying to revive HDD after power failure

Last response: in Windows XP
Share
May 15, 2012 5:16:26 AM

I hate to have to ask this, but I'm now suffering a migraine from stress :fou:  and being parked in front of my pc trying to fix it so I'm running out of options. So here goes:

I have a pc that was plugged into a surge protector. I always leave it on so when we had a power outage, it was turned off. When trying to access my wifi, that's when I realized my pc was off. The surge killed something in my dsl modem (which was fine because I got a free upgrade :wahoo:  ), the adapter plug for my router, and, at the very least, my power supply. Until I got the funds for the physical end, I wanted to see how my HDD survived.

I installed the HDD into my son's pc as a second drive and I was able to access the contents. Was even able to play a game that is ONLY located on my HDD! So, with that being said, we'll call my HDD D: and my son's C: and refer to as such from here on out.

When booting my harddrive, I came up with a BSOD "STOP: c000021a (Fatal System Error)
The windows Logon Process system process terminated unexpectedly with a status of 0xc0000135 (0x00000000 0x00000000).
The system has been shut down."

After attempting MANY suggestion fixes, nothing worked. One suggestion...to use SyncBot to replace files from C: to D:. That was a HUGE mistake. When I tried to boot normally into C:, I got stuck in a logon loop saying " A problem is preventing Windows from accurately checking the license for this computer. Error code: 0×80070002." Neither of the MS fixes worked.

At this point, I was able to get into Safe Mode with either HDD. Since I couldn't get past the license logon loop, it led me to creating a bootable cd. Both HDD originally had XP Media Center with SP3 (D: was preloaded on by eMachines). I have an XP Pro installation disc, an XP2 upgrade disc and I downloaded SP3 and slipstreamed them all together since I wasn't able to uninstall SP3 from either drive. I ran the disc and was able to do a reinstall repair of C:. So, that HDD is now without problems so obviously the CD was made correctly. I tried to do a repair install on D:. I'm still having issues. I ran CHKDSK /p (wouldn't let me do /r). It told me there were one or more errors on the volume. I went to Western Digital's website and downloaded the Diagnostic tool onto a flash drive. I went into SafeMode on D: and did both a quick check and extended check. According to WD's tool, the disk passed both tests so there should be nothing wrong physically with the D: When I went into SafeMode on D:, it kept finding new hardware. Don't know if that's relevant, but now, it probably isn't. So now I ran the slipstreamed CD on D:. Along the way, when loading setup files, there were a few that couldn't load. I could pick "ESC" to ignore or "ENTER" to retry. Some went through when I hit Enter...others refused to but they seem to point to Windows Media Player so I figured they shouldn't be missed if they didn't load. When all was said and done, I tried to reboot and got a different BSOD saying "STOP: c000021 (Bad Image Checksum) The image WOW32.dll is possibly corrupt. The header checksum does not match the completed checksum." So...I loaded into C: and copied the wow32.dll file from the System32 folder of C: into the System32 folder of D: It seemed right since the file on C: was larger than on D: and both HDD now had the same exact OS install. I was going to copy the wow32.dll file in the I386 folders, but they were the same size so I canceled that. I rebooted into D: and was back to the original BSOD. So...I tried to get into the Recovery Console via CD and now I can't get into it. It told me that there was an upgrade currently in progress. I could Exit, Continue with the current upgrade, or Quit the upgrade and start a new install. I tried to continue the upgrade and it seemed to work fine except I got back to the Bad Checksum STOP BSOD. I tried to quit the upgrade and start new and that doesn't work either. I'm now STUCK in the install process. I also now cannot get into SafeMode on D: I can still access D: through C:

I don't know what I should do or try from here. I don't know if I should disable C: or C: and D: in BIOS and try to do it that way. It doesn't seem to make a difference what I do with BIOS when it comes to this since the CD can access both even if they aren't set to boot.

I thought to copy the boot.ini from C: to D:, but at this point, I don't want to chance screwing anything else up.

Any advice with clear, concise directions would be very much appreciated at this point. I can copy my files off D: onto either C: (don't think I have enough room though) or I can save some files in SkyDrive in Hotmail...or both. It's bad enough I might have to rebuild my pc (really hoping it's just the power supply and not the mobo) again (just rebuilt it 4 yrs ago).

If there's any other info you need, please let me know! Sorry it's so long, but I tried to get all the questions answered ahead of time. Thanks in advance!!
May 15, 2012 9:15:42 AM

the found new hardware was relevant since the BSOD is most likely caused by the Windows on the D: trying to load the chipset/controller drivers of the old motherboard.

look into 'Fix HDC'
m
0
l
May 15, 2012 8:01:01 PM

Emerald said:
the found new hardware was relevant since the BSOD is most likely caused by the Windows on the D: trying to load the chipset/controller drivers of the old motherboard.

look into 'Fix HDC'


Makes sense. Thanks! I did do something in the meantime. I decided to download the wow32.dll and replaced the one on D: and I can now get into SafeMode. But when I did, it said that Setup cannot be finished in SafeMode. It quit and restarted. It then said setup was starting. I thought that maybe we'd be able to move forward, but no. First I got a I386\halaacpi could not be loaded error. I've come across that before and once I rebooted the CD, it either finished or I'd get another xxx could not be loaded.

Well, off to work. I'll tackle it again tonight after work. Thanks for any help!
m
0
l
!