Sign in with
Sign up | Sign in
Your question
Solved

Limited Access / No Internet (802.11n Wireless)

Last response: in Components
Share
January 30, 2010 7:26:46 PM

Hi everyone,

I have a strange problem I need some help with. I recently upgraded our home wireless router to a D-LINK DIR615. Everything worked just fine for the past 30 days or so.

About three weeks ago I bought some cheap Wireless-N USB adapters so that all wireless connections would be 802.11n and wouldn't be mixed. All worked fine up until the past few days.

I'm running Windows 7 64-bit on all computers (except one, which has a wired connection, is running XP). On the two computers with the "Tenda W311U" USB Adapter, I see my network available to choose from, but when it tries to connect, it hangs up for a while then eventually will say "Limited Access" or "Network Access Only" something along those lines. Maybe 1 out of 10 or 20 tries will get me connected. It seems if I restart the PC, it helps, but that may just be luck

I've tried re-enabling my built-in 802.11g on my laptop and I'm getting the same errors. So, is this a router issue...?

Any idea why it would have worked just fine for the past month and now all of a sudden it's causing problems? Do you think the fact that I bought these cheap, no name USB adapters had anything to do with it (i.e., did I get what I paid for :p  ).

Thanks,
Steve
January 30, 2010 7:30:41 PM

I encounter hiccups like that on occasion and it resolves itself after I go and reboot the router.

I have no idea what causes it but it seems to happen at least once a month or so.
m
0
l

Best solution

January 30, 2010 8:10:47 PM

Reboot the router and try switching channels.
Share
Related resources
January 30, 2010 8:54:07 PM

LoneWolf_53 said:
I encounter hiccups like that on occasion and it resolves itself after I go and reboot the router.

I have no idea what causes it but it seems to happen at least once a month or so.


I forgot to mention in my original post that when the problem first occurred (on my laptop only) - I rebooted the router & the cable modem and all was fine for a few days. Now yesterday and today, it's both PC's that have this USB adapter... I just wish I knew if it was the router or the NIC.

Is it possible since they're the same Adapters, they're trying to assign the same IP address and getting confused / stuck? I don't know much about the internal workings here, so I'm not sure if that's even a possibility...

daship said:
Reboot the router and try switching channels.


What do you mean by switching channels? Is this something I need to do in the set-up for the router? I'm pretty sure I set it up with the recommended settings and didn't do any manual set-up at any point...

Thanks,
Steve
m
0
l
January 31, 2010 6:14:29 PM

daship said:
Reboot the router and try switching channels.


Ok, so I went into the Advanced Manual Settings and changed two things. First, I noticed it was on "Mixed Mode" even though I have all 802.11n adapters. So, I set it to communicate with N devices only.

Then, there was an "auto-detect" channel, but it was preselected for channel 6 or 7 I believe. I unchecked the option for "auto-detect" and selected a channel that was one lower that what it was at.

Now, it connects immediately and there are no hang-ups. It appears this solved the problem. I can disconnect & reconnect immediately!

Thanks for your input. I was ready to try a D-Link adapter, thinking it didn't like these no name brand adapters.
m
0
l
January 31, 2010 6:14:39 PM

Best answer selected by steve9207.
m
0
l
January 31, 2010 6:44:39 PM

go for channel 1 6 or 11

the other ones are actually in between channels and overlap.

ie 5 overlaps with 3,4--6-7

m
0
l
January 31, 2010 7:26:22 PM

rand_79 said:
go for channel 1 6 or 11

the other ones are actually in between channels and overlap.

ie 5 overlaps with 3,4--6-7


Ah, good to know, I think I have it on 5 right now, I'll have to go back over and change it...

Not sure if this is even related, but ever since I made the change & put it to Wireless N only, instead of mixed, my signal strength has increased dramatically. Before I would get 2 or 3 out of 5 bars. Now I'm getting 4 or 5 consistently.
m
0
l
October 6, 2012 4:15:42 PM

I had the same issue and here is whatIi did to fix it.

1. Went on problem computer, did ipconfig /all in command prompt to find the MAC address.

2. Went into my router settings and clicked DHCP Reservation.

3. Manually add client: Pick a name, assigned IP 192.168.1.148, put in MAC address and save changes.

4. Went on a computer hardwired to router with working internet. Ipconfig /all in command prompt to find DNS server, there were 3, I took note of the first 2.

5. On troubled computer: Control panel -> Network and Sharing Center -> Connection properties -> click Properties then select "Intenet Protocol Version 4 (TCP/IPv4)" click properties.

This guide describes this part best (with pictures):
http://www6.nohold.net/Cisco2/GetArticle.aspx?docid=816...

6. Use the following IP address:
IP Address: The IP we reserved earlier 192.168.1.148
Subnet mask: Gets filled in automatically 255.255.255.0
Default Gateway: 192.168.1.1 (what ever you type in your address bar for your router settings, I think all Linksys is this address)

Preferred DNS and Alternate DNS Server: The two DNS IPs I wrote down in step 4.

That fixed it for me.
m
0
l
October 6, 2012 4:16:10 PM

I had the same issue and here is whatIi did to fix it.

1. Went on problem computer, did ipconfig /all in command prompt to find the MAC address.

2. Went into my router settings and clicked DHCP Reservation.

3. Manually add client: Pick a name, assigned IP 192.168.1.148, put in MAC address and save changes.

4. Went on a computer hardwired to router with working internet. Ipconfig /all in command prompt to find DNS server, there were 3, I took note of the first 2.

5. On troubled computer: Control panel -> Network and Sharing Center -> Connection properties -> click Properties then select "Intenet Protocol Version 4 (TCP/IPv4)" click properties.

This guide describes this part best (with pictures):
http://www6.nohold.net/Cisco2/GetArticle.aspx?docid=816...

6. Use the following IP address:
IP Address: The IP we reserved earlier 192.168.1.148
Subnet mask: Gets filled in automatically 255.255.255.0
Default Gateway: 192.168.1.1 (what ever you type in your address bar for your router settings, I think all Linksys is this address)

Preferred DNS and Alternate DNS Server: The two DNS IPs I wrote down in step 4.

That fixed it for me.
m
0
l
October 6, 2012 4:22:55 PM

I had the same issue and here is what I did to fix it.

1. Went on problem computer, did ipconfig /all in command prompt to find the MAC address.

2. Went into my router settings and clicked DHCP Reservation.

3. Manually add client: Pick a name, assigned IP 192.168.1.148, put in MAC address and save changes.

4. Went on a computer hardwired to router with working internet. Ipconfig /all in command prompt to find DNS server, there were 3, I took note of the first 2.

5. On troubled computer: Control panel -> Network and Sharing Center -> Connection properties -> click Properties then select "Intenet Protocol Version 4 (TCP/IPv4)" click properties.

This guide describes this part best (with pictures):
http://www6.nohold.net/Cisco2/GetArticle.aspx?docid=816...

6. Use the following IP address:
IP Address: The IP we reserved earlier 192.168.1.148
Subnet mask: Gets filled in automatically 255.255.255.0
Default Gateway: 192.168.1.1 (what ever you type in your address bar for your router settings, I think all Linksys is this address)

Preferred DNS and Alternate DNS Server: The two DNS IPs I wrote down in step 4.

That fixed it for me.
m
0
l
December 14, 2012 7:32:38 PM

i have done everything on this thread step by step and none of it works. i have a hp pavillion dv6000 i think with atheros 802 whatever wifi adapter and vista home premium. i have tried everything i could find on all kinds of forums. i can connect with ethernet an i can connect to my friends verizon wifi hotspot an i can connect to my netgear if the security is off but i only get local if the security is on??? i had a computer tech bewildered
m
0
l
!