Sign in with
Sign up | Sign in
Your question

M4N98TD EVO AHCI disaster OCZ Agility 3

Last response: in Storage
Share
October 12, 2011 2:43:50 PM

Hello all, I have been advised to post my problem in this section too after having no luck in the ASUS motherboard section. So here goes. I will quickly abreviate what was said in the other thread between myself and the great tom's Hardware member WR2.

Hello all I have just noticed that I never had AHCI enabled and performed the following regestry edit

1.Exit all Windows-based programs.
2.Click Start, type regedit in the Start Search box, and then press ENTER.
3.If you receive the User Account Control dialog box, click Continue.
4.Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINESystemCurrentControlSetServicesMsahci
5.In the right pane, right-click Start in the Name column, and then click Modify.
6.In the Value data box, type 0, and then click OK.
7.On the File menu, click Exit to close Registry Editor.

After this you’ll have to restart your computer, go to BIOS and enable AHCI. When you log in to Windows again, you’ll notice the installation of drivers for AHCI. Another restart will be required to finish the driver installation.

These steps are provided at your own risk and not suggested unless you know and understand the risks. You will want to make sure the controller driver and MB BIOS support this option before you enable it

But after that when I restart in AHCI mode I get this message:
Error CD-ROM boot priority ...no boot Medium Reboot and select proper boot device and press a key or just shoot yourself

The only way I can get windows to boot is to change the storage configuration back to IDE.

Any help would be ferkin brilliant, I have No Idea.

I just re-read what I posted and realized that with what I have written it looks as though I should probably have posted this in the Windows section but what I'm actually asking is where do I get the drivers I need for my Asus M4N98TD EVO that I'm being asked for during the boot process, and once I have them do I have to burn them to a disc and insert it once it asks?...
I can't find them at the official ASUS site and it also looks like I'm missing my coprocessor driver which I also can't find!.

Hello hankmarvin;

drivers for AHCI = SATA drivers.
What version of Windows are you working with?

Windows 7 Home premium 64 bit

Which already has SATA drivers installed.

Have you tried a System Restore yet?

I did yes

This is a fresh install after that didnt work

Just to double check it is in the storage configuration on the first page of the BIOS that I set it from IDE to AHCI isn't it?...why is it asking me to put a disc in and hit any key, what disc is it referring to do you know?...


I'm not familiar with your BIOS:
As far as I know there will only be one place in the BIOS where that change ACHI would be possible.

I didn't know about AHCI before I installed windows the first time. I changed the registry manually via those instructions when I changed the BIOS settings to AHCI it goes to the black screen asking for the boot cd. I unselected AHCI back to IDE it boots to windows again. I ran Microsoft updates until the cows came home. I manually checked all my drivers via device manager, there is only one driver with a problem, the coprocessor is not there and windows cannot find an update for it and neither can I. I figured something had become messed up somewhere along the line and re-imaged windows. Still no joy so I re-installed windows and still no joy. I tried to install windows with AHCI option enabled and it would not do anything, it just said it could not install windows to disc 0 partition 1, the only way to re-install windows that I could find is to just re-install in IDE mode and re-try to manually adjust the AHCI option after again. No joy.
The strange thing is I re ran the Windows System performance test and the hard drive rating did increase even without the AHCI option enabled in the BIOS. It went from 5.9 to 6.5?...how's that even possible!.

I've run out of ideas. A punt to the Storage forum is still an option.
Also - you can edit the topic title here to mention your motherboard and see if you can get a M4N98TD EVO owner to peek in who might know something more.

Hopefully that was coherent, if not then the original thread can be found here
http://www.tomshardware.co.uk/forum/298889-12-ahci-rege...
October 12, 2011 3:21:46 PM

OK so I found a utility on my motherboard disc called ASUS Make Disc Utility, and on that there is a select driver type with all the different options for RAID/ACHI drivers for Windows. I click on the relevant drivers and in the next box it says destination, with only one option found stating that there is "no proper disk found", I only have the one SSD drive plugged in at the moment, does anyone know what this is?...thanks
October 12, 2011 3:41:09 PM

I don't use 'Utilities'.

From your other thread, I posted:

The simplest is to run Fix It -> http://support.microsoft.com/kb/922976

Some MOBO's allow 'some' of the SATA ports to be IDE and others AHCI; it's best to have them ALL one way or the other. THEN go into the Registry or use 'Fix It' but be careful to ONLY change the Start = 0 and nothing else.

See:


IF you accidentally created a corruption, the simplest 'fix' is to play musical SATA Ports with ALL the drives, be careful if there's a RAID and reboot. This causes ALL of the drivers to be re-installed and the Registry values re-written.

Good Luck! :) 
Related resources
October 12, 2011 4:22:09 PM

I ran Mr fix It, but still no luck!. I will go and check to see which of my SATA ports allow AHCI and swap them over to it if I can find out which one it is, why do I always loose manuals!
October 12, 2011 4:27:07 PM

From what I can see in the manual it doesn't appear to be SATA port specific, just enable the on-chip S-ATA controller then select AHCI.
October 12, 2011 4:29:39 PM

musical SATA port time!
October 12, 2011 4:43:55 PM

Annnnnd musical SATA's are a no go too. Is my OCZ Agility SSD definitely ACHI enabled, how do I find that out or are all SSD's ACHI enabled?...I know it has TRIMM
October 12, 2011 5:25:57 PM

TRIM works on BOTH AHCI and IDE, obviously AHCI is a better choice as it's faster.

I didn't realize you had an OCZ SSD until now. Use the latest Firmware -> http://www.ocztechnology.com/ssd_tools/ us a Donor PC to flash it; version 1.7 is the latest.

Tecmo34 wrote a great post -> http://www.tomshardware.com/forum/270102-32-useful-arti...

TRIM:
Go to the Command prompt and type > fsutil behavior query disabledeletenotify

DisableDeleteNotify = 1 (Windows TRIM commands are disabled)
DisableDeleteNotify = 0 (Windows TRIM commands are enabled)

October 12, 2011 7:11:57 PM

To say that I'm apprehensive about removing my ssd and flashing it is a huge understatement, you might as well be saying "get that new fangled petrol powered experimental prototype meat grinder, strip, turn off all the lights and see if you can operate it after drinking a bottle of whiskey."
Do I have to re-install Windows again after?...
October 12, 2011 7:35:43 PM

"The SATA controller must be set to ACHI mode in the BIOS to use OCZ Toolbox Utility!"

Seeing as mine wont boot in ACHI mode I can't use Toolbox to update it.
October 12, 2011 8:28:45 PM

I assumed that you were 'posting' here with a different PC.

Okay, though not my favorite, you can open the Device Manager and Uninstall the [+] Drives and the 'drives' listed in the tree and reboot. This will fully re-install the Drivers and overwrite the Registry values.

On the OCZ SSD posts I've seen and been a part of, KNOCK ON WOOD, it's never deleted <or> corrupted the OS.

Bottom-line, 'something' is either corrupted or the SSD is 'bad' or at least the Firmware is 'old' and causing the problems.

edit: As I stated above "us (USE) a Donor PC to flash it; version 1.7 is the latest." - I mean what I say but I don't always say what I mean...
October 12, 2011 8:45:52 PM

Thanks for all this help I really appreciate it. OK so uninstall the drivers for the OCZ drive in device manager, reboot and at that point try to change the BIOS settings again or just let it boot in IDE mode?...
October 12, 2011 8:54:15 PM

1. Uninstall - Device Manager (as above)
2. Boot into BIOS, change to AHCI. Save
3. Boot into Windows (hopefully) and run Fix It -> http://support.microsoft.com/kb/922976

Let me know - good luck!
October 12, 2011 9:07:02 PM

No luck it didn't work. Time to man up and put it in another computer for a firmware update now methinks!
October 12, 2011 10:26:54 PM

Backup Important Data 1ST!!!!!!
October 12, 2011 10:45:52 PM

Ah, so that would explain why I got a performance increase when I altered the registry values. My system must be running in AHCI mode without BIOS being selected as such like his. My current firmware that doesn't work is the one his works on though!. Thanks for finding that for me, you are a gem!.
!