Asus P6X58D Premium USB running at 1.0 speed

Hello,

I'm hoping someone here can help me. On my Asus P6X58D motherboard 6 of the USB ports are running at 1.0 (full-speed) and 2 ports are running at 2.0 (high-speed). Unfortunately, these should be much faster, 6 ports are suppose to be at 2.0 and 2 ports at 3.0 speed.

What I have tried so far:

1) Un-installed the USB drivers and let the windows 7 64 re-install. I've done this atleast 10 times with the same result.

2) Updated the USB drivers through windows (microsoft) AND updated the 3.0 NEC drivers through Asus web sight.

3) Tried an additional external USB port with the same result.

4) Uninstalled (completely wiped) everything from the SSD and HDD and reinstalled windows and the drivers with the same results.

5) Purchased and installed a second uber power supply with the same results.

6) Contacted Logitech (mouse and keyboard supplier) with no help.

7) Contacted Asus with no help. They just say "it's your drivers."

I'm at the end of my rope and can't figure out how to fix this. I need the USB ports to run at 2.0 or higher for my external devices like my mouse and printer.

System:
Asus P6X58D Premium motherboard
Corsair 6 MG memory
Intel SSD 40gb X 2 running in raid 0
WD HDD Black 1.0
Intel i7 930
BFG Nvidia 260
BFG 1200 power supply
Watercooled cpu block
2 answers Last reply
More about asus p6x58d premium running speed
  1. The only thing I can think of short of RMAing the board is uninstalling the USB host controller (not hubs) and rebooting the computer (PS2 keyboard/mouse). Disconnect all USB devices before uninstalling the controller, reboot when done.

    If you haven't done so install the lastest chipset drivers from the ASUS site, again, install the drivers with the USB devices disconnected.

    Flash to a current bios revision if you haven't done so yet, clear CMOS after flashing. If you're your bios is current clear the CMOS anyways with the USB devices disconnected.

    Your bios USB configuration should be configured as such:
    USB Devices-Enabled
    USB Functions-Enabled
    Legacy USB Support-Auto
    BIOS EHCI Hand-Off-Enabled
  2. ^+1
Ask a new question

Read More

Asus Drivers USB Motherboards