Sign in with
Sign up | Sign in
Your question
Solved

Why are only 3.4 GB of 4 GB usable in my W7 64-bit?

Tags:
Last response: in Memory
Share
May 21, 2010 10:49:36 PM

Hi Fellas!!!!

Here are my system specs:

Mobo ASRock G41m-S Socket LGA775
CPU Intel Core 2 Duo E7500 @ 2.93 GHz 3MB L2 Cache
VC using onboard and GF 7200GS (waiting for a XFX 5750)
RAM Corsair XMS2 4GB 800Mhz
HDD Western Digital Caviar Blue 500GB SATAII
PSU Antec TruePower Trio 550w SLI Ready



The thing is that only 3.4 gbs of my RAm are usable, the rest is hardware reserved. I Imagined this was because of the turbocache feature of the 7200GS but I removed it and started using onboard and set in BIOS only to use 64mb of RAM. Why is this happening? How am I gonna be able to unlock the harware reserved? is this going to dissapear when I install the 5750?



Thanks guys =) (sorry about some grammar mistakes or sth. I'm currently learning english and on a hurry xD)

More about : usable bit

May 21, 2010 11:27:23 PM

I had a similar problem with windows 7 X64 recognizing only 3.25gb of the 4gb i had installed, it was on a foxconn g31 chipset and after a bios update, windows fully recognized my 4 gigs. So try a bios update or go into msconfig and in the boot tab, click advanced options and make sure the maximum memory is left unchecked. Also my wei score for ram before the bios update was of 5.9 and after i updated the bios and windows recognized the 4 gigs, the wei score went to a 6.4 for ram.
m
0
l

Best solution

May 22, 2010 4:03:54 AM

LuigiVN said:
Why is this happening? How am I gonna be able to unlock the harware reserved?


It is happening because your OS is not remapping the hardware memory addressing above 4 GB. It exactly what happens with a 32 bit OS, but in your case your OS and board CAN do it, they just are not for some reason.

Lopok advice is pretty sound, save one step you should do before the bios flash. Look in the bios for a option for memory or hardware remapping or something to that effect.

So, try the MSconfig issue first. Then check the bios for turned off remapping features, and if all else fails, try a more recent bios.


Share
Related resources
May 22, 2010 4:10:13 AM

Ok. When I was home I tried the msconfig. It's unchecked. While I was there I tried to download the app to update my bios. The current version is 1.50 and mine is 1.00. I'll do that if flashing doesn't works...

Unfortunately, I'm not going to be at home until sunday =(.

Thanks guys. i'll post the results on monday or sunday. Got a lot of work to do :X
m
0
l
May 25, 2010 12:44:53 AM

FALC0N said:
It is happening because your OS is not remapping the hardware memory addressing above 4 GB. It exactly what happens with a 32 bit OS, but in your case your OS and board CAN do it, they just are not for some reason.

Lopok advice is pretty sound, save one step you should do before the bios flash. Look in the bios for a option for memory or hardware remapping or something to that effect.

So, try the MSconfig issue first. Then check the bios for turned off remapping features, and if all else fails, try a more recent bios.


Ok, i turned on a remapping feature on my bios. Unfortunately. There still is 1MB of RAm hardware reserved. All other 4095 are usable. Thanks to both of you =)

Also. The RAM on my windows experince index went from 5.9 to 6.5 Yay!
m
0
l
May 25, 2010 12:45:56 AM

Best answer selected by LuigiVN.
m
0
l
!