Sign in with
Sign up | Sign in
Your question

New drive not recognised by disk manager but seen in device manager OK

Last response: in Storage
Share
October 14, 2011 2:36:36 AM

Hi

I am trying to add a new drive to a system but it is not seen by Windows disk manager.

System is Windows XP Pro SP3
Motherboard is ASUS PN5-E SLI.
New drive is Western Digital Caviar Green 2TB (WD20EARX) SATA III. Purchased yesterday.
Drive is recognised by BIOS.
Drive appears in device manager under disk drives and shows status as “This device is working properly”.
Drive also appears in device manager under IDE ATA/ATAPI controllers.
Read Speed test initiated from device manager IDE ATA/ATAPI controllers passes.
Western Digital Data LifeGuard diagnostics recognise the disks and shows SMART status as pass and Quick test passes.

System already has two other HD. WD3200AAKS (320G system drive) and WD20EARS (2TB, SATA II)
I added the 2TB WD20EARS drive in back in June without problem.

I have tried with and without a jumper on pins 5/6 of the drive to force into SATA II mode. Without the jumper the Read Speed test initiated from device manager IDE ATA/ATAPI controllers shows “The current transfer mode is Serial ATA Generation 1 – 1.5G”, with the jumper it shows “The current transfer mode is Serial ATA Generation 2 – 3G”. The test run OK in both cases.

I have tried using the SATA and power cable currently going to the other 2TB drive (WD20EARS) but it made no difference. So it is not a cable problem.

I put the drive into another PC (Windows 7, Gigabyte P55A-UD3P) and it was recognised without problem. So the disk is OK.

I looked at “Guide: If you installed a new disk but the system can't see it” (http://www.tomshardware.com/forum/265764-32-guide-insta...) but got to step 10 with no solution unfortunately.

I have been looking at this for half a day but no joy.

Head.scratching=TRUE;

Any ideas? Something obvious hopefully…
October 16, 2011 9:56:28 PM

OK, I think (99% sure) I have this sorted.

There seems to be an issue with the nVidia SATA controller driver and this new SATA III drive. I guess they are “incompatable”. This driver is found in the Device Manager under the section “IDE ATA/ATAPI controllers”.

The solution I have in place now is I updated the driver (actually a version downgrade) from nVidia nForce Serial ATA controller (version 11.1.0.43 dated 9 Apr 2010 to the generic(?) Windows XP Standard Dual Channel PCI IDE Controller (version 5.1.2600.2180 dated 1 Jul 2001). Once in place the new drive appeared in the Disk Manager.

I also tried using the driver version found in the chipset package for the motherboard (found at http://www.asus.com/Motherboards/Intel_Socket_775/P5NE_... and called NVIDIA nForce 430/410 Serial ATA Controller, version 5.10.2600.666 dated 24 Apr 2006) but it seemed to slow the boot time dramatically to ~5 minutes. The generic Windows XP driver I am using now does not show this behaviour.

I’m not exactly sure what I am missing out by using the generic Windows driver rather than the “proper” nVidia driver but the new disk is now recognised which is the main thing. I guess w/o the nVidia driver there is no RAID support(?)

It also feels odd to be using an IDE driver for a SATA drive but perhaps that speaks more to my ignorance than anything else…


m
0
l
February 28, 2012 2:26:21 AM

Thank you very much for posting your solution! I had the exact same problem and I can see a few other people around the Web reporting similar issues. Rolling back to the WinXP default driver worked perfectly for me.

WinXP users should also note, though, that if you format Western Digital "Advanced format" drives in WinXP, WinXP will not "align" the NTFS formatting correctly, resulting in slowdowns.

Solution 1: if you've registered the drive with WD, you can (a) format the drive in XP, (b) download the "WD Align" tool, and (c) use that to correct the formatting. Best to do this before filling it with data.

Solution 2: use GParted for formatting the drive, using these instructions. Make sure to choose NTFS.

Another smaller problem is that WinXP can only use the first 2 TB of a single partition. This drive is very slightly over the limit. To solve this, just make two smaller partitions, or one big one that's a few MB short of the drive's total capacity.
m
0
l
Related resources
January 13, 2013 1:06:35 PM

Thanks kykle.

I have the same problem. How did you go about getting the other driver installed?

On my PC, uninstalling it just reinstalls the same one after a reboot, and rolling back just ended up an earlier Nvidia driver (or possibly the same one).
m
0
l
January 13, 2013 11:58:44 PM

I think you need to update a compatible driver for this new drive.
m
0
l
!