Sign in with
Sign up | Sign in
Your question

Ingame very low fps in cod mw2 with 4870

Tags:
  • Radeon
  • Call of Duty
  • Low FPS
  • Graphics
Last response: in Graphics & Displays
Share
November 23, 2009 9:35:55 AM

i have i7 920, ati radeon HD4870, 3g corsair on x58 platinum, with 600w power.
while playing cod mw2 mainly in large enviroments the performance drops significantly for some seconds. the problem occurs even in 1024x768 analysis with medium game settings and without AA.
Does anybody have a clue ?
Thanks

More about : ingame low fps cod mw2 4870

November 23, 2009 10:30:55 AM

You have the latest drivers?
November 24, 2009 4:43:32 AM

i have the drivers catalust 9.9. when i try to instal 9.11, during the instalation the computer restarts.
while running 3dmark 06 i get 15500 marks, and i guess its not bad.
Related resources
November 24, 2009 6:14:59 AM

Does it give any errors before restarting ?
Also have you tried Catalyst 9.10 too ?
November 25, 2009 1:49:47 PM

idk man im runnin the game fine and my graphics card sux in front of urs i suggest first checking the clocks if tehy are at stock if they are then u need new drivers
November 25, 2009 1:54:31 PM

sounds like a driver issue to me. My system is slower than yours and I play with everything maxed out at 1680x 1050 and manage 77FPS and/or 60FPS with v-sync enabled....
November 25, 2009 2:03:33 PM

melitstom said:
i have i7 920, ati radeon HD4870, 3g corsair on x58 platinum, with 600w power.
while playing cod mw2 mainly in large enviroments the performance drops significantly for some seconds. the problem occurs even in 1024x768 analysis with medium game settings and without AA.
Does anybody have a clue ?
Thanks

http://www.driverheaven.net/reviews.php?reviewid=890&pa...
..that is normal in this game
November 25, 2009 2:17:12 PM

^^???

I use a GTX 260 and I have no performance/FPS drops whatsoever, might drop a few frames here n there but that's about it....
November 26, 2009 4:52:19 AM

thanks guyz.
I install the 9.10 drivers and looks a bit better but still in some areas of certain terrains, the game is not playable. I also update the BIOS but no change. It is also wird that if i try to run aquamark benchmark it crashes after some sessions and give an error message back in the desktop enviroment. 3D mark 06 goes smoothly up to 15500 marks. Is there any setting in BIOS that needs to be changed ?
November 27, 2009 2:28:03 PM

To be honest I believe this issue is not with YOUR drivers. I think it's with the drivers overall..
I am experiencing the exact same thing as you are.
I am running Win7 64 bit, on a ASUSTek P5K MB with an E8400 Processor and 4GB Ram and the Radeon 4870...
My drivers are all up to date...
Now a friend of mine bought the exact same setup as me - Only difference is, he didn't have money for the 4870, so he bought the 4850 instead...
He runs the game WAY better than me, everything maxed out - whereas I can't.

So I think it's basically a Radeon+MW2 Driver issue or the videocard itself that is causing the low FPS.

And NOT you, not being able to update your drivers.
November 27, 2009 6:33:49 PM

PCFreakofNature said:
To be honest I believe this issue is not with YOUR drivers. I think it's with the drivers overall..
I am experiencing the exact same thing as you are.
I am running Win7 64 bit, on a ASUSTek P5K MB with an E8400 Processor and 4GB Ram and the Radeon 4870...
My drivers are all up to date...
Now a friend of mine bought the exact same setup as me - Only difference is, he didn't have money for the 4870, so he bought the 4850 instead...
He runs the game WAY better than me, everything maxed out - whereas I can't.

So I think it's basically a Radeon+MW2 Driver issue or the videocard itself that is causing the low FPS.

And NOT you, not being able to update your drivers.

http://www.driverheaven.net/reviews.php?reviewid=890&pa...
November 28, 2009 9:33:52 AM

well guyz i tried with defragmenting my system partition, and so far the performance is much better.
November 30, 2009 3:13:11 AM

hey i have similar problem with you
but only that my fps is low in almost every game...

i have corei5 2.67 4GB ram and ati 4890 and i cant even run crysis warhead
and RE5 on highest setting
November 30, 2009 4:04:41 PM

well i think i found the problem. The graphic unit is overheat, so i underclock the frequency of the GPU and the memory, and in parallel increase the fun speed. In this way i manage to play 1-2 game sessions without problem, but appeared again the fenomenon when the card overheat, in 20 mins or so...
January 3, 2010 8:14:41 AM

How can i see my fps in cod mw2??
January 6, 2010 2:55:10 PM

Hi guys,


just install the old Version of Catalyst Driver 9.3.

You will see that it works :-))))))

I had the same problem with my ATI 4870 toxic......

have fun
!