Sign in with
Sign up | Sign in
Your question

Set up Buffalo WHR-HP-G54 as wireless access point

Last response: in Wireless Networking
Share
March 1, 2010 6:28:00 PM

Hi,

I have an existing wireless network in my house, and I'm trying to find a cheap way to allow an Xbox 360 to access it. I bought a Buffalo WHR-HP-G54 to access the existing network so I could just hook up an ethernet cable from it to the 360, but I'm having difficulties setting it up. Any suggestions on the best way to go about doing this?

Thanks!
March 1, 2010 6:53:00 PM

Unless that wireless router can be reconfigured as a wireless Ethernet bridge (and I don't know if it can), it's not going to work.

P.S. I took a quick look at the specs and didn't see anything indicating support for wireless Ethernet bridge (aka client mode). I did see support for WDS wireless bridging, but that can be problematic unless your existing wireless router supports WDS, and may even have to be the same manufacturer, Buffalo. Is it?
m
0
l
March 1, 2010 7:27:42 PM

eibgrad said:
Unless that wireless router can be reconfigured as a wireless Ethernet bridge (and I don't know if it can), it's not going to work.

P.S. I took a quick look at the specs and didn't see anything indicating support for wireless Ethernet bridge (aka client mode). I did see support for WDS wireless bridging, but that can be problematic unless your existing wireless router supports WDS, and may even have to be the same manufacturer, Buffalo. Is it?


Hmm, it has an external switch allowing you to change it from router mode to access point mode, and I was assuming access point mode was pretty much the same thing as a client mode. At least, that's the impression I got from reviews and the user manual. I'm currently having problems accessing the device itself because the supposedly default IP address isn't being recognized by my browser.

Also, I just found this in the user manual:
Quote:
To add an AirStation to a network without changing the existing LAN configuration,
proceed as follows:
1. Put the AirStation in AP mode by moving the switch on the bottom from AUTO to BRI.
2. Connect one of the AirStation’s LAN ports to an existing router or switch on your
network.
3. Temporarily change your computer’s IP address to an unused address on the
192.168.11.x subnet, with subnet mask 255.255.255.0.
4. Type “192.168.11.100” into a browser window to open the AirStation’s Configuration
Tool.
5. In LAN Config, configure the following settings:
IP Address = [192.168.11.137] (Specify an unused network address from the existing
LAN.)
Subnet Mask=[255.255.255.0] (Use the same Subnet Mask as the existing LAN.)
6. Restore your PC’s IP address settings to their original values.


I've got 1 and 2 taken care of, but I don't know how to change my computer's IP address. I have both a Mac and a PC, so do you have any advice for which one would be easier to deal with?

Thanks a lot!
m
0
l
Related resources
March 1, 2010 7:48:58 PM

That Buffalo router comes w/ an integrated WAP (wireless access point). When you switch it to AP mode that just disables all the routing features leaving it as a simple WAP. But a WAP is something you connect TO, not something you connect FROM. When connecting it to your XBOX, you want it to act as something you connect FROM over TO your existing wireless router.

The WDS bridging feature does offer the ability to connect FROM that Buffalo TO another WAP. But there's a catch. WDS is not a certified wifi protocol, so implementations vary. What that means to you is the very distinct possibility that it won't work unless your existing wireless router a) supports WDS and b) is also a Buffalo wireless router.

So minimally you need to determine if your existing wireless router supports WDS. If not, you're dead in the water. If it does, then it may work, or it may not due to incompatible implementations of WDS. But sometimes you get lucky and it works even across brands (but usually not). And even then, some implementations of WDS have other limitations (e.g., WEP only).

That’s why the better choice would have been a wireless Ethernet bridge. Without that capability, you’re left w/ WDS and that’s just a PITA most of the time.

So before you take another step, tell me the make & model of your existing wireless router so we can determine if this is even remotely possible.
m
0
l
March 1, 2010 7:56:42 PM

Okay, I understand. I guess that's my fault for not doing decent research. The existing wireless router is a Netgear WGR614.
m
0
l
March 1, 2010 8:02:38 PM

msto said:
Okay, I understand. I guess that's my fault for not doing decent research. The existing wireless router is a Netgear WGR614.


Which version? I'm seeing a boatload of them, up to v9, and some do and some don't support WDS.
m
0
l
March 1, 2010 8:07:49 PM

P.S. If you go to the following link, you'll see an image of a WGR614 router (v9 specifically) that supports WDS.

http://www.dslreports.com/forum/r20927197-WGR614-v9-Sup...

That's the page you need to find on your Netgear router to configure it for WDS. If it’s not there, then you don’t have WDS support. It might be available w/ a firmware update though, so you should check. But if it’s not there and not available as a firmware update, you’re dead in the water
m
0
l
March 1, 2010 8:08:02 PM

eibgrad said:
Which version? I'm seeing a boatload of them, up to v9, and some do and some don't support WDS.


v9, sorry

Would it be easier to just flash the Buffalo with Tomato or DD-WRT?
m
0
l
March 1, 2010 8:09:41 PM

msto said:
v9, sorry

Would it be easier to just flash the Buffalo with Tomato or DD-WRT?


Easier? That's up to you. If it supports dd-wrt or tomato, that would solved your problem, definitely. Then just set it up in "client bridge" mode.
m
0
l
March 1, 2010 8:14:26 PM

eibgrad said:
Easier? That's up to you. If it supports dd-wrt or tomato, that would solved your problem, definitely. Then just set it up in "client bridge" mode.


Alright cool, I'll try using WDS with the Netgear, and if that doesn't work I'll use dd-wrt or tomato (the buffalo supports both). Thanks for all the help and advice!
m
0
l
March 1, 2010 8:36:13 PM

I should be more specific, for dd-wrt use "client bridge" mode, for tomato use "wireless Ethernet bridge" mode.

Good luck, and let me know if WDS works, I'd be interested.
m
0
l
March 1, 2010 11:59:40 PM

I decided to just skip trying to make WDS work and installed Tomato. Installation worked fine, and I was able to access the Tomato interface on the Buffalo. However, when I unplugged it from the PC and brought it to the room with the 360, the router wouldn't access the wifi network I had set it up on. I brought it back to the PC and hooked it up, but I can't get the PC to recognize the Buffalo on any of the IP addresses, either the default Buffalo ones or 192.168.1.1, or 192.168.1.24 (the IP I had given it so it wouldn't conflict with the original router). Any suggestions on how to either reset the Buffalo or access it? I don't think I bricked it, but is there any definite way to tell?
m
0
l
March 2, 2010 12:30:20 AM

Ok, I got back into the Tomato interface, the IP I had selected hadn't saved for some reason. I found the wifi-planet tutorial earlier (the one you got that screenshot from) and I'm working through it. However, the existing network is set up with WEP security (I know it sucks but my dad's not as tech savvy and he's the one who set it up), and the site says that Tomato doesn't support WEP in bridge mode. Is that true? WEP is listed as an option in the Tomato interface, but I don't mind using the client mode if I get essentially the same functionality. Thanks for all your help with this, I really appreciate it.
m
0
l
March 2, 2010 12:40:23 AM

I saw that reference to WEP too. I don't use tomato, strictly dd-wrt. So I don't know if it's still true (that article is a year old, things do change). However, I have a feeling given the fact WEP has been thoroughly hacked and is pretty much worthless, no one has likely upgraded the firmware to support WEP. It's just not worth effort. But that’s just an educated guess on my part. You can always try. But if everything seems to be configured correctly and it still doesn’t work, you may need to briefly disable wireless security on the primary router to find out if that is indeed the problem.
m
0
l
March 2, 2010 1:15:26 AM

Okay, so I set the existing network to WPA, then set up the Buffalo to access it, then renewed the PC's IP address by disabling then enabling the ethernet port. I'm now able to connect to the internet on my PC via the Buffalo connected to the network. As far as I can tell, I'm set. If I just unplug the Buffalo from the room it's in right now and bring it to the room with the Xbox and hook it up, it should work, right? Or is there anything else I need to do to preserve the settings on the Buffalo?
m
0
l
March 2, 2010 1:36:57 AM

If it works w/ the PC, it should with ANY wired device.
m
0
l
March 2, 2010 1:41:15 AM

Awesome, thanks for everything!
m
0
l
!