Sign in with
Sign up | Sign in
Your question

Cant run dual channel memory

Last response: in Motherboards
Share
May 23, 2010 7:25:42 AM

I recently built an i5 system and i cant seem to get my memory to run in dual channel mode. I've already RMA'd the mobo and the RAM with no change. The system runs fine with both memory modules in sockets 1 and 2 (single channel), and its been running for a few hours now with them in sockets 3 and 4. this would lead a person to believe all 4 sockets and both memory modules are good, right?

but if i install them in sockets 1 and 3 (dual channel), i will eventually get errors in memtest...and i get all kinds of goofy memory related problems if i boot into windows (BSOD's, random crashes to desktop, graphical errors in games, etc). the system wont even POST with the modules in sockets 2 and 4.

I started with all stock frequencies when i first assembled this rig. since then ive tried overclocking the base clock to 160 to get my 1600mhz from my ram (its rated frequency). the CPU multiplier was turned down to 19 for a total frequency of 3.04Ghz (im running the stock cpu cooler for now and it wasnt handling the 3.3Ghz very well). Im running the suggested timings and voltages (manually set) for the RAM. i tried increasing my QPI/vtt to 1.21v (ive heard that helps when running with all 4 sockets full) with no luck.

windows xp pro (what? i know!)
Gigabyte GA-P55A-UD3
bios v. F6
G. Skill Ripjaw 2x2GB DDR3 1600 Model F3-12800CL9D-4GBRL
Intel core i5 lynnfield 2.6ghz
Corsair 750w PSU
a b } Memory
a c 177 V Motherboard
May 23, 2010 2:39:41 PM

Is your uncore multiplier set at 21x? The uncore mult must be at least 2x the memory mult, and, for reasons known only to the Intel geeks, odd numbers seem to work better, so U = 2M +1. QPI/Vtt must be within a half volt of Vdimm, so you're good there - won't hurt to 'bump it up' a bit, either... I'm motivated here to help - have pretty much the same RAM spec'd for an upcoming build for someone - except I recommended the CL7D - don't think she's ordered parts yet - still time for a "halt order!"
May 23, 2010 6:18:35 PM

I have exact problem as wicked_sludge, needs help. My system is as follow:

windows 7 64bits (tried xp as well)
Gigabyte GA-P55A-UD3
bios v. F6
Corsair CMX4GX3M2A1600C9 (2x2GB)
Intel core i5-750 2.66GHz
APEVIA 750w PSU

When I placed a single mem module in any slot the system runs fine (to save time I ran PRIME95 for an hour for testing) and it didn't matter which mem module I used so I think both modules are ok. When I placed both modules in single channel configuration (in socket 1 & 2) computer runs fine too. But when placed in socket 1 & 3 the system would lock up within 5 minutes of running PRIME95.

I am a novice so couldn't play much with cmos adjustment, only tried loading optimized and default setting and tried a little different setting like 1333 and 1600 memory speed but none effective.

I had the system for more than a month and RMA the mem modules during the period but looks like mem is not the problem. Do I have a faulty mother board?

Best Regards,
Related resources
May 23, 2010 9:22:49 PM

you may be onto something bilbat. the uncore is set to 16x (ram multiplier is 10x), but, its grayed out in the bios and i cant change it. am i missing some setting that allows me to modify that multiplier? forgive me if this is a noob question as this is only my second build and i didnt have to get this deep into timings and voltages and whatnot on my last setup.

for the QPI/vtt voltage, do you think its necessary to go higher than 1.21v?
a b } Memory
a c 177 V Motherboard
May 24, 2010 12:47:06 AM

I believe there are a number of XMP-related 'peculiarities', but have not yet been able to confim - have a GA-H55M-USB3 based build slated, and intend to 'nail down' some of these things, but client has not yet placed order - have spec'd some memory that is really kind of fast for a Clarksdale, but want to 'play with' XMP, to try to come up with 'solid' procedure for the 1156/1366 platform boards... (Working on a memory tutorial, need to 'hammer out' procedure...)

First thing - I believe, but cannot confirm, that enabling XMP pretty much 'locks you out' of the other overclocking features in the BIOS...

Second, XMP shows a "Profle QPI Voltage" based on XMP (picture on page 41 of manual) - but, I'm not sure it sets that QPI/Vtt...

Third, issue of 'uncore multiplier' needing to be at least double the memory multiplier seems to be 'missed'...

And, I am also 'missing' this: how, exactly, is the XMP stuff set? Do you just enable the XMP profile, and the next boot 'picks it up', and configures during post? Or, does one need to enable XMP, and then execute a "Load Optimized Defaults" to actually accomplish the 'set up'?

So - here's my intent. First, read the BIOS - Saving CMOS section of the 'sticky', if you haven't already... Get the XMP to 'load' - however - be a blessing if you'd post whether it just 'grabs' when enabled, or if it requires a "LoadOpt". Now, once the XMP has loaded, note the "Profle QPI Voltage" displayed on the "Advanced Memory Settings" sub-page of the "MB Intelligent Tweaker(M.I.T.)" BIOS page. Go back to the 'Main Page', do the <F11> save CMOS, name it XMP_On; return to the "MB Intelligent Tweaker(M.I.T.)" page; disable XMP; check that the displayed "Memory Frequency" doesn't change; return to the 'Main Page', do the <F11> save CMOS, name it XMP_Off@16; return to the "MB Intelligent Tweaker(M.I.T.)" page; set the prviously noted QPI/Vtt, and the "Uncore multiplier to two times the memory multiplier plus one; save it again as "XMP_OffQU...

Now, we should have three 'restorable' profiles saved: one, with XMP enabled; one, with the XMP RAM timings and sub-timings for 1600, but XMP disabled, allowing other settings; the third, with XMP off, 1600 timings, and the QPI/Vtt and uncore adjusted correctly. Should be able to reboot, load the third profile, and test... I think [:jaydeejohn:3]
May 24, 2010 1:55:03 AM

sorry, i should have mention ive been running with XMP disabled (since ive been manually adjusting things).

XMP does seem to function like "load optimized defaults" in that it applies the settings immediately. i selected profile1 (my only option) and it changed my CPU multiplier to 17x for some reason (back down to 2.7Ghz), and made the SPD display 1600mhz rather than 1333mhz (although it operates at 1600mhz either way). my BIOS seems to report QPI/vtt voltage as 1.1v no matter what the current setting (whether its set with XMP or manually). its not until i boot into the OS and monitor the voltage from there that i actually see a change. in this case, XMP set the QPI/vtt to 1.7v.

however, from what ive been reading, the socket 1156 CPUs have their uncore multiplier locked. so i guess mine is stuck at 16x. this means if i want my memory multiplier to be <1/2 of my uncore multiplier, i have to select 8x, or even 6x...or 960mhz! i think at that speed, id be better off sticking with 1600mhz single channel, which does run reliably :( 

does this mean my only choices for a stable system are 960mhz dual channel or 1600mhz single channel?
May 24, 2010 2:21:01 AM

Lower your memory timings, the duty is heavier in dual channel.
a b } Memory
a c 177 V Motherboard
May 24, 2010 2:45:06 AM

Eeekk! I should know this stuff! Indeed, the uncore is locked at 16x, limiting memory to 8x - and the i5-7xx CPU's are some of the ones whose 'officially supported by Intel' RAM speeds are limited to 800 & 1066 - no 1333 register setting! However, there is hope - 167 Bclk is pretty much a given, even at stock voltages, which'll give you 1333 RAM, and Tom's testers got to 180 Bclk (1440 RAM) on stock V, and 200 at only 1.32V (which would give you your 1600...)

Might wanna also peek here: http://www.xbitlabs.com/articles/cpu/print/core-i7-870....
May 24, 2010 4:19:26 AM

167 bclk was a no go with the following settings:

167mhz bclk
18x CPU mutliplier (3.0ghz)
16x uncore multiplier (2.6ghz)
8x memory multiplier (1333mhz)
ram timings and voltages were left same as before.

system would not post with ram in either single or dual channel configuration.

is there some other setting i need to change to get my bclk up to 167 and above?
a b } Memory
a c 177 V Motherboard
May 24, 2010 5:30:13 PM

Not ignoring you here - will take a bit: volume two of the CPU's datasheet is 300 pages long, and the 'interesting stuff' didn't 'make an appearance' until page 231!!
May 24, 2010 6:02:59 PM

no problem, im standing by.

running the system at 1600mhz single channel is actually working fine for my current requirements (this is my gaming machine but im not an extremely heavy gamer). the reason im concerned with getting dual channel to work is because i built this rig to be as "future proof" as possible...and being stuck with 4GB of single channel RAM is going to be a problem later down the road :??: 

as a side note...where did you get a copy of intels datasheet? that doesnt seem like the kind of information they would release to the public...
a b } Memory
a c 177 V Motherboard
May 24, 2010 6:43:12 PM

From an earlier post, 're-posted' at the front-end for the memory article I'm 'massaging':

"Funny, I've heard that bilbat guy only knows a lot of arcane BS about Intel processors - cause they're the only ones who document everything! If you wanna know how many Lahore pigeons crap on the roof of the Santa Clara fab each year, not only can you find it in a PDF somewhere (but where - that's the skill!) on their web site, but there's probably a three year plan documented to change their feeding habits, so they crap a lighter color, causing the roof to reflect more sunlight, and cut down on the air-conditioning costs... Every time I try to find out something about an AMD BIOS for someone, I see this business about "update AGESA three point five point three point nine point more digits than pi", and I've been randomly trying for months just to find out what 'AGESA' is - bah - no luck! (I hate acronymns anyway - the only one that ever sticks in my head is back from the days when they finally got completely out of hand with 'PCMCIA' - people can't memorize computer industry acronymns!) And you don't wanna even get me started about nVidia! As far as I can figure, nVidia is actually a front company for the CIA/NSA - if you go looking there for documentation, they'll have you investigated to find out why the hell you're looking for their documents!"
a b } Memory
a c 177 V Motherboard
May 24, 2010 10:59:23 PM

Thought, whilst I'm 'digging', you might enjoy some 'samples'...
May 24, 2010 11:50:53 PM

I'm also having this problem with a GA-EP45-UD3P motherboard. Both 1 and 2 slots as well as 3 and 4 slots work with single channel, but any time I use 1 and 3 or 2 and 4 my computer has problems staying booted up. I get blue screens and general memory errors and sometimes boot loops.

I just RMAed this board for a broken 12v which they fixed, but it came back with this problem.
a b } Memory
a c 177 V Motherboard
May 25, 2010 2:10:05 AM

wicked_s

Look toward the bottom of this post, download and run CPU-Tweaker as shown, click on its 'SPD button, and post back the pair of screens; if you've not captured and posted an image, there's a tutorial here... It's normal for RAM in 2 & 4 to fail - i5/i7 rule is 'farthest slot(s) first'; I'm surprised the manual says a single DIMM can be in either 1 or 3, and the init rule for single DIMM is 'farthest slot on channel 0'...

Biowulf

Please start a new post; list:
CPU type & stepping
MOBO rev (1.0, 1.1, 1.6?) & BIOS rev
Memory mfg & part number
CPU cooling type

I have eight sets of EP45 'canned parameter lists', six of which are for that (UD3P) board specifically, for various CPUs and RAM; 'far as I know, all were successful; I know at least one was, as an IT guy from a data center in South Africa 'copied' one I had posted for someone else, and I got a nice letter of thanks for it! Reason I ask about cooling is that most include a reasonable, 'easy-on-the-hardware' overclock...

I have ones for:
E7400
E7500
E8400
Q6600
Q9450
Q9550
Q9650
...in stock - no waiting[:jaydeejohn:4]
May 25, 2010 2:56:40 AM

well an interesting thing happened when i got home from work today...

last night, i had left the rig at 1600mhz single channel (which had proven to be my "safe spot"). when i fired the rig up this evening i started getting those little "quarks" you get when you have bad memory (browser crashing seconds after opening, graphical errors, the like). i restarted and ran memtest and got loads of errors on just the first pass. how frustrating! this thing broke itself OVERNIGHT!

so, unable to use my "safe spot", i did some more experimentation. it seems to me that my failure to boot at 167 bclk before may not have been so much bclk frequency related, but the 8x memory multiplier...as it seems i cant run the 8x multiplier with either 133 bclk OR 160 bclk without the same fail-to-boot results. but, i have not tried 167 bclk with 6x yet.

currently, the box is running 160bclk, 6x memory multiplier, 21x CPU multiplier and DUAL CHANNEL MEMORY. i ran 2 passes of memtest and i ran Prime95 for a little while and it seems OK....for now :( 

as per your request, heres a screenshot of CPU-tweaker:



i may try to bump my bclk up now with the 6x multiplier and see what happens :??: 


EDIT: the 8x memory multiplier seems to be the issue. the system didnt bat an eye at 170bclk with the 6x multipier. that still only leaves me with 1020mhz though... :??: 

EDIT #2: i realized the above screenshot came out kind of small (photobucket :pfff:  ), so heres a second with my current timings (170bclk, 1020mhz RAM, dual channel).

!