Sign in with
Sign up | Sign in
Your question
Solved

HDD detected in system BIOS, but unavailable when installing windows..

Last response: in Systems
Share
November 19, 2009 1:23:14 AM

Just put together this system. My Gigabyte GA-MA770T-UD3P is seeing my 500GB Samsung Spinpoint drive in BIOS and shows it when booting if I have my SATA set as RAID or AHCI. No matter what my BIOS settings are, however, it will not appear when I'm installing Windows. I'm told to install drivers, but apparently none of the included drivers are compatible with my hardware. I've downloaded the latest chipset drivers from Gigabyte's website and have tried those, but I'm still having no luck. Apparently I need a floppy drive to flash BIOS, and since I don't have one it looks like I don't have that option. Can any of you help me? Been struggling with this for the past few hours and it's getting really aggravating.

I've tried installing Windows 7 home premium 64 bit and Vista ultimate 32 bit, and the problem persists. Doesn't seem like something specific to one OS.
November 19, 2009 1:50:16 AM

Is the windows a full version and not a Upgrade? Try setting the HDD in the bios to compatibility mode if its there.
m
0
l
November 19, 2009 2:15:13 AM

Both CDs are full versions. I just installed ubuntu 8.10 without issue. I have no idea what the problem is. At first I thought it was a driver conflict, but the HDD is showing up in BIOS and linux doesn't have any problem detecting it. Seems to be Windows-specific.

I'll try compatibility mode in a few minutes, just testing ubuntu right now.
m
0
l
Related resources

Best solution

November 19, 2009 2:20:04 AM

You can flash the BIOS with a pen drive (I've stopped using floppies) on that board. Check the manual for how to exactly. Also, the motherboard CD should contain the AHCI/RAID drivers needed by Windows during install. If you have a SATA DVD drive however, you must first copy the appropriate drivers to a pen drive and then load during the install. Again, consult the manual for the MB, it should lead you through these steps better than my memory can recall.
Share
November 19, 2009 2:20:13 AM

^ Did you try setting the HDD to IDE mode in the BIOS ? Change it from AHCI/ SATA to IDE in the BIOS...
m
0
l
November 19, 2009 2:25:37 AM

gkay09 said:
^ Did you try setting the HDD to IDE mode in the BIOS ? Change it from AHCI/ SATA to IDE in the BIOS...

It's IDE by default, I just tried switching it up in hopes that it would work. Anyway, it's working now. I used Linux to format the drive and it suddenly appeared for Windows installation. Thanks for the suggestions. What a strange solution :heink: 
m
0
l
November 19, 2009 3:25:47 AM

^ Thats odd...hmm...
But I know 1 thing about linux is that when you install linux on a partition, which is available in WIN, it would disappear from Windows...so I guess formatting the drive in linux would have erased any linux files, thus making the drive available in WIN...
m
0
l
November 19, 2009 3:16:08 PM

That was weird, but Vista and Win 7 do not need you to supply SATA drivers, they have them. Only XP and before needs you to install drivers using the "F6" method when prompted at the beginning of the install process. Strange indeed.
You should have been able to set the drive to AHCI mode and install just fine. Whatever the problem was, it was not due to the SATA/AHCI/IDE mode setting.
m
0
l
!