Sign in with
Sign up | Sign in
Your question

Asrock x58 extreme installed memory is 6gb. Win 7 x64 shows 4gb

Last response: in Motherboards
Share
May 25, 2010 4:44:32 PM

Hello,

I just put together a new rig and am using the ASrock x58 Extreme motherboard and an I7 920 proc with Crucial Ballistix Tracer 6GB (3 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600.

I have the newest version of the bios (as came installed with the mobo) and it is showing that I have 6 GB of RAM installed.

However, Win 7 x64 Ultimate shows that I have 4 GB of RAM installed.

Has anyone come across this issue? I have found various similar posts on forums but nothing exactly the same and I haven't been able to resolve the issue.

Thanks!

Cheers,

Jesse
a c 297 V Motherboard
May 25, 2010 7:36:42 PM

Hi newcomer and welcome to the Tom's hardware forum.

It is happening because your OS is not remapping the hardware memory addressing above 4 GB. It exactly what happens with a 32 bit OS, but in your case your OS and board CAN do it, they just are not for some reason.

Try this: Start, run and write msconfig and in the boot tab, click advanced options and make sure the maximum memory is left unchecked.

Also check in ur bios for a option for memory or hardware remapping or something to that effect.
m
0
l
Anonymous
a b V Motherboard
October 1, 2010 8:38:40 PM

The same thing happens to me too, however I see it already in the BIOS, so I don't think it's windows. Some times it finds 4GB sometimes 6GB. I already replaced the board once, and now it's happening with the new one too. What gives? Anyone experiencing the same thing?
m
0
l
Related resources
March 28, 2011 11:08:27 PM

Quote:
The same thing happens to me too, however I see it already in the BIOS, so I don't think it's windows. Some times it finds 4GB sometimes 6GB. I already replaced the board once, and now it's happening with the new one too. What gives? Anyone experiencing the same thing?

same thing happening to me too with my asus p6t mobo.
m
0
l
a c 717 V Motherboard
March 28, 2011 11:47:43 PM

@Anonymous & @ntbuwa - Please start a New Post. Otherwise @Jessiah is getting unwarranted notifications.

This subject is VERY Common. 9/10 Set to AI OC Tuner -> XMP {assuming XMP RAM} <or> set DRAM Frequency -> Rated and if necessary increase the DRAM Voltage in BIOS to Spec to Spec +0.05~+0.1 {lowest stable}.

Too many other variables.

Thanks! :) 
m
0
l
!