Cant format hard drive

try to format seagate 2tb but keeps stopping at 54% any ideas i'm running vista home basic
4 answers Last reply
More about cant format hard drive
  1. try to check if it's in working order using seatools

    if it passes, try formatting using diskpart (and becareful)
    first select disk 1 (or whatever number, see list disk)
    then clean
    followed by create partition primary
    and select partition 1
    followed by format fs=ntfs

    if that fails too, you might have a bad disk or os
  2. thanks tried all that and also tried seagate diskwizard but nothing i think the drive might be faulty.
  3. hello,
    Try to run command in cmd (command prompt) as "chkdsk drive or partition name like c: , d: , etc..".
    then, type "format partition or drive name like c: drive, d:drive,etc..


    >chkdsk h: <enter>
    >format h: <enter>

  4. If you have a bootable windows disc, any windows disc, try formatting through that.
    First, boot from cd/dvd.
    When the installation shows you the partitions, click on the drive/partition you wanted to format, and hit 'Format'.
    It'll do the trick..!
Ask a new question

Read More

Hard Drives Format Seagate Home Basic Windows Vista Storage