Sign in with
Sign up | Sign in
Your question

[SOLVED] running GA-X58A-UD3R in AHCI mode - WinXP - BSOD 0x0..07B

Tags:
  • Gigabyte
  • Blue Screen
  • Motherboards
  • Product
Last response: in Motherboards
Share
May 25, 2010 7:00:09 PM

Hello,

I can't seem to make this board to run in AHCI. I have tried all four controllers F6 drivers to no avail.
I made winxpsp2 to install without a BSOD, by Loading Optimum Defaults (turns all to IDE mode) and Giving it ONLY

ICH10R F6 driver from CD [thanks to bilbat's stiky] (as downloaded one fails! )

Now I am trying to switch ich10r to AHCI mode and I receive BSOD on boot
0x0000007b (0xbacc3524, 0xc0000034, 0x00000000, 0x00000000),
right about where I should see the blue background for first time.

Gigabyte support just ignores my request for assistance for two days already. (Are they out of business or something?)

GA-X58A-UD3R
i7-930 (Memory posts fine)
Crucial Ball.Trac. DDR3 1600 3x2Gb
OCZ ModStream 700 PSU (yes, video connected)
XFX Rd HD 5770 PCIe16 (yes, in slot pcie16 #1).
HD: Known Good WD50000AAKS on Sata_0 (yes, on true sata power connector).
CD/DVD LiteOn Sata on Sata_9 (GBB controller).
Legacy Floppy (not usb)

Nothing else is connected.


What gives, guys?

More about : solved running x58a ud3r ahci mode winxp bsod 0x0 07b

a c 177 V Motherboard
May 25, 2010 7:59:43 PM

Quote:
Now I am trying to switch ich10r to AHCI mode and I receive BSOD on boot

Not sure what you mean by "switch to"?

Current Intel drivers (32&64 bit)...

Sequence is:
set BIOS AHCI to enabled
<F10> to save, exit, and reboot
check that drive is no longer 'discovered' by the regular IDE POST detection - should be discovered by Intel AHCI BIOS/option ROM on seperate screen...
boot windoze install disk
watch for <F6> prompt
load driver
proceed to partition, format, & install
m
0
l
May 25, 2010 8:11:37 PM

Thanks for a reply, bilbat!

By switching I meant changing bios setting for ich10r to ahci mode, then booting back into windows and hoping the drive is now used in ahci mode.

I couldn't install win xp sp2 as you outlined in your reply:

If I change ICH10R controller mode in bios to ahci, then proceed to install
windoze, I will receive BSOD after F6, right where it says "starting windows" in
the setup screen status line.

This is why I installed windows with F6 for ICH10R, but with controller set to
IDE mode by Optimized Default. I was hoping that after windows is installed,
I would be able to change the mode to AHCI and boot already in AHCI mode.
m
0
l
May 25, 2010 8:38:35 PM

I think I see the light, bilbat...

If the F6 driver can not be integrated while installing windoze with controller in IDE mode,
then my BSOD upon switching to AHCI post-install is pretty much granted (there is still no F6 ACHI driver to use!), right?

Then it seems I have misdiagnosed my problem. It should probably read:
"Cannot instal windoze with ICH10R controller in AHCI mode, receiving BSOD."

And the solution is probably lies in finding better F6 driver?

Do I understand you right?
m
0
l
a c 177 V Motherboard
May 25, 2010 10:47:36 PM

Um - I think... I've been trying to find something, and damned if I can! I've never seen the screen (AHCI 'discovery', or 'polling') I described, I always configure everything I do with RAID drivers installed for the ICH's, and AHCI for the jMicrons (GSATAs)...

I'll try to explain a bit better... When your board POSTs, if none of the SATA controllers has an 'extended' mode enabled (RAID or AHCI), the controllers and their drives are detected during the opening screen of POST, and shown as an 'IDE' configuration [i.e., Channel0 Master, Channel 1 Slave - even though the 'master/slave' designations have no purpose in SATA]; this happens quite quickly... Once you enable an extended mode for a controller, there is a 'seperate piece' of the BIOS, provided by the controller manufacturer [Intel, jMicron, Marvell] called the 'Option ROM' for that controller; typically, what will happen is you'll get a 'clear screen' after the 'in-POST' memory enumeration, and IDE detection, and then, your drive will be detected and displayed - along with the controller mfg's name and a version # for the ROM; if you've selected a RAID mode, this is also where you'll see the 'prompt' (for example, for Intel RAIDs, it's "press ctrl + I to enter RAID configuration"...) that allows you to 'build' the array... Systems I build are all RAID enabled for the ICH, and AHCI for the GB's, so those are the only two I ever see.

You've pointed out a documentation problem to me here; the manuals have screen-shots of what the RAID Option ROM screens look like for every controller - what they never bother to show you is what the AHCI 'discovery' screens look like! :o 

So, yes, you can't switch afterward; I'm pretty sure you have to have AHCI enabled when you do the <F6> driver install, for it to configure correctly, in Xp; there's some controversy with seven about whether it can 'switch back and forth' after installation; I know it works for a non-boot jMicron, as I do it all the time! The driver I pointed you to should be the latest - but I can't see it mattering that much; I'm pretty sure they were just released to 'cover' TRIM pass-through for SSDs...

The reason I blather about the seperate screen 'discovery' is that is how you can tell that the MOBO 'sees' the controller as AHCI, and that the AHCI actually 'sees' the drive! ;)  From there on, should be 'a piece of cake...'

m
0
l
May 26, 2010 1:34:39 AM

OK, I unpacked a driver from Intel (your link), for some reason it show
newer date but older version than that from Gigabyte website:

F6 ICH10R SATA Driver 32 and 64 8.9.0.1023 2010 05 04 from Intel
F6 Intel SATA RAID Driver [for AHCI and RAID Mode] 9.5.0.1037 2010 03 03 from Gigabyte

With F6 driver from Intel site on a floppy, I attempted install again.

Loaded optimized defaults (all controllers on IDE mode),
Set NoLogo
Set No USB Storage
Set No USB KB and NO USB Mouse
Set ICH10R to AHCI
Set Sata 0-3 to Native

Connected HD to Sata_0, and CD to Gigabyte Controller Sata_8

Booted, did F6, and guess what, after "Starting Windows" Setup reported no HDs available.

WHAT?!?

Went back to bios setup and yep, no HDs listed in device listing, only a dvd burner!

I have the screens for you, but do not have the online storage to post them, I can email them if you want.

Basically, first boot screen, - apparently the regular bios shows only CD/DVD-RW IHAS and no Hard Drives.
Second screen, which is the special AHCI rom, shows Hard Drive detected on Port00, and shows it's model.
Third screen shows PCI Devices.

The hard drive is known good, brand new, and I just installed winxp on it (the original post).
I zapped the mbr with Zap.com prior to this test to be sure everything is virgin.

So, the verdict is....? Bad Mobo?

m
0
l
a c 177 V Motherboard
May 26, 2010 2:39:48 AM

Middle picture is the one I wanted - hardware is OK, AHCI BIOS is 'seeing' drive; has to be some kind of 'Xp thing' - will d/l the latest MS technet 'techlib' tomorrow, & dig in; I'm nuts, have to have fairly strict rules about sleeping, or I get really nuts! [:fixitbil:9]

[:bilbat:9] Thanks to that one picture, now I'm nuts and cross-eyed [:bilbat:2]
m
0
l
May 26, 2010 2:56:59 AM

Yet, there is no listing of the hard drive in CMOS Setup screen! You think this is normal?

I haven't seen this yet before. I think drive should be listed on the first line in the last picture.

I think the problem is with AHCI BIOS. It does sees the drive, yet, it does not send the device information down to normal BIOS.

m
0
l
a c 177 V Motherboard
May 26, 2010 3:04:26 AM

It's entirely normal; as I said, setting any 'extended mode' (AHCI or RAID) effectively 'removes' the drive from control of the normal BIOS ROM, and 'moves it' to the control of the 'Option ROM' provided by the controller's manufacturer... Tomorrow, I'll take a few pictures to show you - I can 'toggle' one of my drives between AHCI and 'normal'; with AHCI enabled, nothing is seen by my main BIOS at all; when AHCI is disabled, both the IDE CD/DVD and the Seagate 1.5 on it 'pop into' the main BIOS' discovery display page, as well as the "Standard BIOS Features" screen of the BIOS setup...
m
0
l
May 27, 2010 5:34:41 AM

Gigaupport finally answered - at the end of 4th day. Their reply is a request for information that I have already carefully entered in their form, bleh, show lack of attention. Waiting for their solution.

I was searching internet for AHCI and XP, and not finding much I searched my HD (I am a pesky type that saves good web pages), and found a saved Wikipedia Article that states this:



Common problems switching to AHCI under Windows

* Enabling AHCI in a system's BIOS will cause a 0x7B Blue Screen of Death STOP error (INACCESSIBLE_BOOT_DEVICE) on installations of Windows XP and Windows Vista where AHCI/RAID drivers for that system's chipset are not installed; i.e., boot failure.[5] Switching the chipset to AHCI mode involves changing the BIOS settings and will not work. Usually, manual installation of new drivers is required before enabling AHCI in BIOS.[6] Alternatively, a "Repair" installation with the appropriate driver loaded during the setup process usually corrects the problem. For motherboards with more than one Sata controller (for example, some boards have Intel and Jmicron Sata controllers) another alternative is possible. The sata cable for the boot drive can be inserted into a port on one controller (which can be configured in IDE mode), allowing the machine to boot successfully with the other controller configured for AHCI mode. The AHCI drivers can then be installed in windows without difficulty before swapping the cable back.
* For Intel chipsets (for example, Intel ICH9) drivers are available from either an OEM motherboard or computer manufacturer. For the Intel versions, the driver must be loaded before loading the OS (by pressing F6 as setup starts, then using the floppy disk when prompted). The Intel drivers will work for both XP and Vista. Also, in the case of ICH9, an unsupported method to enable AHCI on ICH9 is available.
* When attempting to install Windows XP or a previous version on an AHCI-enabled system, setup will fail with the error message "setup could not detect hard disk drive..." since no drivers will be found for accessing the SATA controller/s. This problem can be corrected by either using a floppy disk or by slipstreaming the appropriate drivers into the Windows XP installation CD, or by turning on IDE emulation in the BIOS settings if it's available (usually labeled IDE mode, ATA mode, or COMPATIBILITY mode [versus AHCI mode and RAID mode]).
* Enabling AHCI in a system with Windows Vista already installed will result in a BSoD if SATA was configured in IDE mode during Vista's installation. Before enabling AHCI in the BIOS, users must first follow the instructions found at Microsoft Knowledge Base article 922976. This fix also works with the Windows 7 Beta.
* Enabling AHCI in a system BIOS on installations of Windows XP or Windows Vista will cause SATA Optical drives to disappear. A Hotfix for Windows Vista is available under the title: "SATA optical drives are not available after you start a Windows Vista-based computer."[7] This problem was fixed in Vista SP1.
* Windows Vista installation process may take several hours on a system that uses an AMD/ATI SB600 Series chipset operating in AHCI mode.[8]



Currently that same page doesn't have this information. (http://en.wikipedia.org/wiki/Advanced_Host_Controller_I...)

Elsewhere in forums I have found other people's opinions that both Intel and M$ are actively censoring out this type of information as both are interested in forcing a switch to Windows 7, and prefer this to be a nerve-breaking experience resulting in a decision to buy 7.

I am still trying different things, and am preparing to try the "controller substitution" method that my saved wiki page mentions, and a friend of mine said he used before.

bilbat, if you have any ideas, I am still checking this thread. I will post what solved it (if I ever solve this) (I hate finding posts "solved, thanks anyway" without the solution itself. Thanks again.
m
0
l
a c 177 V Motherboard
May 27, 2010 1:41:54 PM

I did get the latest TechNet technical library yesterday, and will look once I get it on a DVD for installation... If the "controller substitution" method is what I'm thinking, and involves modifying some .inf's and registry keys, the only version of the .inf's I could find in MS' knowledgebase didn't have new enough 'substitute' drivers for me to guess it would work on a more or less 'modern' machine - but - who knows?
m
0
l
May 28, 2010 5:49:47 AM



Success! (Well, sort of... I did it without F6, so as far as getting ALL
AHCI running on GA-X58A-UD3R this is

=== S * O * L * V * E * D ===

As far as getting the above accomplished through F6, I still know of no solution.



The problem with Turning an AHCI mode on on a SATA controller is that there
needs to be a different driver
then the one already present on Windows XP (IDE mode driver), for the
controller to communicate with the drive. We then have a following paradox:

Turn the AHCI ON and you can't boot into windows.
Turn the AHCI OFF (IDE or "Compatibility" mode ON), and you can boot into
Windows XP, but cannot
install the AHCI driver since the controller is not ON (AHCI mode is OFF).
Catch 22.


OK, I did the "controller substitution method". The idea is from (Archived) Wikipedia
banned article that I have posted above.

Steps as follows:

- Install XP with all controllers in IDE (Compatibility Mode),
The "to be boot" drive connected to Intel controller
(do not use F6 at all, unless there are other things you have to preload).
Run Intel INF installation utility 9.1.2.1007 2010 04 29

- Reboot

- Install: Marvell and Gigabyte AHCI drivers. (Gigabyte and JMicron drivers are packaged into one):
- Marvell Console Driver [SATA3] 1.0.0.1027 2009 11 10 (from GBB Site)
- Marvell RAID Driver [SATA3] for AHCI Mode 1.0.0.1036 2010 04 29 (from GBB Site)
- GIGABYTE SATA2 Driver 1.17.54.1 2010 04 29 (from GBB Site)

- Reboot with Marvell controller switched to AHCI and second drive attached to it.
Make sure Marvell AHCI is listed in SCSI Controllers section of Device Manager.

- Reboot with Gigabyte controller switched to AHCI and second drive attached to it.
Make sure Gigabyte AHCI is listed in SCSI Controllers section of Device Manager.

- Reboot with Intel controller switched to AHCI and BOOT drive attached
to Marvell or Gigabyte
, and a second drive attached to Intel controller.

- Install Intel SATA RAID Driver 9.5.0.1037 2010 03 03 (RST) (from GBB Site).

- Reboot

- Viola!

Feel free to boot from ANY controller, in ANY* mode, with ANY other drive attached to ANY controller in Any mode. Any drive in AHCI mode can and should be software-disconnected PRIOR to LIVE REMOVAL (just like a USB drive, and from the same control applet in System Tray). Do not LIVE disconnect your system drive (shouldn't be possible anyway). I haven't tried to boot from eSata ports, but I do not see why not.

* ANY above should be understood as freely switching controllers from IDE to AHCI mode and back at will.
I do not know about RAID mode, you might need more drivers to be installed to run RAID modes.

Bilbat, thank you for digging through with me and losing sleep.
m
0
l
a c 177 V Motherboard
May 28, 2010 5:01:41 PM

Always !

Deviously clever solution! I will definitely be adding a pointer to this one to my 'fix list'!

As for missing sleep - never happens! I often apologize here for dropping something in 'mid-course' toward evening. As I said, I'm nuts [:bilbat:2], manic-depressive; makes one 'naturally insomniac', insomnia leads to mania, which leads to worse insomnia, and more mania - and, pretty soon, I'm pacing around the ceiling with my tinfoil hat on, to prevent the NSA and nVidia from altering my brainwaves[:fixitbil:9]!

Roundabouts 10PM central, I take enough hypnotics to drop a dancing elephant [:jaydeejohn:3]

On of the main sources of difficulties in my life has come from it taking forever to learn (mostly, the hard way :??:  ), that 'passing out' in a drunken stupor IS NOT equivalent to sleeping!
m
0
l
May 29, 2010 3:20:19 AM

Just tried to boot from eSata (in AHCI) - no problem, boots just fine.

Have other problems with this mobo, but those belong to a different thread, will post that tonight may-be.

bilbat, easy with that elephant buddy... may-be let it dance, we only live once (according to the manual) :D 
m
0
l
July 2, 2010 12:22:02 AM

devt333 said:
Just tried to boot from eSata (in AHCI) - no problem, boots just fine.

Have other problems with this mobo, but those belong to a different thread, will post that tonight may-be.

bilbat, easy with that elephant buddy... may-be let it dance, we only live once (according to the manual) :D 


i think i have the same issue with the x58a ud3r mobo. i have completely installed window 7 64bits. i checked the bios setting and it show my intel 40gb ssd was detected in sata mode, however the wd 1tb sata 6.0gb hdd was still in ide mode. the wd hhd was connected to the marvell 9128 port which should be supported sataIII as it was advertised from gigabyte. do you have any clue about this issue?
m
0
l
a c 177 V Motherboard
July 2, 2010 1:45:01 AM

The fact that a port is indicated by POST as 'IDE' has nothing to do with SATA vs IDE - it is a SATA drive attached to a SATA port on a SATA controller - the IDE indication is the mode of operation of the SATA controller - it is in 'compatibility mode', using the same BIOS vectors as IDE - that's all! For a controller to be in anything but "IDE mode", you must have enabled either AHCI or RAID mode, for the controller, in the BIOS... Windows 7 has 'native' support for AHCI, but I don't think it extends to the (POC) Marvell controllers - I have not been able to confirm this, as Marvell sets a new record for complete neglect of their own users!

from another post, two days back:
SATA3 is, at this point at least, totally useless. The 'physical' side of hard drives cannot (and will not, for years) produce a data stream that comes even close to 'pushing' the capabilities of SATA2, much less 3... So far as I am aware, there are only three SSDs that can read (not write!) at speeds 'into the realm' of SATA3 (NewEgg list), and two of them (the Crucials) have terminal firmware problems yet... The 'venerable' Intel SATA2 ICHs outperform the Marvell SATA3 controller hands down: Benchmark review

For the time being, you are much better off leaving the Marvell off (disabled), and connecting everything elsewhere!
m
0
l
July 2, 2010 4:46:51 AM

if i switch the port now from marvell 9128 to another sata port, would i have to format the hdd again or it is a plug and play. sorry coz i am a new guy in custom built. in addition, do you think it is better to download the vga drive from asus or ati(asus eah5870). thanks for all your effort.
m
0
l
a c 177 V Motherboard
July 2, 2010 4:08:55 PM

It should not matter where the already formatted drive is plugged in - but there are no guarantees - only way to know for sure is to try it!

As for the VidCard, can you give me some more of the part number? Asus appear to make three EAH5870's: the EAH5870/2DIS/1GD5, EAH5870/2DIS/1GD5/V2, & EAH5870/G/2DIS/1GD5. I want to pull a manual, to ensure the card is 'to reference', and doesn't have any 'clever invention' type OCing or anything else that would limit your driver choice. I'm pretty particular about only buying 'reference' cards, so I get all my drivers direct from ATI (10.6 was just released - but lots of griping going on, I guess I'd recommend sticking with 10.5 for now...)
m
0
l
November 27, 2010 1:56:10 PM

Thanks devt333!

Your solution is clever and flexible and worked with my GA P55A-UD3 MB for installing WHS. Key elements include (excuse my nomenclature):

CMOS first in IDE mode for SATA and GSATA, Install the OS (F6 is not needed).

Save Hardware Profiles (do this as a bare minimum under the Hardware Tab in System Properties) and perhaps clone a few OS HD images along the way

If the OS is on the GSATA, power down and add a blank drive (this was the main trick) to a SATA port, and while booting up, go into the CMOS and change the SATA mode to AHCI in Integrated Peripherals

Load the AHCI drivers for the blank drive, most everything may be installed directly from the MB CD (including for WHS using S2k3 drivers) – I did not have to download “special drivers” from the Intel or GA websites – However I did use the TEXTMODE, CAT and INF files downloaded for S2k3 for the SATA AHCI drivers (but I suspect these are on the CD too)

Power down, switch the blank drive from a SATA port to a GSATA port and the OS drive from the GSATA port to a SATA port, and while booting up, go into the CMOS and change the GSATA mode to AHCI in Integrated Peripherals (now both SATA mode and GSATA mode are AHCI!)

Again load the AHCI drivers for the blank drive as before from the MB CD and you are good to go with just about any configuration between IDE and AHCI.

Thanks again devt333!
m
0
l
December 8, 2010 1:14:04 PM

This is my first post, so be gentle..

The way i did it on my X58A-UD5..(single boot drive)

Set all controllers to ahci in BIOS,
attached drive to the gigabyte/jmicron sata port 0,
Installed XP using the F6 to install Gigabyte/jmicron controller drivers,
Booted windows, let it install all drivers (few re-boots).

THEN - Install the INTEL drivers ('Rapid Storage Drivers' - I think - from Intel site)into your OS, Reboot/Restart..., then turn PC off.

Now - Attach the boot drive to sata port 0 on the intel controller, then START PC, --- Viola!

This also worked for me with XP Already Installed previously (3yrs old install originally on core2duo).

Can now switch the drives between the controllers, no problem.

Hope this helps..
m
0
l
February 16, 2011 11:50:45 PM

Hello to everyone:

Tittle for this: Problem:"Windows 7 "Sleep Mode" not working after switching to ACHI" and a gift for you all: "Guide: How to change to ACHI easily without reinstalling the whole Win7 OS".

First the gift: I manage to change to ACHI on a GA X58A-UD3R with Windows 7 x64 already installed WITHOUT reinstalling or downloading any driver (Windows 7 reinstalled ALL drivers by it self or downloaded automatically from the web thru "Windows Update"). I followed the steps in this guide, since what I was really trying to do is to install MAC OS 10.6.5 in a second different HD. One of the requirements was to change ACHI in the MB. Gladly they made a guide for changing ACHI without reinstalling Windows 7 again. Well, here is the guide:

Now the PROBLEM:
After I changed my settings in my MB from IDE to ACHI, Windows 7 x64 wont enter in sleep mode. Do you know how to solve this problem ???

Thanks !!!

Xeikon
m
0
l
a b V Motherboard
February 18, 2011 6:11:47 PM

The really easy answer is supplied by microsoft here ('Let me fix it myself' section):

http://support.microsoft.com/kb/922976

1) First you boot to Windows 7 with the disk in Legacy/IDE mode
2) Then you change the registry entry as stated in the Microsoft Knowledge Base article
3) Next you restart and change the BIOS entry from Legacy/IDE to AHCI for the appropriate disk controller
4) F10 Save and restart.

Brings your SSD from a 5.9 WEI to 7.x depending on the size of the drive. Mine's currently 7.7 after making the switch.

That's it.
m
0
l
February 19, 2011 12:08:25 AM

I tried the cable switch idea with XP and it worked great!!! Thanks for the info!!! However I added a new twist. I wanted to setup RAID 0 with XP on the Gigabyte GA-P55A-UD3 GSATA with ACHI enabled. So what I did was enabled ACHI on the GSATA, in the BIOS saved and restarted. Then I setup the RAID 0 with 2 - 1TB 6GBs WD Hard drives which showed ACHI enabled in the RAID setup. Saved the configuration and powered down. Then I disconnected the RAID drives and installed a blank hard drive on the SATA2 controller. I loaded XP Pro. in IDE mode on the blank drive then loaded all the drivers from the CD which automatically loaded the ACHI drivers for the GSATA RAID controller. I shut down and connected the RAID drives back to the GSATA controller and booted. Windows XP found the drives and loaded the virtual disk which I initialized in Disk Management. Then I backed up (created an image of) the install with Macrium Reflect free edition to an external USB drive. After the backup I immediately restored it to the RAID (which went on the drive in ACHI mode). I then shutdown and removed the originally blank drive that I loaded with XP then booted to the RAID. Windows recognized the new Drive as C: and asked for a reboot. During the reboot I enabled the ACHI on the SATA2 controller so when windows booted it asked for the ACHI driver. Since my SATA CD/DVD drive was on that controller as well I couldn't access it to load the driver, so I downloaded it from Gigabyte's website. It was the F6 driver. I pointed the install to the driver and it installed. Then my SATA CD/DVD popped up and was installed. I then powered down and added a 1.5gb backup drive to the ACHI SATA2 controller, booted and formatted it. I use Macrium Reflect to automatically backup the RAID once a day (since it is RAID 0) so if one of the drives fails I can simply restore. Once again thanks for the hints on how to install ACHI in Windows XP.
m
0
l
!