Sign in with
Sign up | Sign in
Your question

I think Bootfix messed up my boot record and now I get Disk Read Error

Last response: in Windows XP
Share
May 24, 2012 1:00:26 PM

I ran Bootfix from a flash drive to try and fix this boot problem I had, but the problem just got worse. Now when I try to boot, immediately after the HP splash screen on my computer, I get a message saying "A disk read error has occurred. Press Ctrl+Alt+Delete to restart."

I booted into Parted Magic and opened the partition manager on the desktop, and saw that my whole hard drive had become unallocated. And the Properties window said "Cannot have partition outside the disk".

The hard drive in question was originally one drive with an extra tiny partition on it. Now it's a C: drive and an E: drive after Bootfix ran. Any idea what happened here, and if it can be fixed? Without a Windows XP CD?

Not sure where this fits, I wanna say Configuration & Customization, but this might be a malware issue so it might fall under Security. Or the whole boot problem might be because of a corrupt Driver. But because configuration got me into this further mess, I'll try that one.

Also I can attach this hard drive to another computer and run CHKDSK on it, if anyone needs me to.

Also, I don't think I have backups saved of the boot, but I do have a text dump of my master boot record, if it helps. I think the problem is it can't find the NTLDR. Because Bootfix did something and now it's lost somewhere on the drive.
May 24, 2012 2:25:56 PM

http://www.techsupportforum.com/forums/showpost.php?p=1...

You could try the steps provided in the link. But there are some conditions. First I would test your HDD just to make sure it hasn't failed. No reason to fix a broken drive.

Just do some research into partition table recovery and be very very careful if there is data you need off of it.
m
0
l
May 24, 2012 7:16:06 PM

The HDD works, I mean, all of the data on it is fine. The drive appears in My Computer and all of the files are on it, but I can't boot from it.

I should note, it used to be one drive and a partition, but now it's two drives. Which is basically the same as a partition, I guess. So, both the drives appear in My Computer.

I tried TestDisk, but it didn't take. Maybe the drive I chose to boot from was the wrong one?
m
0
l
May 24, 2012 8:23:03 PM

I deleted the extra drive (E:) , and now GParted shows that everything's no longer completely unallocated. There is a small section that is unallocated though, about 2.49 MB in size.

I'm still getting Disk Read Error when I try to boot. I'm thinking it's because of that partition, any way I can delete it?
m
0
l
!