Sign in with
Sign up | Sign in
Your question
Solved

Problems in Playing Far Cry 2 !

Last response: in Graphics & Displays
Share
November 26, 2009 12:27:17 PM

In my system, Far cry 2 and need for speed under cover is having a "frame skipping" effect that feels like "jumping forward" when in the game play (in all quality settings). I played call of duty modern warfare two and it is running superb with maximum settings.
My machine configuration is :

Intel corei7 920 - 2.66 GHz

8 GB Kingston DDR3 RAM

Intel DX58SO main board

2 X 500 GB Hitachi SATA hard disks

MSI nVidia 9800GT (N9800GT-T2D1G-CO) 1GB.

Windows 7 Ultimate 64bit

ASUS 550W P-55GA power supply

Res is : 1440 x 900

More about : problems playing cry

a b Î Nvidia
November 26, 2009 12:31:10 PM

Is V-sync on in the graphic options ?
m
0
l
November 26, 2009 3:52:48 PM

I did run Far Cry on both directX 10 and 9.. both gave same results.. :( 
m
0
l
Related resources
November 26, 2009 3:54:23 PM

Maziar said:
Is V-sync on in the graphic options ?

I tried with and without v-sinc.. but same result.. same "jumping" effect is there.. :( 
m
0
l
November 26, 2009 3:55:32 PM

Quote:
Also, is it running in dx10 or 9 mode?

I tried both diretX 9 and 10 modes.. but gave me the same results.. :( 
m
0
l
November 27, 2009 2:53:22 AM

Quote:
I am assuming there does not appear to be any jumps in actual fps numbers and that it runs pretty constant?

Ya.. frame rate runs smooth in the testing mode. but that 'jumping' effect is there.
m
0
l
a b Î Nvidia
November 27, 2009 6:29:34 AM

hmm,is it like a "One-sec periodic lag"? i mean the FPS is the same but for a second the game freezes and again it moves on ?
m
0
l
November 27, 2009 6:32:08 AM

Maziar said:
hmm,is it like a "One-sec periodic lag"? i mean the FPS is the same but for a second the game freezes and again it moves on ?

Exactly. it is not for a one second. but for a very litle time.(less than one second) but can feel it.
m
0
l

Best solution

a b Î Nvidia
November 27, 2009 9:27:31 AM

Well here are 2 threads with the same subject in another forums:
http://forum.notebookreview.com/showthread.php?t=170763
http://forum.notebookreview.com/showthread.php?t=169041
The recommendations are
1_Setting "Threaded Optimizations" to OFF has helped,(Open the nVidia control panel, go to "Advanced 3D Settings," and set "Threaded Optimization" to "Off." )
2_Set Texture Filtering - Negative LOD to Clamp
3_Set your page file correctly (RAM * 1.5 = PageFile)

Check if they help you or not
Share
November 28, 2009 11:00:43 AM

Maziar said:
Well here are 2 threads with the same subject in another forums:
http://forum.notebookreview.com/showthread.php?t=170763
http://forum.notebookreview.com/showthread.php?t=169041
The recommendations are
1_Setting "Threaded Optimizations" to OFF has helped,(Open the nVidia control panel, go to "Advanced 3D Settings," and set "Threaded Optimization" to "Off." )
2_Set Texture Filtering - Negative LOD to Clamp
3_Set your page file correctly (RAM * 1.5 = PageFile)

Check if they help you or not

K.. ill try these things out.. thanks guys.. thanks alot.. :bounce: 
m
0
l
a b Î Nvidia
November 28, 2009 2:20:20 PM

No problem,hope it helps you ;) 
m
0
l
November 28, 2009 2:56:53 PM

3_Set your page file correctly (RAM * 1.5 = PageFile) said:
3_Set your page file correctly (RAM * 1.5 = PageFile)


8gigs and still using pagefile?

m
0
l
a b Î Nvidia
November 28, 2009 3:06:46 PM

Its a possibility,its good to check
m
0
l
December 2, 2009 12:54:15 PM

Maziar said:
Well here are 2 threads with the same subject in another forums:
http://forum.notebookreview.com/showthread.php?t=170763
http://forum.notebookreview.com/showthread.php?t=169041
The recommendations are
1_Setting "Threaded Optimizations" to OFF has helped,(Open the nVidia control panel, go to "Advanced 3D Settings," and set "Threaded Optimization" to "Off." )
2_Set Texture Filtering - Negative LOD to Clamp
3_Set your page file correctly (RAM * 1.5 = PageFile)

Check if they help you or not


Thanks alot for the help brother.. your suggestion is correct.. i re-installed my graphic drivers and it resetted all the settings i changed back to default. (before i had thread optimization on) now its running smooth with ultra settings and 8X antializing. :D  thanks again for the help brother.. :) 
m
0
l
a b Î Nvidia
December 2, 2009 4:07:19 PM

No problem glad it fixed it for you :) 
m
0
l
!