Sign in with
Sign up | Sign in
Your question

PowerColor HD 5770 + Asus A8R32-MVP = No Boot?

Last response: in Graphics & Displays
Share
November 26, 2009 3:37:43 PM

I just purchased a new PowerColor HD 5770 card to upgrade my twin X1900XTX cards in my Asus A8R32-MVP motherboard. I researched before I purchased the card to be sure it would be compatible, and other than it downgrading to PCIe 1.0, it seemed to be ok. My power supply is an Enermax Liberty 620, so I know I have lots of power there. I put the new vid card in, and it won't even get to the BIOS, no POST beep or anything. I called PowerColor, and they said some motherboards do not support a 1GB vid card? Has anyone heard of that before?
November 26, 2009 5:30:30 PM

I think at the problem has to do with the PCIe v1.0a that is on the motherboard. I've been reading where others have had an issue plugging in late model v2.0 cards into the older v1.0a slots and the board not booting up.
m
0
l
November 26, 2009 9:10:50 PM

I have the latest BIOS installed, v701. The problem is that the "latest" BIOS is from 2007 :) 
m
0
l
Related resources
November 27, 2009 1:11:54 AM

reset CMOS - you may have to use card other than 5770 to get into the bios - make sure all settings compatible with 5770 - power down - install 5770 - Hope For Post !! Can't remember, but think there is PCI/PEG option or somesuch within the bios. Ciao !
m
0
l
January 7, 2010 9:09:39 AM

I have the exact same problem, the diference is i have a Asus HD 5770 and a Asus M2A-MVP mobo.... i have the latest bios update form 2009 and a PCI-e 2.0 ... i've been runing a HD 4670 till now.... and the power supply is 650w ... so... any other ideas? :( 
m
0
l
January 7, 2010 6:08:12 PM

Sorry, no help here. I had to resort to buying a new MB (along with new CPU, memory, etc) in order for my new video card to boot.
m
0
l
January 7, 2010 6:52:11 PM

dachrist said:
Sorry, no help here. I had to resort to buying a new MB (along with new CPU, memory, etc) in order for my new video card to boot.


I came to the same conclusion that the mobo is tto old and dosen't suport 1Gb GDDR cards.... goo thing that i exchanged the 5770 with a GTX 260 until i get the money for a new motherbord and cpu and ram and... :( 
m
0
l
!