Sign in with
Sign up | Sign in
Your question
Closed

Alienware m17x Problems!

Last response: in Windows 7
Share
October 10, 2011 5:25:08 AM

My Alienware m17x recently crashed (BSOD and system recovery loop.) So I was forced to do a clean install of Windows. After that, I found out I needed to reinstall all of the computer's drivers. After hours of work, I think I was able to install all of the drivers except for one called the "PCI" device.

I started my computer up and I was greeted with a message titled Notify, it said, "the ac adapter currently connected is not supported. System will continue to run on battery." But in the taskbar, the battery icon was displaying the battery charging animation. I tried to open programs and the computer was extremely slow to respond, when the program did open, it would crash in a few minutes and the entire computer would freeze. When I tried to use the Internet, it would run for a few minutes and then result in another freeze. I have rebooted repeatedly to no avail. Does anyone have any idea how to fix this?

Summary of Problems:

Computer is very slow to boot up, open programs, and respond.
Computer thinks AC adapter is unsupported but it still charges
PCI device driver is not working and I can't find the Driver
Mouse does the loading animation every few seconds
Internet cuts out and computer freezes every few minutes and the computer needs to be restarted
Gets stuck logging off when shutting down

Best solution

October 10, 2011 6:32:08 AM

For the PCI device, go into Device Manager.
From there right click the PCI Device and go into Properties. In the Details tab select Hardware IDs from the dropdown list.

You should see something like "PCI\VEN_1111&DEV_0000&blah blah blah"
Go to www.pcidatabase.com and search using the DEV number. It should give you an indication of what the device is.

Not sure about the freezing/slowness. Could be an incompatible driver?
If the laptop came with an application disk you could try uninstalling all current drivers and installing ones that came on the disk.
Share
October 11, 2011 1:25:24 AM

I located the PCI Driver, updated my bios and got rid of a driver called "Intel(R) HM67 Express Chipset Family LPC Interface Controller - 1C4B," which greatly increased my system speed.

Now my computer runs ok, but major problems remain. Every time I open a large program such as Powerpoint or iTunes, my computer freezes and the Wifi cuts out, it seems to be only a partial freeze though because I am still able to open my control panel, and minor windows applications, but when I try to open the network settings, the will not open for some reason. My computer is also still showing the loading animation every few seconds and when it boots up it is showing the "Ac adapter currently connected is not supported. System will continue to run on battery," message, even if the adapter is not plugged in, and warnings are disabled in BIOS! Also, the Alienware Command Center says that it is running in Disabled Mode. Any Solutions?

Remaining Problems:

Computer freezes and Wireless cuts out after launching programs
Network settings sometimes won't open
The unsupported AC adapter message appears even if the adapter is not plugged in
Alien FX is running in "Disabled Mode"
Windows stops responding.
Score
0
Related resources
October 11, 2011 2:22:56 AM

If you installed the drivers from the Alienware website and it's still having issues you could try formatting again and installing everything from scratch.
If that fails I'd recommend sending it back.
Laptops, unless you've changed hardware or hardware settings (overclocked etc), shouldn't blue screen.
Score
0
October 12, 2011 12:24:23 AM

I think I fixed it... I downloaded a program called Driver Identifier and from there I was able to to locate and update all of my drivers. The only problem I have now is the "notify" message...

Thank you for your help!
Score
0
October 12, 2011 12:25:11 AM

Best answer selected by topazoo.
Score
0
a b $ Windows 7
October 12, 2011 12:25:51 AM

This topic has been closed by Nikorr.
Score
0
!