Sign in with
Sign up | Sign in
Your question

Ram help with dell dimension e520

Last response: in Motherboards
Share
May 28, 2010 8:19:59 AM

I'm ususally a problem solver myself, however this time I need assistance on the matter at hand.
I've brought a 2gb gkill ddr2 800 ram at a cheap price, and I've tried to upgrade my dimension e520. However, the computer failed to get past the bios screen, f2 and f12 aren't responding, I then tried to boot with my original stock ram, but to no avail. The computer would not get pass the bios loading screen.
Any help would be appreciated
-Leon
May 28, 2010 5:10:51 PM

Do you have the RAM pushed in all the way?

Also, does the motherboard beep?
The number of beeps can give you a clue. Use the number of beeps (beep code) to find out what the issue is.

If it's not beeping and you are sure you have the RAM properly inserted then you likely have a motherboard issue. You may need a new motherboard. But before buying a new one I would try reseting the CMOS.
m
0
l
!