Sign in with
Sign up | Sign in
Your question

GA-X58A-UD3R GSATA RAID Config in BIOS Freezing

Last response: in Motherboards
Share
May 30, 2010 8:44:47 PM

Hello,

I have zero experience with RAID arrays.

On this board, I am not trying to build RAID just yet, but may do so in the future.
I am just checking all options in BIOS to get familiar with and to make sure that this board is fully operational before my 30 days from purchase expire.

I am going to a BIOS option "GSATA RAID Configuration" under "Integrated Peripherals", and enter it.
It says on the bottom of the screen:

Marvell RAID On-Chip Controller
Enter: Operation, F10: Exit\Save, Esc: Return

So, when I hit Escape, nothing happens, I am not back in "Integrated Peripherals", I am still in GSATA RAID Configuration.
(Escape button works elsewhere in BIOS)
When I hit F10, I receive a prompt "Exit YES or NO", I hit "Y" and it exits back to "Integrated Peripherals" sometimes normally, and sometimes not, meaning that sometimes I can't move my selection anywhere else in BIOS after exiting "GSATA RAID Configuration by way of F10.

Also, I think F10 way of exit is exit with saving, so this would mean that exit without saving, "Return" by way of ESCAPE just doesn't work.

I have no RAID drivers or utilities installed, just AHCI drivers. Since this is a Raid Control, can it be that I need to load RAID drivers before this portion of BIOS becomes fully operational?

There is a noticeable delay both entering "GSATA RAID Config" and exiting it.

RAID experts, what do you think?
a c 177 V Motherboard
May 30, 2010 10:35:10 PM

Do you have "GSATA 6_7/IDE Controller" two items above "GSATA RAID Configuration" set to "Enabled"? Do you have a pair of disks connected? Some RAID configuration sub-systems cannot be entered with either of the above conditions satisfied... You would think it would just gove you a 'graceful' error message - but, who knows...

The Marvells are pretty much useless at this point anyway... Give 'm a year of option ROM revisions, and driver fixes, and by that time there might be something fast enough to connect and make actual use of them!
m
0
l
a c 177 V Motherboard
May 30, 2010 10:36:20 PM

Oh - & it has nothing to do with drivers - BIOS uses no drivers for anything - has no means to load 'em...
m
0
l
Related resources
Can't find your answer ? Ask !
May 30, 2010 10:50:26 PM

Ah, I see. No drives connected, 6&7 enabled. I have tried with one drive connected to 6, and it was same, but more often it exited through f10 more gracefully. Stiil no exit without save through Escape key.

I am a little skimpy to connect my boot sta and data sata drives there to test RAID rom function, but I should find some empty satas laying around.

Thanks bilbat!
m
0
l
a c 177 V Motherboard
May 30, 2010 10:56:12 PM

Always !
m
0
l
May 31, 2010 3:03:45 AM

Just tried to boot with two 1tb black wds connected to 6 and 7 ports (Marvell), and the behavior of GSATA RAID Configuration portion of BIOS is the same as originally described. Still no exit through Escape key. Still a delay both entering and exiting.
m
0
l
a c 177 V Motherboard
May 31, 2010 4:08:55 AM

Think it's time for a bug report to GB's tech support...

This is, however, likely a Marvell problem - not likely a GB problem! When they 'throw in with' a supplier for a sub-system chip, like a CODEC, or a LAN transceiver, or, god forbid, a SATA3 controller), they are given a 'template' design to follow (the process is called: 'design by reference'; the exemplar design template is called the 'reference design'...), and typically, the service includes the 'chunk' of BIOS (called the 'option ROM'), as well as drivers & updates. This process is most apparent in Vidcards - it's why, say, all 2Gb 5870's look alike - they're all to an ATI 'reference' design (or, in that case, may even be made by ATI for their 'channel partners'... They always have to hope they've 'thrown in with' the right guys; that it'll work, and that upgrades to both code and drivers will be forthcoming - but in the case of the SATA3 - they were the 'only game in town'!
m
0
l
!