Sign in with
Sign up | Sign in
Your question

Nvidia 8800GTS, powers but no display

Tags:
  • Nvidia
  • Graphics
Last response: in Graphics & Displays
Share
Anonymous
November 28, 2009 12:19:57 AM

It's another one of those gents.

I've built the system i'm currently using about 2 years ago and has run everything i do flawlessly, though recently some things have happened.

Whilst playing Saints Row 2 (PC version), the game randomly froze. Freezes are common in the SR2 client due to its nature as a horrible port with many holes.

Anyway, i performed a hard reset and since then many problems have arisen. Firstly, my PC no longer detects my video card (Listed below), and my memory has been acting up, but i've managed to keep it stable. In order to log in to my PC i've had to use the on-board graphics unit with my mobo.

In this mode ( On Board ), when i go into device manager, the card is listed as "3D video controller" under "other devices" with a small yellow "!" next to it.

The odd thing is, the card is functional and running, with the fan operational and the sounds heard if directly connected by VGA (Login sounds, etc)

Is there any hope, i don't feel i should have to pay another £60 or so due to a random crash in a horribly optimised game, if that indeed is the cause...

Specs:
CPU: Intel Core 2 Duo E6550 @ 2.33ghz
GPU: Nvidia 8800Gts
Memory: 2GB Ballistix @ 800 Mhz
PSU: (Unknown make) @ 500w

More about : nvidia 8800gts powers display

December 6, 2009 7:05:14 PM

it sounds like the driver became corrupt or is missing. try reinstalling from Nvidias website and see it the exclamation mark goes away in device manger.

oh wait you are onboard video? ok that means you need to install the drivers for that from the manufactures website.

though to be honest, i think you are having larger hardware problems than just your video card.
Related resources
!