Sign in with
Sign up | Sign in
Your question

SSD not being recognised

Last response: in Storage
Share
October 22, 2011 7:01:41 PM

Hey guys I just recently purchased a Corsair Force 3 SSD.
I wanted to update the Firmware but the Corsair Firmware updater cannot find the drive. Also in my Nvidia Control panel for my storage device settings the drive again does not appear. I've installed all the Nvidia drivers and ACHI Drivers. The bios settings are also set to ACHI.
I have installed Crystal Disc to see if the drive appears , and it shows the drive and all the information based on the drive.
Has anyone experienced this or has any advice, its driving me nuts, it's my first SSD and I don't have much experience with them.
Is there any way to fix this problem to make the drive appear?
Thanks

System Specs
E8500 OC 4GB
ASUS Striker II Extreme
OCZ 8GB 2000Mhz
CORSAIR Force 3 SSD 120 GB
2 x GTX 560ti SLI
ENERMAX Revolution 1020 Watt PSU
Windows 7 64

More about : ssd recognised

a c 119 G Storage
October 22, 2011 7:13:49 PM

Go to the start menu and in the run box type in Disk Management and when the screen pops up right click on the Corsair drive and initialize the drive. Setting the patition is the same thing and then you want to format it. I don't like saying this as you have the drive already but the Corsair Force GT is a much better SSD. IMO.
m
0
l
October 22, 2011 7:24:27 PM

Thanks for your reply , I have already initialised the drive and formatted it in Disk Management. The drive is showing in Disk Management and is reporting it as healthy.
I agree the Force GT would of been a better choice, but I got the Force 3 for a good price.
I'm stumped , I've done everything with getting this drive up and running to the best of my knowledge, am I missing something else?
m
0
l
Related resources
a c 119 G Storage
October 22, 2011 8:07:21 PM

I do have two questions;
1. You said that in the Nvidia control pannel it does not appear under storage devices , I thought that the Nvidia control pannel is for video cards not storage devices.
2. Do you see the SSD in the bios , in the boot devices menu? Or the storage devices menu
3. Do you have another hdd that your OS is on , I didnt see one listed.
Oops thats three , oh well , I did notice that you have a Asus Striker 11 Extreme , that is an old MB , have you updated the bios and let me know if the bios sees the drive.
Do you see the drive in Computer?
m
0
l
October 22, 2011 8:16:38 PM

1 The Asus Striker Extreme is an Nvidia board so all the drivers including storage are from Nvidia for the mobo. All the Mobo's settings are in the Nvidia control panel , it shows storage devices , ethernet adaptor settings and also graphics settings in the one program.
2 The SSD appears in the bios in boot devices menu
3 The SSD is the primary drive, I have a velociraptor for storage which I removed untill I sort the primary drive first (SSD)
4 I have the latest Bios and the drive appears in the bios as normal and in my computer also.
m
0
l
a c 119 G Storage
October 22, 2011 8:48:00 PM

Well I guess I am confused , you are saying that the SSD is your primary drive and you are using it now as we speak for your OS. But you are trying to update the firmware and the updater is not seeing it ? I wonder if it isn't seeing it because you have the OS on it. I have the Corsair Force GT and I did a firmware update but I did do it before I loaded the OS on it. You do sound that you know what you are doing so I hate to ask this question , did you download the right firmware update for your SSD. I just went to the Corsair forums page where they have the updater and there are a lot of different downloads , I am wondering since the updater can't find your SSD maybe you got the wrong one ?
m
0
l
a c 119 G Storage
October 22, 2011 8:51:12 PM

Also if you are not having problems they do say it's not necessary to do a firmware update , I know it's not easy to ignor since an update is there you want to do it.
m
0
l
October 22, 2011 9:58:59 PM

I've downloaded the firmware driver 1.32 for the Force 3 120GB SSD it is in a package called the Corsair Field updater V1.1. Its definately the right driver, the updater shows no drives in the list to update.
The only reason I want to update the firmware is because I get a disk failure on boot up sometimes, I reboot it and it comes back to normal , not often but enough to make me try the update, thought it might fix that problem.
m
0
l
October 24, 2011 7:09:21 PM

I went through a very similar issue the other day with my SSD install. If you look in your device manager, I suspect that your SSD is recognized as a SCSI driver rather than a SATA drive.

What I found was that the SSD did not work well with the nVidia storage controllers and I had to roll them back to the standard Windows 7 IDE ATA controller. Once I did this, my SSD was recognized by the firmare software, and everything worked much better.

I got the following extract from the OCZ forum that pointed me in the right direction to rollback the drivers...

http://www.ocztechnologyforum.com/forum/showthread.php?...

-Uninstall nvidia nforce chipset drivers (all of them)
-Run nasty files remover to remove ALL of the nvidia drivers
-Uninstall the sata controllers labeled as "nvidia nforce serial ata controller" from the devices manager, checking the erase driver checkbox when available
-Reboot. They come back now as "nvidia ata controler" or something like that, under IDE ATA/ATAPI controllers. Now I can switch drivers to use "standard dual channel pci ide controller".

Good luck

m
0
l
November 2, 2011 9:57:27 PM

Thanks for your advice ae7456t.
I uninstalled all the nvidia chipset drivers, ran nasty files remover and it only detected the display drivers.
I uninstalled ythe nvidia nforce sata ata controllers from the device manager but they just keep coming back after restart.
The Ahci driver and standard dual channel pci ide controller have dissapeared from device manager now , and it still shows the force 3 as a SCSI drive.
Not having much luck here , I've tried everything but it just wont work for me.
Now when I boot up it sometimes goes to a black screen for about a minute before it goes to the welcome screen , Its running much slower now :( 
m
0
l
November 5, 2011 3:50:14 PM

monsta...sorry my fix didn't work for you. The only other step that I would recommend is after removing the nvidia nforce driver, when the system reboots and you are in the Device Manager, in the IDE controller section, when you select a device and choose "update driver", choose the option to "browse my computer...", then on the next screen, it allows you to "Let me pick from a list of device drivers...". At that point, you should be able to select the standard Windows driver for the IDE controller (and all other IDE controllers listed), and it should eliminate the nvidia drivers from then on.

The SSD is worth it, but sorry it has been so tough to take advantage of it.

Good luck...
m
0
l
November 8, 2011 11:12:10 PM

AE7456T your advice has been great , thank you, everything you have said makes perfect sense , I just don't understand how the nvidia storage drivers have taken over my pc. I re-installed windows 7 and again , they are still there , the standard IDE controller is showing and also the AHCI driver but selecting them does nothing, the nvidia drivers are still active.
My pc now has random freezes, I feel my SSD upgrade has been a major dissapointment.
I don't believe the SSD is faulty and that its just the drivers that are making it unstable, what's your opinion?
I'm just going to sit it out and wait for the X78 Mobos to arrive and not have to deal with any nvidia storage drivers , think its my only resolution to my problem.
m
0
l
November 9, 2011 4:33:19 AM

Formatting the drive made no difference , the drivers appear to be installed by default by the motherboard on first boot up.
m
0
l
November 11, 2011 10:19:58 AM

I'm going to RMA the drive , it started to get worse , freezes and locks up with any download or install and even browsing the net.
Hopefully it was just a bad drive and I can get my system up and running again with a SSD.
Put back my WD Velociraptor and it works perfectly, even tho it also shows up as a SCSI drive.lol
m
0
l
!