Sign in with
Sign up | Sign in
Your question

ASUS M4A785TD-V EVO and Corsair XMS3 DDR3-1333

Tags:
Last response: in Memory
Share
June 1, 2010 11:04:33 AM

Hey guys. To cut a long story short, I finally got my replacement RAM after 3 months of waiting. I loaded them up but I'm having all kinds of problems.

Before I go any further,
OS: win7 x64,
mobo: ASUS M4A785TD-V EVO
memory: 2x 2GB Corsair XMS3 DDR3-1333

I think that the new DIMMs might not be compatible with my motherboard, or I'm not installing them properly for dual channel. If I install either one on its own, the system boots and works 100%. memtest86+ also passed with 0 errors, so I'm pretty sure the RAM isnt faulty. As soon as I add a second DIMM everything goes haywire. The system boots, but loading a game in cod4 either locks up the system completely, or has some crazy flickering and other graphics glitches. Sometimes windows has artifacts and weird colours too.

In the mobo manual, on page 1-11 for reference, they label the memory slots A2,B2,A1,B1 (Black,Black,Blue,Blue). This should mean that I need to load them up in either the black slots (A2,B2) or the blue slots (A1,B1) for them to work in dual channel right? No matter what configuration I try, it doesnt work with 2 DIMMs.

Please help. If this RAM doesnt work I dont know what more I can do. I'm more exasperated than I might sound, believe me :/ 

Thanks
a c 128 } Memory
June 1, 2010 1:40:50 PM

Try changing the setting for "memory mapping" in the bios, and use the auto setting for timings.
June 1, 2010 2:10:02 PM

Thanks, the timings (and clock speeds and anything else adjustable) are on auto. I can't seem to find any setting like "memory mapping" though?

Sigh, I think one of the two might be faulty, but I'm going to install linux tonight and see how that handles the RAM, and if it isnt maybe something else that's the problem
Related resources
a b } Memory
June 1, 2010 10:33:16 PM

Check it with Memtest 4.10 and be sure to diasble Legacy USB Support in the BIOS as Memtest has a conflict with this setting on some ASUS boards. Check each module for 3-5 passes each.
June 2, 2010 8:41:52 PM

Meh, I'm pretty sure the one DIMM is broken. Now even if I put it in by itself I get all the problems mentioned above, but with the other one alone its fine. SIIIGH.

I'm scared that I damaged it when I put it in, how easy is it for static to screw with ram? I worked on a metal table, disconnected the PSU from the mains, and kept contact with the metal on the case as I worked with the stuff.

Sigh sigh sigh sigh sigh
June 2, 2010 8:45:37 PM

Sorry for double post, but I am not allowed to edit

I only seem to have trouble when I run graphical stuff under windows (games, aero itself). My linux partition detects all 4GB and runs as smooth as ever
June 10, 2010 10:48:46 AM

...bump?
!