WD external hard drive problem

Hi guys this is my first post on tomshardware.

You see the problem is my very-new-4-days-old WD passport external hard drive. I was copying a movie into it ( the original exorcist - very worth watching ) and after it finished copying I went on and played some games ( with the hard drive still attached ). While I was shooting up some nazis, I heard a beeping noise coming from the hard disk . After a few minutes the beeping noise came again, but I did not suspect anything. After a while I safely removed the hard drive.

Later on, when I tried to copy some more files into the drive, it wouldn't work. I plug it in, hear a few beeps (!) and no "what-should-i-do-with-this-device" window pops up. So I went to My Computer and it wasn't there. I went to device manager and I saw my WD drive listed there. I even went to Devices & Printers and I also found it there. Plainly, my computer recognised it but wouldn't allow me to access it.

I have tried going to disk management under computer management and they asked me to initialize a "Disk1" but I couldn't, because of a certain "I/O device error".

This hard rive is spanking new and I didn't even drop it or anything like that.


So..........help?
2 answers Last reply
More about external hard drive problem
  1. no reply after a few days??
  2. If it's that new, why don't you get a warranty exchange from WD or the vendor you purchased it from? Everyone gets the occasional bad drive.
Ask a new question

Read More

Hard Drives Western Digital External Hard Drive Storage