Sign in with
Sign up | Sign in
Your question

ATI HD 4200 and HDMI - Screen turns green and then colours distort

Last response: in Graphics & Displays
November 29, 2009 12:24:36 PM

I have just build a new system using the following components:
ASUS M4A785TD-M EVO (integrated HD 4200 with 128 Mb dedicated memory (Sideport)
A-DATA AD31333E002G DDR3-1333+ XPG DDR3 Unbuffered-DIMM Non ECC Memory, 2 * 2 GB

I have installed all the updates and new drivers that I have found. I still have the following problem:

After the computer has been on for some time, from 5 minutes to 35 minutes, the screen suddenly flashes into blank green for one second. Then my display returns to original, but the colours are distorted into pinkish-greenish scheme. This stays like this for 10 seconds to 2 minutes and then returns to normal. This keeps happening on average every 30 minutes.

This happens during normal Windows operation, using only Firefox and IE or nothing at all.

And only when using HDMI cabel. VGA works fine. My display is a Philips 22PFL5604 Full-HD display with both VGA and HDMI.

I am pretty confident the problem is not with the display. I changed in BIOS that the card only uses Sideport memory, 128 Mb and no shared memory, but this had no effect.

Are there any settings in ATI drivers I should try? I am not familiar with ATI settings, having used NVidia for 10 years.

I am most grateful for any advice.
November 30, 2009 7:02:33 PM

Further to my problems, I am also unable to run any 3D programs or games. Running Civilization 4 Colonization freezes the system totally, screen turns black. Only reset button helps. This game run perfectly under 32-bit Win Vista Home Premium. Also tried 3DMark06, this just freezes on the startup screen, I am able to terminate this from Task Manager. What can it be? Posted to ASUS support, hopefully they can help.

I also tried VGA-cable and did not get this distortion - but still no 3D operation.
December 1, 2009 8:01:50 AM

Well, I also contacted ASUS support and they responded (in less than 10 hours!):

"Dear Valued ASUS Customer!

Your motherboard is most likely defective, please contact your reseller."

I guess this is the only way to go. It´s a shame, the MB looked very promising anyway. Hope the next example runs smoothly.

I suppose it is only the HD 4200 chip that is faulty, as everything else works fine. But how can it run 2D (almost) ok, but no 3D?
Related resources
December 2, 2009 6:45:18 PM

Further to this. I decided not to return the MB yet, instead disabled firewall (Comodo) and anti-virus (Avast). This helped to solve the problem with 3D, I can now even run games.

I searched AMD Game Forums and found that there is a general issue with ATI and Philips HD-TV´s:

(If this link doesn´t work, search the forum with "Philips").

Several Philips model/ATI model/Windows version combinations seem to be affected.

I reported this to Philips Custormer Service too.

Let´s see what happens!
December 11, 2009 6:48:07 AM

I shall close this thread as no one else contributed here (hopefully this was useful to someone anyway).

I found the solution via AMD Game Forums.

It is quite simple looking at it afterwards.

In ATI CCC the pixel format needs to be changed from the default YCbCr 4:4:4 to RGB 4:4:4. Then restart your computer and all works fine.

This is however an issue, that either ATI or Philips should do something about, as there are tens of users with this problem. I can't imagine either that someone with only limited IT knowledge could ever solve this problem.

The root cause of this problem seems to be that CCC uses as a default YCbCr 4:4:4 and Philips TV:s do not support this. In CCC on the Pixel format tab it basically indicates that the device supports all these four pixel formats. So is the Philips communicating wrong information or either end does not actually support YCbCr correctly? So the only options in CCC should be RGB 4:4:4 and 4:2:2 and no one would have this problem!
February 10, 2010 9:24:30 AM


Thanks for all the information you've providedon this subject :-)

I have the exact same problem as you (Philips 8404 + ATI 5770 connected via HDMI). I'm wondering exactly what you do in the CCC-menu? I can't seem to find the correct settings...

Thanks, Per Egil
February 10, 2010 8:40:24 PM


It is not the easiest to find, but try these instructions

Right-click on an empty space on your desktop
Open Catalyst(TM) Control Center
Graphics -> Desktops & Displays
Little triangle inside Monitor 1 picture on the botton left corner -> Configure
Pixel Format