Sign-in / Sign-up
Your question

How to deal with IDE drives with Windows 7

Tags:
  • Hard Drives
  • Windows 7
  • Storage
Last response: in Storage
October 24, 2011 8:11:11 AM

My system consists of:
Dell Studio Quad Core Q9550 running on Windows 7 Home 64-bit.
2 HDD drives inside tower Disks 0 and 1 plus another 4 HDD inside a SansDigital TowerRaid Enclosure with ESata cable connected to the PC via a Rocket Raid 622 Controller Card.Adapter
Additionally im using a Sabrent USB-DC5C IDE to SATA/IDE Hard Drive Adapter with own Power source and connected to the Desktop tower via USB cable.

My problem is when using this contraption. I have tried accessing contents of a Maxtor DiamondMax Plus 9 IDE 80GB HDD, a Maxtor D740X-6L IDE 40GB. None of these 2 seem to be recognized by the Windows 7 software, changed the jumpers to the Master position to which both Maxtor and Sabrent recommend, and still no recognition, i can hear the drives spinning and being warm from being active The Start- Computer-Manage- Disk management sequence lets me know that the HDD is there, but it requires being initialized. Gives me the option to choose between GPT or the other option(name slips me now). So as i am unable to "initialize the disks"(individually as i cannot have them both connected at once) i have no access to inspects its contents and furthermore work with them. and Less of all resize partitions even delete and or reformat.
1. that is issue one, any idea what could be happening to them? Is there an issue with my PC being Sata based and therefore thre is no back-compatibility with running IDE disks even though they are mounted on USB to IDE SATA Drive Adapter?
2. my second issue is with a 3rd drive, a Western Digital Caviar IDE WD400. These drives jumpers seem not to need to be set. Connected on the Sabrent unit it is recognized and seems to be initialized, but nothing seems tyo happen when i want to acces it with Mini Partition Wizard to work on it. Any suggestions here ?

I would appreciate any suggestions in simple layman terms please as my knowledge on this field is very limited.

Thank you kindly

More about : deal ide drives windows

a b $ Windows 7
a c 395 G Storage
October 24, 2011 12:59:40 PM

If I had to guess, I'd put my money on the adapter being defective.

If I had this issue, I would test in this order

1) If I know anyone with a motherboard that supports IDE drives, put the drives in there and see if they are readable or dead. A dead drive would explain your issue.

2) Try the adapter / drive pair in another system.

3) Use recovery software, starting with free data recovery from EASEUS or maybe Clonezilla, to try to scan the drives and recover files.

4) Ask for more help if none of the above work.

Do not initialize, partition, or format the drives if you want the data that is currently on them.
m
0
l
a b G Storage
October 24, 2011 1:39:16 PM

Sounds like a crappy adapter. Those USB to IDE/SATA adapters seem to be hit-and-miss in my experience.
m
0
l
a b $ Windows 7
a c 352 G Storage
October 24, 2011 3:00:23 PM

If your MB has a USB port connect HDDs one at atime to that port. Use a 80 conductor ribbon cable not the old 40 wire one. May also need to enable IDE port in bios.

If no Ide port follow WyomingKnott suggest on determining if proble is Drive related, or enclosure related.
m
0
l