Sign in with
Sign up | Sign in
Your question
Solved

Onboard sound issue

Last response: in Motherboards
Share
June 2, 2010 9:17:43 PM

I just completed my first build using an asus m4a79xtd evo. I have an odd sound issue causing two games to crash to desktop.

I am using onboard sound and updated to the latest VIA drivers. Here is what happens:

In Battlefield 2, starting a campaign, the music plays fine, but when someone starts to talk, it goes black screen, very static-y/crackling, then crashes. Similar for Red Alert 3.

I also tried using the HDMI from the graphics card, but games die in exact same spot.

COD4 plays fine for hours. All other music, sounds, etc in the system are fine.

Any suggestions would be greatly appreciated.

(Not sure if specs are required, but here they are):
CPU: X2 555 BE, unlocked to 4 cores, not oc'd
GPU: Powercolor 4850, 1GB, not oc'd
PSU: OCW Fatal1ty 550W
OS: Win 7 64-bit.

Thanks!

More about : onboard sound issue

a b V Motherboard
June 3, 2010 1:13:29 PM

If you disable the sound and run the game does it still crash?

Have you checked with the Battlefield2 knowledge base for crash to desktop fixes? Maybe there are ini settings to work around this issue.
Related resources
June 3, 2010 5:19:39 PM

mosox said:
Seems like it's a common problem of that board:

http://vip.asus.com/forum/view.aspx?board_id=1&model=M4...

LE Maybe it's better to RMA it and get a Gigabyte it looks like this mobo has some issues with W7.


Thank you for the link! It is close to my issue and likely related, however I only get a crackle sound on 2 games, then they crash.

Also, oddly, I have the same "crackle" using the video card's HDMI, as well as a discrete audio card I added later.
June 3, 2010 5:23:24 PM

canadian69 said:
If you disable the sound and run the game does it still crash?

Have you checked with the Battlefield2 knowledge base for crash to desktop fixes? Maybe there are ini settings to work around this issue.


Yep, if I disable sound in bios, it still crashes. No matter what audio input/output I use, it crashes (HDMI, discrete card, etc).

I tried a few INI setting found on BF2 support sites, but no luck. I am wondering if I am missing something I need to set in-game. Generally, I just install and play. Maybe Win7 64 is more picky?
a b V Motherboard
June 3, 2010 5:25:22 PM

You could try backing up your saved games and reinstalling B2. Or maybe there is some form of game config utility that you can run. Sounds more like an application problem.
June 3, 2010 7:57:21 PM

I enabled 2 cores on this dual core. Is it possible that the machine will run perfectly, but in these 2 games, something hits one of those unlocked cores and it is unstable, but only in those games?
a b V Motherboard
June 3, 2010 8:28:07 PM

I doubt its CPU related. Try re-installing one of the games. If that doesn't work I would start to question the audio drivers again.
June 3, 2010 8:41:36 PM

I've uninstalled both games, reinstalled, and applied all patches. I have also deleted all audio drivers and reinstalled. Ditto for the video card. The games still crash in the exact same places.

I am certainly no where close to knowledgeable on this, but am wondering how it can be audio when the games crash in the same places regardless of using onboard, discrete, or HDMI. The other kicker is the crashes still occur when audio is disabled in bios.

i fear its the mobo at worst. best case is one of the cores i enabled I should have left disabled.

Best solution

a b V Motherboard
June 3, 2010 9:11:31 PM
Share

I forgot about it crashing even when the audio was disabled. Having said that, most games dont use dual cores. Some games have ini settings that allow you to specify how many cores your processor has. You did say that the game crashes when it tries to utilize the audio and that it is only these two games that cause a problem. This suggests a software issue.

edit: is there an XP compatibility mode option for running the game? also set to run as the administrator.
June 7, 2010 2:57:31 PM

It appears it was unstable, unlocked cores. When I revert back from quad to dual, everything runs perfectly. Thanks for your many suggestions, Canadian69! I may still leave it as quad and see if I can find those INI settings.
June 7, 2010 3:02:18 PM

Best answer selected by mgkunkel.
a b Ĉ ASUS
a b V Motherboard
June 7, 2010 3:06:21 PM

You may have only one bad core, enable them in your BIOS one at a time, first nr3 and then nr4.
June 7, 2010 3:54:19 PM

Thanks mosox.

I think both cores may be a bit off. with cores 0,1,2 enabled, it plays the games fine, but when the machine sleeps, it won't come back out. Had to do a hard boot and came back to bsod. Finally fixed itself in safe mode.

Enabling cores 0,1,4 gave me the bad sound/crashing games issue, so that core is shot for sure when stressed.

I need to figure out a middle-ground, because the computer just screams w/all 4 cores just doing non-gaming tasks.
!