Harddrive appears in bios then it doesn't...then it does.. then it ..

What is happening to my hard drive?
It appears in my bios and I am able to boot into Win 7. Do what I need to do for a few hours, shut down properly.
Start it up again... hard-drive does not appear in bios... wont boot. Reboot again.. it appears... then sometimes out of the blue it freezes or locks up. I have done defragging, scandisk. Found no errors, I have used Win 7 startup recovery - and it cleared whatever issue it had and restarted. Only to later once again the problems reoccur.

I just downloaded Spinrite, and Hiren 14.

Any suggestions? Or should I just assume its a physical issue and software wont do anything. Go buy another HD. :(

XFX 770i Motherboard, a WD Blue Harddrive (sorry dont have model # at the moment.), Win 7 Ultimate.
5 answers Last reply
More about harddrive appears bios doesn then does
  1. Did you use a different power cable in it or a different power rail from your PSU? It could be that your PSU is faulty.
  2. thanks, I have tried different power cables, and sata cable connections to the MB and drive. Still the same problem happens: appears in bios, next time it doesn't. Download some diagnostics from WD. But past experience is that they just do some very limited tests. I dont hear any clicking sounds, either. So I am not sure if its a physical damage problem.
  3. Have you tried a brand new fresh Sata-3 compatible cable?

    I replace my s-ata cables 2-3 times per year, for some reason I have major issues with degradation of these s-ata cables.

    PC starts having issues, a new cable and everything is OK for another 6 months.
    Cables with locking has had no effect, and I can't see any oxides.

    Really wierd imo
  4. I will try that again, replacing the sata cables,

    ( honestly I dont know if they are Sata "3". they came with the MB and they fit both ends. worst case i assume its backwards compatible.)

    I got a bunch in a box never opened, but the problem with finding a solution is that once I think its solved... ( the problem reoccurs again.. a few days later or at random in one day.)
  5. deadfish said:
    What is happening to my hard drive?
    It appears in my bios and I am able to boot into Win 7. Do what I need to do for a few hours, shut down properly.
    Start it up again... hard-drive does not appear in bios... wont boot. Reboot again.. it appears... then sometimes out of the blue it freezes or locks up. I have done defragging, scandisk. Found no errors, I have used Win 7 startup recovery - and it cleared whatever issue it had and restarted. Only to later once again the problems reoccur.

    I just downloaded Spinrite, and Hiren 14.

    Any suggestions? Or should I just assume its a physical issue and software wont do anything. Go buy another HD. :(

    XFX 770i Motherboard, a WD Blue Harddrive (sorry dont have model # at the moment.), Win 7 Ultimate.


    I have this exact same problem :/. Been looking for months and haven't found a solution
Ask a new question

Read More

Hard Drives BIOS Storage