Sign in with
Sign up | Sign in
Your question

Memory controller or user error?

Last response: in Memory
Share
June 4, 2010 10:43:58 PM

I have had my computer for a few years now. a few months ago it started locking up seemingly randomly. I started troubleshooting and the symptoms seemed to point to the memory. I ran a memory testing bootable and sure enough it indicated the 4th slot. I pulled it and replaced it with a new module only to have the exact same results. Finding this odd I pulled all the modules and tried all combination of single and dual channel with all modules I have. No matter the combination the last module in the array always tests as bad, ei 1 module single channel = slot 1, 2 modules single channel = slot 2, 2 modules dual channel = slot 3, 4 modules dual channel = slot 4. The only difference in the different configurations is that the more modules installed the faster they fail the tests.

I have never used memory testing software before, so I dont know if these results existed before I started having problems. The results seem to be consistent in how they fail, expeted results +1 on all tests.

I have a Gigabyte S-series GA-P35-DS3P mobo, and I'm using Kingston DDR2-800 1gb unbuffered RAM. CPU Intel core2 quad 2.4ghz.

The lockup problem I have been having can happen just about any time, but occurs most frequently when I'm downloading something.
a b } Memory
June 5, 2010 5:00:44 AM

Is the ram setup properly? Your not running any crazy ram, but perhaps they are older sticks or ones that need more then 1.8? Make sure the timings and voltage are set correctly.

Lock ups can happen for more reasons then just bad ram. Its a good place to start though so see if getting good ram can fix the problem.
June 7, 2010 4:43:23 AM

the timing and voltage 'should' be at the right settings. that being said, the voltage is a bit high (1.92) but that is the lowest it will go as there are no settings that allow it to be lowered. A 2% variation in voltage shouldn't cause a problem (otherwise batteries would constantly fry stuff) but it is another indicator that somewhere there is a component that is not working as intended.

When I ran the tests on the sticks I included new stick, going through all combination of single and dual channel (yes, it did take a long time.) the new stick's results were exactly identical to the old sticks' results, in spite of being 3+ years newer.
a b } Memory
June 7, 2010 3:17:42 PM

What I was looking for were sticks that called for 2.1V, while it was only providing 1.8. Giving the sticks .3 volts less then what they want can make them error. Same if you are trying to use 4-4-4-12 timings and they call for 5-5-5-18.

Its possible the board is dead/dying. Take the sticks and put them in another computer. If they test as fine, its the board. A new board should fix the problem.
!