HDD undetectable/ hangs at BIOS POST

Hi,

One of my HDDs which is also my OS HDD have been working perfectly until two days ago. When i tried to start up my system, the system hanged after checking the RAMS at the BIOS POST. When i remove the HDD in question ( a Maxtor DiamondMax 22 500 Gig), the system is able to boot up.

Using another Hdd with another windows installed, i tried to connect the maxtor to the system through USB cable and the system is unable to detect the HDD also. The hdd still spins and i don't hear any scratching sounds.

I have quite alot of important data in the hdd that i have yet to backup and was hoping to recover those files but with most recovery programs, they require me to "select target hdd" which is impossible because the hdd is undetectable in the 1st place. I tried using seatools dos mode to diagnose the drive but as the HDD cause the system to hang at POST, i cannot boot up the program. If i unplug the hdd, boot up seatools and replug the hdd, seatools does not detect it.

Is there anyway i can recover the data/make the hdd detectable without sending it to specialists (very costly) ? Or is the hdd just... dead?

Thanks
4 answers Last reply
More about undetectable hangs bios post
  1. Try installing the OS in another drive and then boot up and connect the problematic HDD.
  2. hell_storm2004 said:
    Try installing the OS in another drive and then boot up and connect the problematic HDD.


    I have already tried that. It was not detected either through usb or if i connected to mobo once i got into windows.
  3. It looks like the controller card on the drive is the problem. I say that because the BIOS does not see the drive. That is a function of the controller card, not the mechanical platter assembly.

    You may be able to resurrect the drive by replacing the controller card with another one from an identical (same model numbers) drive.
  4. Some firmware versions (eg MX15) are affected by Seagate's 7200.11 BSY bug. This bug produces the symptoms you describe.

    Seagate offers free data recovery for drives so affected. Otherwise there is an easy DIY solution.

    Seagate 7200.11 BSY bug and 0 LBA fix:
    http://sites.google.com/site/seagatefix/
    http://www.msfn.org/board/index.php?showtopic=128807
    http://www.overclock.net/hard-drives-storage/457286-seagate-bricked-firmware-drive-fix-pics.html
    http://forums.seagate.com/t5/Barracuda-XT-Barracuda-Barracuda/SOLUTION-FOR-7200-11-SERIES-MAXTOR-SEAGATE-BRICKED-DRIVES/td-p/26009/page/1

    See also http://www.tomshardware.com/forum/266011-32-maxtor-diamond-stm3750330as-detecting

    BTW, a straight board swap won't work, not even if the drives are "identical". This is because each board stores unique, drive specific "adaptive" data in an 8-pin serial flash memory chip. This chip, or its contents, needs to be transferred to the donor.
Ask a new question

Read More

Hard Drives BIOS Storage