Solved

SSD Not detected in IDE or AHCI after updating firmware

After putting together the build listed below and installing the OS to the SSD, I was running great for a few months. Then the OS started freezing up. Reinstalling Windows did not help at all, I submitted a trouble ticket to OCZ thinking it was a problem with the SSD. They suggested clear the CMOS, switch to AHCI in the BIOS and update the firmware following the steps in this link.

Unfortunately the drive was not detected by their version of Linux Live in order to do the firmware update while in AHCI, so I switched back to IDE and did the update. Afterwards the drive was not detected by the BIOS or their Linux Live in IDE or AHCI. I even tried booting into an Ubuntu Live CD session and again it was not detected in either mode (IDE or AHCI). I just want to format the drive, set it to AHCI and reinstall Windows so I can get this tower running again...Thanks in advance for the help guys.

Antec BP550 Plus 550W Continuous Power ATX12V V2.2 80 PLUS Certified Modular Active PFC Power Supply
G.SKILL Ripjaws Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1600
MSI N560GTX-TI Twin Frozr II/OC GeForce GTX 560 Ti
MSI P67A-G45 (B3) LGA 1155 Intel P67 SATA 6Gb/s USB 3.0 ATX Intel Motherboard
Intel Core i5-2500K Sandy Bridge 3.3GHz
OCZ Agility 2 90GB SATA II MLC (SSD)
Windows 7 Professional
(Other parts are not listed obviously)
7 answers Last reply Best Answer
More about detected ahci updating firmware
  1. Can you see the SSD in another computer?

    If not maybe your SSD is toast, or maybe has a bad firmware update now.
  2. Best answer
    I see lots of complaining about this, with a number of SSD manufactures. Apparently updating the firmware can render an SSD useless for a number of reasons, just google around, what happened to you is not that uncommon. The one common cure though is you have to RMA the drive, found very few instances anyone was able to recover the drive once they toasted it.
  3. Through trial, error, and google I solved it. I listed the steps that I used for it in another thread for another poster having the exact same issue.

    http://www.tomshardware.com/forum/275581-32-vertex-hangup#t1884740
  4. Wow nice one gqsmooth.

    Glad you got it going.
  5. Yeah, great going, and and thank you for coming back here and letting us know the solution. We appreciate it!
  6. Best answer selected by gqsmooth.
  7. My brand new SSD (Ocz,SATA3) is not recognized in BIOS.My motherboard have SATA2, newest BIOS, set AHCI , like this http://images.anandtech.com/doci/5714/Gigabyte%20BIOS%207%20Integrated%20Peripherals_575px.JPG .When BIOS search disc I have info http://i1212.photobucket.com/albums/cc456/gre_gre/nowy%20bios%20f8/ahci1.jpg and after while info: "not any attached..."
    If I turned ON AHCI in BIOS (if disc is good) must be visible in BIOS??
Ask a new question

Read More

SSD Firmware Storage