Sign in with
Sign up | Sign in
Your question

Radeon 4870 possible power issue?

Last response: in Graphics & Displays
Share
December 2, 2009 10:15:15 PM

So I've had this problem for awhile now... my computer will boot up fine until I install my radeon drivers, then it reboots and i just have artifacts all over the boot screen and windows. I upgraded to windows 7 recently and the artifacts are no longer in my bios screen, but appear once i get into windows. I've tried all sorts of drivers, and none have fixed it. I have also reinstalled windows countless times. Now here's the catch... if i turn my computer completely off, unplug it and press the power button to drain the power from the computer, then start it up, it will boot up just fine and i can use my graphics card. This is also my 2nd card I've got and they work fine in other PCs. I'm currently ordering new RAM and mobo cause they needed upgraded but my current setup is:

Biostar A770 A2+ Mobo
1x4 Corsair DDR2 800
SAPPHIRE Radeon HD 4870
Phenom 9600 quad core
Antec SmartPower 2.0 500W ATX12V SLI Ready
December 3, 2009 9:41:28 AM

Have you checked the motherboard manufacturer’s website for the latest updates for your BIOS? These companies periodically update to accommodate newer cards. Send them an email with a description of the problem and they may even send you a more recent BIOS version than what they have on the website (they did it for me!). BE CAREFUL WITH CHANGING YOUR BIOS. If you haven’t done it before do your research first, it can ruin your computer if you get it wrong!
m
0
l
December 3, 2009 11:08:24 AM

If you are going to update your BIOS, be very careful. Follow the manufacturer's instructions exactly. Do not update inside Windows.

And because I do not have a UPS, I always update ("flash") the BIOS late at night. The power grid seems a little more stable.
m
0
l
!